Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS

Betrifft: SVERWEIS von: Josef
Geschrieben am: 14.09.2004 10:48:38

hallo!

warum trägt SVERWEIS einen Wert in eine Zelle, obwohl das Suchkriterium nicht exakt im Bereich vorhanden ist.
Range(Cells(1, Sp), Cells(anzZeilen, Sp)).Select
Selection.FormulaLocal = "=SVERWEIS(G1;Tabelle1!$A$1:D201;3)"
für G1 stehen
001-29
001-30
001-35
...
Wenn nun in meinem Bereich kein 001-35 vorhanden ist, darf es doch nicht den Wert für 001-30 einsetzen.

Josef

  


Betrifft: AW: SVERWEIS von: Felix
Geschrieben am: 14.09.2004 10:51:44

Hallo,

Sverweis hat noch einen 4. Parameter:
Probiere mal:

Selection.FormulaLocal = "=SVERWEIS(G1;Tabelle1!$A$1:D201;3;FALSCH)"

Gruß,
Felix


  


Betrifft: AW: SVERWEIS von: Mac4
Geschrieben am: 14.09.2004 10:53:13

Hallo Josef,

so sollte es gehen:

Selection.FormulaLocal = "=SVERWEIS(G1;Tabelle1!$A$1:D201;3;0)"

Marc


  


Betrifft: AW: SVERWEIS von: Josef
Geschrieben am: 14.09.2004 11:15:07

Danke!


 

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS"