Microsoft Excel

Herbers Excel/VBA-Archiv

Leere Zelle ohne Text erkennen

Betrifft: Leere Zelle ohne Text erkennen von: Ruwer
Geschrieben am: 15.09.2004 11:50:50

Hallo,
wer kann mir helfen?

Ich führe eine Matrixberechnung mit folgender Formel durch:

=SVERWEIS(X26;C2:E7;3) (z.B. in Zelle F26)

Zusätzlich will ich eine leere Zelle (z.B. B26) auf Texteintrag erkennen und dann den Wert "0", sonst den Ursprungswert in Zelle F26 anzeigen.

Also in Abhängigkeit Text vorhanden oder nicht vorhanden.
Wenn Text vorhanden, dann Wert berechnen.
Wenn Text nicht vorhanden, den Wert "0" in Zelle F26 anzeigen.

  


Betrifft: AW: =WENN(ISTTEXT(B26);...;"0") o.T. von: FP
Geschrieben am: 15.09.2004 11:55:47

.


  


Betrifft: AW: =WENN(ISTTEXT(B26);...;"0") o.T. von: Ruwer
Geschrieben am: 15.09.2004 12:16:57

Hallo FP,

dein Text in der Mail ist nicht vorhanden. Könntest du noch einmal antworten


  


Betrifft: Hallo FP von: ruwer
Geschrieben am: 15.09.2004 12:45:23

Hallo FP,

die Formel sieht jetzt so aus:

=SVERWEIS(X26;C2:E7;3)=WENN(ISTTEXT(B26);;0)o.T.

Allerdings erscheint nur die Meldung "Falsch". Auch wenn ein Text eingetragen wird.
Wäre dir für Hilfe dankbar


  


Betrifft: AW: =WENN(T(B26)<>"";SVERWEIS(X26;C2:E7;3;0);0) von: FP
Geschrieben am: 15.09.2004 20:46:04

Hallo ruwer,

probier mal das: Du wolltest doch, dass Deine SVERWEIS()-Formel nur dann zur Anwendung kommt, wenn B26 Text enthält,oder?

Mit der Bedingung T(B26)<>"" wird auch eine Zelle, die nur "scheinbar" leer ist (d.h. sie enthält "") als NICHT TEXT betrachtet.

ISTTEXT würde das allerdings als Text ansehen!

Servus aus dem Salzkammergut
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "Leere Zelle ohne Text erkennen"