Microsoft Excel

Herbers Excel/VBA-Archiv

Tabellenproblem

Betrifft: Tabellenproblem von: Sebastian
Geschrieben am: 15.09.2004 15:40:39

Hallo Excel-Profis,
Ich habe zwei Probleme mit meinen Tabellen. Zum besseren Verständnis habe ich sie auch hochgeladen.

https://www.herber.de/bbs/user/10910.xls

Auf Blatt 1 stehen die Ausgangsdaten und es finden dort Berechnungen der Nettoarbeitstage und der Kategorie/Typ statt. In der zweiten Tabelle werden die Durchschnitsttage errechnet in den einzelnen Kategorien mit den Werten aus der ersten Tabelle.
Wenn jetzt in der ersten Tabelle ein Auftrag doppelt vorkommt und ich die ganze Zeile markiere und entferne, wird mir in der zweiten Tabelle ein Fehler angezeigt. Geht es vielleicht, dass sich die zweite Tabelle automatisch aktualisiert? Wenn ich z.B. Zeile 12 lösche, rückt ja automatisch Zeile 13 an die Stelle der 12.
Tabelle 2 müsste also Daten haben und keinen Fehler anzeigen.
Ein weiteres Problem ist, dass mir die doppelten Nummern nicht mehr angezeigt werden, wenn die Nummer einen Buchstaben enthält. Wie kann ich das umgehen?
Vielen Dank schon mal im voraus.

  


Betrifft: AW: Tabellenproblem von: Elevbe
Geschrieben am: 16.09.2004 02:10:07

Hallo Sebastian,

folgende Lösungen hätt ich für dich:
verwende in der Tabelle2 anstelle von Zellbezügen (zB Tabelle1!N7) die Index-Funktion wie folgt:
=WENN(INDEX(Hoja1!$N:$N;ZEILE(19:19)-12)=Hoja2!B$17;INDEX(Hoja1!$M:$M;ZEILE(19:19)-12);"")
wobei die Funktion Index in jene Zeile der Spalten N bzw M hüpft, welche durch Zeile(19:19)-12 angegeben werden - also hier in Zeile 7
19 steht für die Zeile der Tabelle2 in der diese Wennformel selbst steht...
dann klappts mit dem Löschen von Zeilen wunderbar!

Problem Nr 2: die Doppelten
die von dir verwendete Summenfunktion kann natürlich nicht mit Buchstaben zurechtkommen. Nimm statt dessen mal meinem über alles geliebten SVERWEIS
=WENN(ISTNV(SVERWEIS(E10;E$7:E9;1;FALSCH));"";"doppelt")
(hier am Beispiel der Zelle A10)
ich lasse den SVERWEIS in den Zellen oberhalb in Spalte E suchen - kam die Zahl noch nie vor kommt als Ergebnis #NV raus, was wiederum durch die ISTNV-Funktion abgefangen und im WENN ausgewertet wird. Kommt kein NV raus dann hat der SVERWEIS die Zahl ein weiteres Mal gefunden und folglich ist sie doppelt.