Microsoft Excel

Herbers Excel/VBA-Archiv

Sortieren und Selektieren

Betrifft: Sortieren und Selektieren von: Onkel Bob
Geschrieben am: 15.09.2004 17:42:21

Hallo,
ich möchte das Rad nicht neu erfinden und denke, dass das Problem bereits gelöst ist:
Ich habe in Spalte A verschiedene Kunden, die jeweils verschiedene Beträge (Spalte B) eingezahlt haben. Nun möchte ich, dass in Spalte C die jeweiligen Kunden aufgelistet werden (quasi panaschiert) und in Spalte D die entsprechenden (kumulierten) Werte errechnet stehen.

Vielen Dank für Eure Hilfe!!!


A_________B_______________C____________D

Kunde 3____50,00 EUR_______Kunde 1______300,00 EUR
Kunde 1____100,00 EUR______Kunde 2______300,00 EUR
Kunde 2____250,00 EUR______Kunde 3______150,00 EUR
Kunde 1____200,00 EUR______Kunde 4______20,00 EUR
Kunde 3____100,00 EUR
Kunde 2____50,00 EUR
Kunde 4____20,00 EUR

  


Betrifft: AW: Sortieren und Selektieren von: th.heinrich
Geschrieben am: 15.09.2004 18:58:48

hallo Robert ??,

bitte mit realvornamen posten. zur loesung.

in A2:A8 stehen die kunden. in B2:B8 die betraege. in C2:C5 Kunde 1 bis Kunde 4.

nun in D2 =SUMMEWENN($A$2:$B$8;$C$2:$C$5;$B$2) und bis D5 kopieren.

das sollte es gewesen sein.

gruss thomas


  


Betrifft: AW: Sortieren und Selektieren von: Bernd
Geschrieben am: 16.09.2004 09:09:42

Hallo Thomas,
herzlichen Dank für Deine Hilfe, das Problem ist aber, dass ich eine große Anzahl von Kunden habe (die ich aber vorher noch nicht kenne), so dass ein fester Eintrag der Kunden in der Tabelle nicht möglich ist. Ich möchte ja gerade mit einer Formel alle gleiche Kunden (die wahllos in der Liste stehen) auflisten und die einzelnen Beträge als Summe zusammenfassen: z.B. kommt der Kunde A in einer Liste von ca. 100 Positionen fünf mal vor und ich möchte dass er in einer Extraspalte einmal vorkommt mit einer Gesamtsumme.
Tut mir leid, wenn ich mich etwas missverständlich ausgedrückt habe.

Gruß Bernd


  


Betrifft: kennst du deine kd? von: r.sch.
Geschrieben am: 16.09.2004 13:42:09

Hi Bernd,

?? ...habe (die ich aber vorher noch nicht kenne), so ...??
(das verstehe ich nun nicht, wie kannst du Unbekannten Beträge zuweisen,) über die du dann mit genau DER Formel die zugehörigen Summen ermitteln kannst!!

Gruß
Reinhard


  


Betrifft: AW: kennst du deine kd? von: Bernd
Geschrieben am: 16.09.2004 14:16:02

Hallo Reinhard,
tja alles vielleicht etwas ungeschickt formuliert :-).

Die "Kundenliste" ist variabel bzw. dynamisch (also nicht aus einer anderen "festen" Tabelle heraus, sondern die Kunden werden jedesmal neu eingetragen).

Aus dieser Tabelle soll jetzt eine weitere entstehen, bei der - falls der Kunde mehrmals in der Liste auftaucht - nur einmal mit der jeweiligen Gesamtsumme erscheint (die anderen Kunden, die nur einmal auf der ersten Liste sind, sollen natürlich auch auf der zweiten Liste wieder auftauchen.

Liste 1 Liste 2
Kunde Zahlungen Kunde Zahlungen
Kunde A 100,00 EUR Kunde A 180,00 EUR
Kunde B 200,00 EUR Kunde B 200,00 EUR
Kunde C 300,00 EUR Kunde C 400,00 EUR
Kunde A 50,00 EUR
Kunde A 30,00 EUR
Kunde C 100,00 EUR

Ich hoffe ich konnte wieder etwas Licht ins Dunkel bringen!

Gruß Bernd


  


Betrifft: AW: Sortieren und Selektieren von: th.heinrich
Geschrieben am: 16.09.2004 20:48:55

guten abend Bernd,

habe nun ziemlich lange rumgebastelt, aber bin einfach zu bloed um die doppelten kundennamen zu eliminieren.

als alternative biete ich an: in A1 steht kunde in A2:A die kunden bunt gemischt.
in B1 steht betrag in B2:B eben die betraege.

in C1 schreibst Du die FORMEL =TEILERGEBNIS(9;B:B), dann die SPALTE A mittels AUTOFILTER filtern. die FORMEL funzzt auch bei ausgeblendeter SPALTE B.

dabei kannst Du leider immer nach einem kunden auswerten :-(

gruss thomas


  


Betrifft: AW: Sortieren und Selektieren von: Bernd
Geschrieben am: 17.09.2004 09:16:48

Hallo Thomas,
herzlichen Dank, dass Du Dir so viel Mühe gibst mir zu helfen. Das Problem bei Deiner Lösung ist allerdings, dass die Tabellen in einem festen "Formblatt" eingefügt sind und ich diese meinen Kolleginnen und Kollegen zur Verfügung stellen und diese Berechnung so komfortabel wie möglich gestalten wollte.

Ich habe es auch schon mit einem Zwischenergebnis versucht die doppelten anzuzeigen und dann mit der Formel ={=WENN(ZEILE(A1)>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE(A1))))}= (siehe http://www.excelformeln.de/formeln.html?welcher=43) eine weiter Liste ohne Leerzeilen zu erstellen, hat aber nicht funktioniert, da ich in der Zwischentabelle in jeder Zeile ja eine Formel hinterlegen muss, damit es mir die doppelten anzeigt und die anderen nicht und somit war ja jede Zelle mit einem "Wert" hinterlegt.

Ich denke ohne ein spezielles Makro funktioniert es nicht ( - und da habe ich nicht so viel Ahnung).

Gruß Bernd


  


Betrifft: AW: Sortieren und Selektieren von: th.heinrich
Geschrieben am: 17.09.2004 19:05:28

hallo Bernd,

falls Du es noch lesen solltest.

wenn man die threads verfolgt sind viele dabei aus denen z.b. auch ich etwas lernen kann,
aber bei dieser FORMEL ist bei mir schicht im schacht.

eroeffne einen neuen thread, basierend auf dieser FORMEL und lade evtl. eine kleine beispieltabel ind Forum.

viel erfolg wuenscht thomas


  


Betrifft: AW: Sortieren und Selektieren von: r.sch.
Geschrieben am: 15.09.2004 18:59:37

Hi Onkel,

wie wär's mit summewenn(Bereich;Kriterium;Summierbereich)!?

Gruß
Reinhard


  


Betrifft: AW: Sortieren und Selektieren von: Leonie Scane
Geschrieben am: 17.09.2004 21:36:50

Hi,

schau dir doch mal meinen dilettantischen (?) Vorschlag unter https://www.herber.de/bbs/user/11024.xls
an; zwar musst du in Spalte C (in meinem File Spalte D) dann immer noch einen neu hinzugekommenen Kunden ergänzen und die Formel in Spalte E anpassen, vielleicht hilft's, wenn denn niemand in VBA-Code "übersetzen" kann...

Gruss,
Leonie


  


Betrifft: AW: Sortieren und Selektieren von: r.sch.
Geschrieben am: 18.09.2004 15:49:02

Hi,

wenn ihr, wollt auch so:

in A die Namen (hier bis Zeile 100), dann etwas Recherche, z.B. hier http://www.excelformeln.de/formeln.html?welcher=194

mit der ArrayFormel die doppelten ausfiltern und dann nur noch Summewenn

Gruß
Reinhard


https://www.herber.de/bbs/user/11040.xls


 

Beiträge aus den Excel-Beispielen zum Thema "Sortieren und Selektieren"