Microsoft Excel

Herbers Excel/VBA-Archiv

WERT! Fehler umgehen ?

Betrifft: WERT! Fehler umgehen ? von: Fred
Geschrieben am: 16.09.2004 12:22:23

Hallo, habe folgene Formel, nur wenn keine Einträge in den Zellen sind, kommt
der WERTE! Fehler.

=WENN(ODER(C4="U";C4="K";C4="Fe";C4="SU");Stammdaten!$C$5;WENN(G4>0;E4-D4-G4;E4-D4-F4))


Problem: Die Zeiten in Stammdaten!C5 sind in Dezimal, und die Zeiten in den
Zellen E4,D4,G4 u. F4 sind im Format [h]:mm.
Die Ausgabe (Summe) in Zelle H4 soll in Dezimal erfolgen.

Wie muss diese Formel aussehen ?


Gruß
Fred

  


Betrifft: AW: WERT! Fehler umgehen ? von: Holger Levetzow
Geschrieben am: 16.09.2004 12:30:00

Hallo Fred,

der Fehler scheint in D4/E4/F4/G4 zu stecken. Excel kann nicht rechnen. Steckt evtl. irgendwo ein Text drin?

Die Formatierung ansonsten ist egal. Brauchst Du Dezimalzahlen, multipliziere das Ergebnis mit 24, aber erstmal muss Excel rechnen können.

Holger


  


Betrifft: AW: WERT! Fehler umgehen ? von: Fre
Geschrieben am: 16.09.2004 12:52:08

Hallo Holger, den ersten teil habe ich hinbekommen, aber mit der Umrechnung in Dezimal
klappt es nicht.

WENN(H4>0;F4-E4-H4;F4-E4-G4)~f~

Diese ganzen Zellen sind im Format [h]:mm, nun soll die Ausgabe in Dezimal in Zelle I4
erfolgen.

Wie muss die Formel aussehen ?

~f~WENN(H4>0;F4-E4-H4*24;F4-E4-G4*24) funktioniert nicht !

Gruß
Fred


  


Betrifft: AW: WERT! Fehler umgehen ? von: Holger Levetzow
Geschrieben am: 16.09.2004 13:35:59

Hallo Fred,

Klammerrechnung :-). Versuche

WENN(H4>0;F4-E4-H4;F4-E4-G4)*24 und formatiere auf Zahl

Holger


  


Betrifft: Das klappt ! von: Fred
Geschrieben am: 16.09.2004 13:44:16

Danke dir das war`s !


Gruß
Fred


 

Beiträge aus den Excel-Beispielen zum Thema "WERT! Fehler umgehen ?"