Microsoft Excel

Herbers Excel/VBA-Archiv

Datum nochmal!

Betrifft: Datum nochmal! von: Thommy
Geschrieben am: 16.09.2004 16:45:18

Also folgendes Problem!

Ich habe in einer Tabelle 1 lauter Daten stehen!
Nun habe ich auf Tabelle 2 mir ein Jahr (mit Heute(), Heute()-365 usw) in Spalte A schreiben lassen. Nun möchte ich auf Tabelle 2 mir die Summe aller Beträge des in Spalte A stehenden Jahres anzeigen.
Das Datum steht auf Tabelle 1 in Spalte O (tt.mm.jjjj uhrzeit) und der Nettobetrag in Spalte R!
Wie funktioniert das?
Ich habs schon mit

=SUMMEWENN(Tabelle1!O:O;">=1-"&A3;Tabelle1!R:R)-SUMMEWENN(Tabelle1!O:O;">=1-"&A3+1;Tabelle1!R:R)

probiert aber da kommt immer 0 raus! Das kann aber nicht sein!!

A3 = die Zeile in der das Jahr steht!

  


Betrifft: AW: Datum nochmal! von: Elevbe
Geschrieben am: 16.09.2004 17:03:08

Der Ausdruck ">=1-"&A3 scheint mir das Übel zu sein.
versuch mal was in der Art ">="&Text(A3;"TT.MM.JJJJ)

was das 1- im Ausdruck bedeutet ist mir unklar (und sowieso hier fehl am Platz vermut ich)


  


Betrifft: AW: Datum nochmal! von: Thommy
Geschrieben am: 16.09.2004 17:17:36

Also hier mal meine Tabelle:
https://www.herber.de/bbs/user/10973.xls

In die gelben Teile auf Tabelle 2 möchte ich dass die Daten, die von Tabelle 1 geholt werden eingetragen werden!
Und zwar erstens nach Jahren sortiert und dann die Summe aller Beträge in diesem Jahr, dann die Summe aller Beträge im Monat eines bestimmten Jahres und dann noch pro Quartal des Jahres!! Wie mach ich das am besten?? Welche Formeln brauch ich da??


  


Betrifft: AW: Datum nochmal! von: Elevbe
Geschrieben am: 16.09.2004 17:57:32

die Pivot machts wie immer gut...

https://www.herber.de/bbs/user/10979.xls

Achtung: in der Datentabelle darfs keine Leerspalten geben
weil du das Datum in der Auswertung 2 mal brauchst (als Jahr und als Monat zB) reicht das Gruppieren allein in der Pivottabelle nicht aus. Daher hab ich 2 Spalten Jahr und Monat in der Datentabelle zusätzlich eingefügt...