Microsoft Excel

Herbers Excel/VBA-Archiv

Suchen und addieren

Betrifft: Suchen und addieren von: Stephan
Geschrieben am: 16.09.2004 20:54:05

Hallo,

ich habe in Spalte A 7-stellige nummern und in Spalte G Werte dazu. Wie kann ich alle Werte, deren Nummer in Spalte A mit 48 anfangen in Zelle C61 zusammenaddieren und alle anderen Werte in Zelle C60? Die Werte und Nummern fangen ab Zeile 7 an.

Vielen Dank

  


Betrifft: AW: Suchen und addieren von: Matthias G
Geschrieben am: 16.09.2004 21:13:29

Hallo Stephan,

mir fallen da nur zwei Hilfsspalten ein.

z.B.
in Zelle H7: =WENN(LINKS(A7;2)="48";G7;"")
in Zelle I7: =WENN(LINKS(A7;2)="48";"";G7)

und das Ganze runterkopieren.
Danach die Spalten einzeln addieren.

Gruß Matthias


  


Betrifft: AW: Suchen und addieren von: Stephan
Geschrieben am: 16.09.2004 21:24:40

Hi,

danke fuer eure antworten. Das file besteht aber aus 23 Spalten und ich wuerde es gerne ohne einfuegen haben!!


  


Betrifft: Zusatz von: Stephan
Geschrieben am: 16.09.2004 22:20:55

es waere super, wenn jemand ein makro dafuer haette, da ich das ganze bei 4 Dateien machen muss, die jeweils 70 Arbeitsmappen haben!!!

Danke


  


Betrifft: =SUMMENPRODUKT((LINKS(A7:A1000;2)="48")*G7:G1000) von: WF
Geschrieben am: 16.09.2004 21:18:02

und den Rest dann eben mit =SUMME(G7:G1000)-C61

Salut WF


http://www.excelformeln.de/
die ultimative Formelseite


  


Betrifft: Alle Achtung... von: Kurt
Geschrieben am: 16.09.2004 21:40:54

...du bist ja fast schon so gut wie Boris!

Kurt


  


Betrifft: Und mal wieder alternativ mit SUMMEWENN ;-) von: Boris
Geschrieben am: 16.09.2004 22:26:15

Hi Walter,

=SUMME(SUMMEWENN(A:A;">="&{48.49}&"00000";G:G)*{1.-1})

Grüße Boris

http://www.excelformeln.de - die ultimative Formelseite


  


Betrifft: Fehler von: Stephan
Geschrieben am: 16.09.2004 22:41:03

Danke Boris, leider gibt mir excel einen Fehler und zwar das rechte A von A:A!
Hast du vielleicht eine Loesung!

stephan


  


Betrifft: AW: Fehler - kann nicht sein... von: Boris
Geschrieben am: 16.09.2004 22:46:40

Hi Stephan,

denn ich hab die Formel so aus meiner Excelbearbeitungsleiste rauskopiert - und bis dahin hat sie einwandfrei funktioniert ;-)
Kann sich also imho nur um nen Schreibfehler deinerseits handeln.

Grüße Boris


  


Betrifft: hätte mich auch gewundert... o.T. von: barni
Geschrieben am: 16.09.2004 22:48:20




  


Betrifft: AW: Fehler - kann nicht sein... von: Stephan
Geschrieben am: 16.09.2004 22:48:33

Hi Boris,

habe sie aber so reinkopiert!!!


  


Betrifft: Dann lad deine Mappe mal hoch... von: Boris
Geschrieben am: 16.09.2004 22:52:05

Hi Stephan,

...denn bei mir funktioniert das einwandfrei.

Grüße Boris


  


Betrifft: AW: Dann lad deine Mappe mal hoch... von: Stephan
Geschrieben am: 17.09.2004 14:44:02

Hi Boris,

anbei eine Beispieldatei!
https://www.herber.de/bbs/user/11012.xls


Danke


  


Betrifft: Is ja nu auch kein Wunder... von: Boris
Geschrieben am: 17.09.2004 22:23:11

Hi Stephan,

...dass es nicht funktioniert...
2 Dinge:
Die Formel
=SUMME(SUMMEWENN(A:A;">="&{48.49}&"00000";G:G)*{1.-1})
summiert Spalte G - und da sind alle Einträge NULL.

Weiterhin sind deine Zahlen in Spalte A keine Zahlen sondern Text mit einem vorangestellten Hochkomma.
Entweder du entfernst diese Hochkommata oder du gibst es in der Formel mit vor.
Zudem hab ich die Formel jetzt mal auf Spalte F als Summenspalte angewandt (und das Hochkomma mit eingebaut):

=SUMME(SUMMEWENN(A:A;">='"&{48.49}&"00000";F:F)*{1.-1})

Aber syntaktisch war das alles von vornherein korrekt.

Grüße Boris

http://www.excelformeln.de - die ultimative Formelseite


 

Beiträge aus den Excel-Beispielen zum Thema "Suchen und addieren"