Microsoft Excel

Herbers Excel/VBA-Archiv

umschalten tabellenblattberechnung

Betrifft: umschalten tabellenblattberechnung von: uwe
Geschrieben am: 18.09.2004 13:13:25

mahlzeit die damen und herren,

folgende problemstellung mal so dargestellt.

habe eine datei mit 3 tabellenblättern. nennen wir sie mal apfel, birne und kirsche.

ich möchte jetzt in apfel in a1 alternativ ja oder nein eingeben damit er bei ja
ja z.b. die daten aus birne anzeigt und rechnet und bei nein eben kirsche...
auf deutsch möchte ich also frei wählen können aus welchem blatt in apfel gerechnet wird.

alles banane ????

als belohnung gibt es ne himbeere.

danke

gruß

uwe

  


Betrifft: AW: umschalten tabellenblattberechnung von: Reinhard
Geschrieben am: 18.09.2004 13:23:10

Hi Uwe,
Beispiel in Apfel:
A1: ja (bzw. nein)
B1: =WENN(A1="ja";2*Birne!A1;WENN(A1="nein";2*Kirsche!A1;"in A1 ja oder nein eingeben"))
KernloseGrüße *g
Reinard


  


Betrifft: AW: umschalten tabellenblattberechnung von: uwe
Geschrieben am: 18.09.2004 13:39:02

hallo reinhard,

so wie ich deine formle verstehe ohne es kurz probiert zu haben bezieht sich das dann auf die ergebnisse in feld b1. ich möchte aber, daß alle berechnungen in apfel dann umgeswitcht werden. ich habe eine datei geschrieben ( apfel ) die sich auf ca. 200 berechnungen in birne bezieht. ich kann aber manche dinge nicht berechnen ohnen eienen ausschluß von manchen faktoren zu machen. ich muß also jetzt birne praktisch neu kopieren in kirsche und dort neue konstanten definieren. dafür muß aber in apfel eben umgeschaltet werden. ich könnte natürlich auiuch apfel neu kopieren und dann auf birne beziehen lassen. aber das ist mir zu umständlich... idee ???


  


Betrifft: AW: umschalten tabellenblattberechnung von: Reinhard
Geschrieben am: 18.09.2004 13:57:15

Hi Uwe,
kannste mal Butter zu den Fischen äh, Sahne zu dem Obstsalat geben? *g
Also eine Datei hochladen, sonst müsesen wir in einem langen Hin und Her Satz für Satz für mich mystische Satzteile wie "ich kann aber manche dinge nicht berechnen ohnen einen ausschluß von manchen faktoren zu machen." in meine Logik übersetzen :-)
Gruß
Reinhard


  


Betrifft: umschalten Tabellenblattberechnung von: Beate Schmitz
Geschrieben am: 18.09.2004 16:11:32

Hallo Uwe,

ich habe dir mal eine Beispieldatei geschrieben, wie ich es verstehe. Das Makro steht im Codefenster der Tabelle "Apfel" und im Blatt "Apfel" musst du in Zelle A1 über Dropdown auswählen, aus welcher Tabelle du einen bestimmten Bereich (Werte, Formeln und Formate) einfügen möchtest. Ebenfalls kannst du in A1 die eingefügten Inhalte löschen. Die Bereiche musst du dir nur im Makro anpassen.

https://www.herber.de/bbs/user/11042.xls

Gruß,
Beate


 

Beiträge aus den Excel-Beispielen zum Thema "umschalten tabellenblattberechnung"