Microsoft Excel

Herbers Excel/VBA-Archiv

Datum

Betrifft: Datum von: Markus
Geschrieben am: 18.09.2004 14:41:04

Hallo!

Ich habe eine Tabelle in der sind einige Datumseingaben, über ein ganzes Jahr verteilt, enthalten. Ich möchte diese auswerten und suche nun eine Möglichkeit um mir ausgeben zu lassen, wie viele Eingaben in einem Monat gemacht wurden. Ein Beispiel:






25.09.04 Eintrag 1
30.09.04 Eintrag 2
10.10.04 Eintrag 3


Ich möchte die Anzahl der Einträge im September bzw. auch in den anderen Monaten...

Kann mir da jemand weiter helfen, mir fehlt es an einem vernünftigen Ansatz....

Danke!

Markus
  


Betrifft: AW: Datum von: Heinz Ulm
Geschrieben am: 18.09.2004 15:48:30

Hallo Markus,

mal als AAnsatz mit einer Hilfsspalte:

Tabelle2
 ABCDE
1     
2     
310.09.2004September September6
414.09.2004September Oktober7
518.09.2004September November8
622.09.2004September Dezember2
726.09.2004September   
830.09.2004September   
904.10.2004Oktober   
1008.10.2004Oktober   
1112.10.2004Oktober   
1216.10.2004Oktober   
1320.10.2004Oktober   
1424.10.2004Oktober   
1528.10.2004Oktober   
1601.11.2004November   
1705.11.2004November   
1809.11.2004November   
1913.11.2004November   
2017.11.2004November   
2121.11.2004November   
2225.11.2004November   
2329.11.2004November   
2403.12.2004Dezember   
2507.12.2004Dezember   
Formeln der Tabelle
B3 : =TEXT(A3;"MMMM")
E3 : =ZÄHLENWENN(B:B;D3)
A4 : =A3+4
B4 : =TEXT(A4;"MMMM")
E4 : =ZÄHLENWENN(B:B;D4)
A5 : =A4+4
B5 : =TEXT(A5;"MMMM")
E5 : =ZÄHLENWENN(B:B;D5)
A6 : =A5+4
B6 : =TEXT(A6;"MMMM")
E6 : =ZÄHLENWENN(B:B;D6)
A7 : =A6+4
B7 : =TEXT(A7;"MMMM")
A8 : =A7+4
B8 : =TEXT(A8;"MMMM")
A9 : =A8+4
B9 : =TEXT(A9;"MMMM")
A10 : =A9+4
B10 : =TEXT(A10;"MMMM")
A11 : =A10+4
B11 : =TEXT(A11;"MMMM")
A12 : =A11+4
B12 : =TEXT(A12;"MMMM")
A13 : =A12+4
B13 : =TEXT(A13;"MMMM")
A14 : =A13+4
B14 : =TEXT(A14;"MMMM")
A15 : =A14+4
B15 : =TEXT(A15;"MMMM")
A16 : =A15+4
B16 : =TEXT(A16;"MMMM")
A17 : =A16+4
B17 : =TEXT(A17;"MMMM")
A18 : =A17+4
B18 : =TEXT(A18;"MMMM")
A19 : =A18+4
B19 : =TEXT(A19;"MMMM")
A20 : =A19+4
B20 : =TEXT(A20;"MMMM")
A21 : =A20+4
B21 : =TEXT(A21;"MMMM")
A22 : =A21+4
B22 : =TEXT(A22;"MMMM")
A23 : =A22+4
B23 : =TEXT(A23;"MMMM")
A24 : =A23+4
B24 : =TEXT(A24;"MMMM")
A25 : =A24+4
B25 : =TEXT(A25;"MMMM")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Gruß Heinz


  


Betrifft: AW: Datum von: Markus
Geschrieben am: 18.09.2004 18:55:22

Danke, habe es ausprobiert es funktioniert.

ich hatte mir auch schon was mit ner hilsspalte ausgedacht, deine lösung ist allerdings eleganter!

Gruß

Markus


  


Betrifft: AW: Datum von: Heinz Ulm
Geschrieben am: 18.09.2004 19:15:33

Hallo Markus,

vielen Dank für die Rückmeldung.

Ein Schönes Wochenende aus Baden-Würtemberg
wünscht dir

Heinz


  


Betrifft: Ohne Hilfsspalte von: Boris
Geschrieben am: 18.09.2004 23:49:15

Hi Markus,

...ist das ne simple Aufgabe für SUMMENPRODUKT.

Datümer in Spalte A - die Anzahl im Mai erhälst du mit:

=SUMMENPRODUKT(N(MONAT(A1:A100)=5))

Wenn Leerzellen vorkommen können, dann müssen diese für den Januar noch in der Formel eliminiert werden (da MONAT(Leerzelle) = MONAT(00.01.1900) = 1 = Januar = Billy´s Logik ;-) )

=SUMMENPRODUKT((MONAT(A1:A100)=1)*(A1:A100<>""))

Grüße Boris