Rangbestimmung / Lottoauswertung

Bild

Betrifft: Rangbestimmung / Lottoauswertung von: Erich M.
Geschrieben am: 06.02.2005 10:11:01

Hallo EXCEL-Freunde,

hatte gedacht, dass ich mit diesem Thread bereits die Lösung habe:
https://www.herber.de/index.html?https://www.herber.de/forum/archiv/556to560/t558436.htm

Jetzt ist aber das Problem aufgetaucht, wenn die gefundene Anzahl "0" ist, dann
stimmt die sortierung bzw. Zuordnung nicht mehr; in Spalte A ist die Rangstelle - aufsteigend; in Spalte B ist die gezogene Zahl; in Spalte C ist wie oft gezogen,
und Spalte D ist eine Hilfsspalte zur ermittlung wie oft gezogen:

Ränge
 ABCD
68675810,410
69686810,310
7069000,000
7170322-0,670
Formeln der Tabelle
B68 : =INDIREKT(ADRESSE(1;100-WENN(RECHTS(D68;2)*1<1;RECHTS(D68;2)*100;RECHTS(D68;2));;;"Zahlen"))
C68 : =INDIREKT(ADRESSE(2;100-WENN(RECHTS(D68;2)*1<1;RECHTS(D68;2)*100;RECHTS(D68;2));;;"Zahlen"))
D68 : {=KGRÖSSTE((Zahlen!B$2:BS$2)-SPALTE(B$2:$BS$2)/100;ZEILE()-1)}
B69 : =INDIREKT(ADRESSE(1;100-WENN(RECHTS(D69;2)*1<1;RECHTS(D69;2)*100;RECHTS(D69;2));;;"Zahlen"))
C69 : =INDIREKT(ADRESSE(2;100-WENN(RECHTS(D69;2)*1<1;RECHTS(D69;2)*100;RECHTS(D69;2));;;"Zahlen"))
D69 : {=KGRÖSSTE((Zahlen!B$2:BS$2)-SPALTE(B$2:$BS$2)/100;ZEILE()-1)}
B70 : =INDIREKT(ADRESSE(1;100-WENN(RECHTS(D70;2)*1<1;RECHTS(D70;2)*100;RECHTS(D70;2));;;"Zahlen"))
C70 : =INDIREKT(ADRESSE(2;100-WENN(RECHTS(D70;2)*1<1;RECHTS(D70;2)*100;RECHTS(D70;2));;;"Zahlen"))
D70 : {=WENN(KGRÖSSTE((Zahlen!B$2:BS$2)-SPALTE(B$2:$BS$2)/100;ZEILE()-1)<0;0;KGRÖSSTE((Zahlen!B$2:BS$2)-SPALTE(B$2:$BS$2)/100;ZEILE()-1))}
B71 : =INDIREKT(ADRESSE(1;100-WENN(RECHTS(D71;2)*1<1;RECHTS(D71;2)*100;RECHTS(D71;2));;;"Zahlen"))
C71 : =INDIREKT(ADRESSE(2;100-WENN(RECHTS(D71;2)*1<1;RECHTS(D71;2)*100;RECHTS(D71;2));;;"Zahlen"))
D71 : {=KGRÖSSTE((Zahlen!B$2:BS$2)-SPALTE(B$2:$BS$2)/100;ZEILE()-1)}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Ich habe das mal so abgeändert in C70, dass kein Minus, sondern "0" erscheint,
jetzt findet er aber die zugehörige Zahl nicht aus dieser Tabelle:

Zahlen
 ABCD
1Zahl123
2Anzahl035
3 b338:u631  
Formeln der Tabelle
B2 : {=WENN(SUMME(ZÄHLENWENN(B$1;INDIREKT($B3)))>0;SUMME(ZÄHLENWENN(B$1;INDIREKT($B3)));0)}
C2 : {=WENN(SUMME(ZÄHLENWENN(C$1;INDIREKT($B3)))>0;SUMME(ZÄHLENWENN(C$1;INDIREKT($B3)));0)}
D2 : {=WENN(SUMME(ZÄHLENWENN(D$1;INDIREKT($B3)))>0;SUMME(ZÄHLENWENN(D$1;INDIREKT($B3)));0)}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gerne stelle ich auch die Datei ins Netz, falls erforderlich.

Besten Dank für eine Hilfe!

mfg
Erich
http://www.toolex.de
Bild


Betrifft: AW: Rangbestimmung / Lottoauswertung von: th.heinrich
Geschrieben am: 06.02.2005 11:43:04

hallo Erich,

habe ich nicht genau kapiert in Spalte B ist die gezogene Zahl; in Spalte C ist wie oft gezogen,, z.b. Lottozahl = 68??

aber hier ein vorschlag aus dem Archiv

https://www.herber.de/forum/archiv/548to552/t548222.htm

gruss thomas


Bild


Betrifft: AW: Rangbestimmung / Lottoauswertung von: Erich M.
Geschrieben am: 06.02.2005 12:12:23

Hallo Thomas,

hätte ich noch ergänzen müssen: es geht hier um eine Auswertung von Keno: 20 aus 70.
Da gibt es 70 Zahlen (und nicht nur 49).
Der Thread aus dem Archiv hilft mir leider auch nicht weiter.

mfg
Erich
http://www.toolex.de


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Blatt einzeln mit Pfadangabe speichern"