MITTELWERTA() / MINA()

Bild

Betrifft: MITTELWERTA() / MINA() von: {Boris}
Geschrieben am: 15.02.2005 01:01:10

Hi Leute,

Gegeben:
A1: 1
A2: x
A3: 3

Die Funktion =MITTELWERTA(A1:A3) ergibt korrekt: 1,33333333
Gebe ich die Zellen aber als Matrixkonstanten vor:
=MITTELWERTA({1;"x";3})
dann erhalte ich im Ergebnis 2 ?!?!?

Das Gleiche mit MINA():
=MINA(A1:A3) ergibt korrekt: 0 (da ja Text als Null gewertet werden).
Das Gleiche aber mit Matrixkonstanten:
=MINA({1;"x";3})
ergibt 1 ?!?!?

Was geht hier vor? Wo liegt der Unterschied zwischen Bezügen auf die Tabelle und Direktbezügen mit Matrixkonstanten?

Mal wieder verwirrt...

{Boris}

Bild


Betrifft: AW: MITTELWERTA() / MINA() von: Hübi
Geschrieben am: 15.02.2005 01:16:44

Hi Boris,

gönne deinem Rechner eine Pause ;-)
Dein Beispiel nachgestellt, sieht bei mir so aus
Tabelle1
 AB
11 
2x 
33 
421
521
Formeln der Tabelle
A4 : =MITTELWERT(A1:A3)
B4 : =MIN(A1:A3)
A5 : =MITTELWERT({1."x".3})
B5 : =MIN({1."x".3})
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: AW: MITTELWERTA() / MINA() von: Ute
Geschrieben am: 15.02.2005 01:24:31

Boris hat MITTELWERTA und MINA verwendet, kleiner Unterschied!

mfg Ute


Bild


Betrifft: A-Variante von: Boris
Geschrieben am: 15.02.2005 09:46:25

Hi Hübi,

wie Ute schon anmerkte, geht es hier um die A-Variante der beiden Funktionen.
Siehe auch bereits Antwort an Beate.

Grüße Boris


Bild


Betrifft: AW: A-Variante von: Hübi
Geschrieben am: 15.02.2005 16:40:59

Hi Boris,

hatte mir Ute auch schon mitgeteilt.
Bin wohl doch ein Fall für Fielmann geworden ;-((

Gruß Hübi


Bild


Betrifft: AW: MITTELWERTA() / MINA() von: Beate Schmitz
Geschrieben am: 15.02.2005 02:16:02

Hallo Boris,

bei mir gibt es drei richtige Ergebnisse und ein falsches Ergebnis:

 
 AB
111,33333333
2x1,33333333
330
4 1
Formeln der Tabelle
B1 : =MITTELWERTA(A1:A3)
B2 : =MITTELWERTA({1;"x";3})
B3 : =MINA(A1:A3)
B4 : =MINA({1;"x";3})
 

Excel 2002 SP2

Gruß,
Beate


Bild


Betrifft: Versionsunterschied von: Boris
Geschrieben am: 15.02.2005 09:45:15

Hi Beate,

wie gesagt - bei xl2000 ergibt =MITTELWERTA({1;"x";3}) im Ergebnis 2. Da scheint es einen Unterschied zu xl2002 zu geben. Bei MINA() aber offensichtlich (noch) nicht...

Danke erstmal - aber ich kann halt nicht verstehen, warum eine Matrixkonstante anders behandelt wird als eine Matrix als Tabellenbezug...

Grüße Boris


Bild


Betrifft: AW: MITTELWERTA() / MINA() von: heikoS
Geschrieben am: 15.02.2005 08:48:18

Hallo Boris,

die Argumente als Werte der Funktionen (nicht Matrixkonstante) ergibt bei mir die korrekten Ergebnisse:

=MITTELWERTA(1;N("x");3)
=MINA(1;N("x");3)

Von der Beantwortung Deiner eigentlichen Frage nach dem Unterschied bin ich leider meilenweit entfernt. ;-)


Gruß Heiko


Bild


Betrifft: AW: MITTELWERTA() / MINA() von: Boris
Geschrieben am: 15.02.2005 12:04:04

Hi Heiko,

klar - denn N("Text") ergibt eben immer Null. Nur wird eben der Text innerhalb der Matrixkonstante nicht in Null umgewandelt - sondern eben nur bei Bezug auf die Tabelle.
Mal sehen, ob noch jemand irgendeine Idee hat ;-)

Danke und Grüße

Boris


Bild


Betrifft: AW: MITTELWERTA() / MINA() von: heikoS
Geschrieben am: 15.02.2005 12:26:19

Hallo Boris,

gutes Stichwort. Nicht innerhalb, sondern "außerhalb" in eine Zahl umwandeln:

=MITTELWERTA(N({1;"x";3}))
=MINA(N({1;"x";3}))

führt zu korrekten Ergebnissen.

Klingt für mich logisch, weil bei mina(a1:an) auch zunächst der (angezeigte) Zellinhalt von a1:an in Zahlen umgesetzt wird (werden muß) und dann das Minimum ermittelt wird. Zumindest erkläre ich mir das so.

Gruß Heiko


Bild


Betrifft: AW: MITTELWERTA() / MINA() von: HermannZ
Geschrieben am: 15.02.2005 20:20:11

Hallo Boris,

interesantes Thema, ich bin vor vierzehn Tagen auf diese Tretmine gelascht,weil ich wahrscheilich genau wie du davon ausgegangen bin das diese Funktion auch wirklich text erkennt.Ich habe dann damit etwas rumgespielt und bin zu dem Schluß gekommen das sie das garnicht kann, sonder nur ein bewertung zu Beispiel von WAHR und FALSCH macht, und alles andere mit dem Fehlerwert #WERT belegt.Schaue dir einmal meine Notizen dazu an und was du daraus für einen Schluss ziehst.

https://www.herber.de/bbs/user/18143.xls

Gruß Hermann


Bild


Betrifft: Danke vielmals... von: Boris
Geschrieben am: 16.02.2005 19:25:22

Hi Hermann,

...ich schau mir das in Ruhe an.
Wenigstens hab ich die Gewissheit, dass ich nicht spinne ;-)

Grüße Boris


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellinhalt nach Arbeitsblatt bennenen"