Summe nichtdoppelter Einträge

Bild

Betrifft: Summe nichtdoppelter Einträge von: Claudia
Geschrieben am: 15.02.2005 00:23:18

Hallo,
suche verzweifelt nach einer Lösung zu folgendem Problem:
Ähnliches Beispiel sichtbar unter:
http://www.excelformeln.de/formeln.html?welcher=64

In Spalte D5-D24 habe ich Auftragsnummern (mit einem Bindestrich in der Mitte).
In Spalte G5-G24 stehen jeweils dafür die Auftragsbeträge (stehen in Zusammenhang).
In Spalte D stehen jedoch unterschiedliche Angaben, wobei sich einige Einträge bezüglich der Spalten D und G wiederholen.
Jetzt möchte ich im Feld G26 die Summe aller Aufträge ermitteln, wobei die Addition der Beträge nur mit einmaligen Auftragsnummern erstellt werden soll.
Leider kommt bei mir (bezüglich Beispiel) immer das Ergebnis "#WERT!" raus.
Hier nochmal die Formel:
=SUMME(WENN((ZÄHLENWENN(BEREICH.VERSCHIEBEN(D1;;;ZEILE(D5:D24));D5:D24)=1)*(D5:D24<>"");G5:G24))

Was mache ich falsch?
Lieben Dank für jegliche Hilfe,
Claudia

Bild


Betrifft: AW: Summe nichtdoppelter Einträge von: Hübi
Geschrieben am: 15.02.2005 00:45:02

Hi Claudia,

deine Formel ist richtig - klicke in die Bearbeitungszeile und schließe die Eingabe mit Strg+Shift+Enter ab.

Gruß Hübi


Bild


Betrifft: AW: Summe nichtdoppelter Einträge von: th.heinrich
Geschrieben am: 15.02.2005 00:57:50

hallo Claudia,

damit komme ich nicht klar.

In Spalte G5-G24 stehen jeweils dafür die Auftragsbeträge (stehen in Zusammenhang).
In Spalte D stehen jedoch unterschiedliche Angaben, wobei sich einige Einträge bezüglich der Spalten D und G wiederholen.


wie haengt das zusammen, btw ein naiver ansatz mittels Spezialfilter

Tabelle1
 ABC
16nrsonstigesbetrag
171-1a1
182-1c2
191-1s3
203-1l4
21   
22vor FILTER 10
Formeln der Tabelle
C22 : =TEILERGEBNIS(9;C17:C20)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


A16:A22 markieren, Daten-Filter-Spetialfilter keine duplikate.

Tabelle1
 ABC
16nrsonstigesbetrag
171-1a1
182-1c2
203-1l4
21   
22nach FILTER 7
Formeln der Tabelle
C22 : =TEILERGEBNIS(9;C17:C20)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


gruss thomas


Bild


Betrifft: AW: Summe nichtdoppelter Einträge von: Claudia
Geschrieben am: 15.02.2005 01:12:37

Jaaaaaaaaaa,
lieben herzlichen Dank.
Dieser Tastatureingriff (STRK+Shift+Enter) wirkt Wunder.
Vielen Dank,
Claudia


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellinhalt nach Arbeitsblatt bennenen"