Rangfunktion Ergebnis umkehren

Bild

Betrifft: Rangfunktion Ergebnis umkehren
von: Jürgen
Geschrieben am: 15.02.2005 16:43:39
Hallo Excelfreunde,
Ich habe mit der Rangfunktion eine Auswertung einer Liste definiert.
Nun soll aber die größte Zahl in der Liste Rang 1 sein und Listenfelder mit dem Wert null nicht berücksichtigt werden.
Könnt ihr mir helfen ?

Bild

Betrifft: AW: Rangfunktion Ergebnis umkehren
von: th.heinrich
Geschrieben am: 15.02.2005 17:49:36
hallo Jürgen,
passt dies?
Tabelle1
 AB
5listerang
612
7  
851
Formeln der Tabelle
B6 : =WENN(ISTLEER(A6);"";RANG(A6;$A$6:$A$8;0))
B7 : =WENN(ISTLEER(A7);"";RANG(A7;$A$6:$A$8;0))
B8 : =WENN(ISTLEER(A8);"";RANG(A8;$A$6:$A$8;0))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruss thomas
Bild

Betrifft: AW: Rangfunktion Ergebnis umkehren
von: Jürgen
Geschrieben am: 15.02.2005 19:01:16
Hallo Thomas,
Dein Vorschlag funktioniert schon gut. Allerdings sollten die Zellen deren Werte null sind nicht angezeigt werden. Sie haben jetzt den letzten Rang.
Gruss Jürgen
Bild

Betrifft: AW: Rangfunktion Ergebnis umkehren
von: th.heinrich
Geschrieben am: 15.02.2005 20:28:41
hi Jürgen,
dann so.
Tabelle1
 AB
1werterang
213
30 
432
5  
651
Formeln der Tabelle
B2 : =WENN(A2=0;"";RANG(A2;$A$2:$A$6;0))
B3 : =WENN(A3=0;"";RANG(A3;$A$2:$A$6;0))
B4 : =WENN(A4=0;"";RANG(A4;$A$2:$A$6;0))
B5 : =WENN(A5=0;"";RANG(A5;$A$2:$A$6;0))
B6 : =WENN(A6=0;"";RANG(A6;$A$2:$A$6;0))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruss thomas
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Rangfunktion Ergebnis umkehren"