ausgefuellte zellen zählen

Bild

Betrifft: ausgefuellte zellen zählen
von: roland_k
Geschrieben am: 19.02.2005 04:48:43
hoi guten morgen zusammen
ich habe in mehreren nebeneinanderliegenden spalten unterschiedlich viele x eingetragen.
nun will ich diese zählen z. b. zeile 5 sind 2 (x)dann soll diese 2 mit dem inhalt von zelle E5 multipliziert werden und das erg. in zelle P8 stehen

Spielliste 1x48 4er Schwarz
 EFGHIJK
111xxxxxx
122 x x x
133xx x  
144  x x 
155xx    
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
hm irgendwie mit in array einlesen denke ich ..aber eben ...das wie:-(
danke im voraus ....
gruss roland_k
Bild

Betrifft: AW: ausgefuellte zellen zählen
von: Reinhard
Geschrieben am: 19.02.2005 05:31:45
Hi Roland,
meinst du das so?
Tabellenblattname: Tabelle1
    A   B   C   D   E   F   G   H   I   J   K   L   M   N   O   P    
1                  1   x   x   x   x   x                        5   
2                  2   x       x                                4   
3                  3       x       x   x                        9   
4                  4   x   x       x                           12   
5                  5   x   x                                   10   
Benutzte Formeln:
P1:  =E1*ZÄHLENWENN(F1:O1;"x")
P2:  =E2*ZÄHLENWENN(F2:O2;"x")
P3:  =E3*ZÄHLENWENN(F3:O3;"x")
P4:  =E4*ZÄHLENWENN(F4:O4;"x")
P5:  =E5*ZÄHLENWENN(F5:O5;"x")
Wenn nicht, dann bitte mehr Informationen.
Gruß
Reinhard

Bild

Betrifft: stimmt genau im tabellenblatt aber ..im code?
von: roland_k
Geschrieben am: 19.02.2005 07:09:23
hi reinhard ...so will ich das haben ..
nu muss ich aber die formel im vba code einbauen etwa dort die anweisungenmachen
oder eben im blatt mit funktionen

ich habe 89 zeilen ..

das ist nur der zählgedanke...nu muss ich
folgendes machen:
Tabelle1
 BCDEFGHIJKLMNO
9  +-      +-
10        
11333 xxxxxx(3+6X)*33 
122244  x x x(44+3X)*22 
13122 4xx x   (4+3x)*122*-3
1465 12x x x  (12+3x)*65*-3
159 3xx     (3+2x)*9*-3
16           
17              
18            Faktor -3 konstant
19    Anzahl x   
20      
21              
22              
23              
24  plus  aus …C * (D + Anzahlx) in  spalte L  
25    
26    
27    
28    
29              
30  minus aus … C * ( E + Anzahlx in) * -3  spalte N  
31    
32    
33    
34    
35              
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

dabei will ich alle zellen mit formeln schuetzen so dass der anwender da nicht von hand eingibt
ich hoffe dass das erkennen kannst wie ich das meine
ansonsten kanich ein beispieldatei hochladen
danke dir ..
gruss roland_k
Bild

Betrifft: ja, lade mal eine verständliche Datei hoch o.w.T.
von: Reinhard
Geschrieben am: 19.02.2005 07:12:36

Bild

Betrifft: hoffe es geht so ...fuer den anfang
von: roland_k
Geschrieben am: 19.02.2005 07:53:56
hoi reinhard
habe das nochmal reduziert
ich muss die ausgezählten x zu nem wert addieren und dann multipizieren und das ergebniss in spalt L haben
in spalte D kummen werte aus einem formular ....die spalte L soll eben immer den neuen wert zeigen wenn sich in D was ändert
frage ist eben ob ich in spalte L12 - L 178 jeweils die formel reinstelle oder im bva editor was bastle
hm hoffe du kannst mir das fuer eine zeile zeigen ,,
dsnke gruss roland
Tabelle1
 CDEFGHIJKLMNO
6 wenn in spalte D ein wert eingegeben wird soll in spalte L direckt ergebniss stehn  
7  
8            
9         + 
10         
1153 xxxxxx455 *( 3 + 6 )
1284  x x x568 * (4 + 3)
13             
14             
15   Anzahl x     
16       
17             
18 In spalte L ergbniss aus:…C * (D + Anzahlx)   
19   
20   
21   
22   
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bild

Betrifft: AW: hoffe es geht so ...fuer den anfang
von: Reinhard
Geschrieben am: 19.02.2005 08:26:25
Hi Roland,
Tabellenblattname: Tabelle1
     C6   D6   E6   F6   G6   H6   I6   J6   K6   L6   
 6                                                    
 7                                                    
 8                                                    
 9                                                    
10                                                    
11   5    3         x    x    x    x    x    x   45   
12   8    4              x         x         x   56   
13                                                    
Benutzte Formeln:
L11:  =WENN(D11<>"";C11*(ZÄHLENWENN(E11:K11;"x")+D11);"")
L12:  =WENN(D12<>"";C12*(ZÄHLENWENN(E12:K12;"x")+D12);"")
Gruß
Reinhard
Tabelle wurde eingefügt mit Code von https://www.herber.de/forum/technik/messages/1226.html

Bild

Betrifft: AW: ausgefuellte zellen zählen
von: HermannZ
Geschrieben am: 19.02.2005 11:04:32
Hallo Roland,
meinst du das so???
Beispiel;
Summe
 ABCDEFGHI
2025         
202653xxxxxx45
202784 x x x56
2028         
Formeln der Tabelle
I2026 : {=A2026*(B2026+SUMME(IDENTISCH("x";C2026:H2026)*1))}
I2027 : {=A2027*(B2027+SUMME(IDENTISCH("x";C2027:H2027)*1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
 Bild

Beiträge aus den Excel-Beispielen zum Thema "ausgefuellte zellen zählen "