Suche Formel

Bild

Betrifft: Suche Formel
von: Christian
Geschrieben am: 19.02.2005 19:07:16
Brauche mal wieder Hilfe.
In Spalte H stehen nicht sortiert, die Werte 0101 - 1879.
Jetzt brauche ich eine Formel, die für die dritte Zahl ( Zehner)
einen Buchstaben in einer anderen Spalte ausgibt.
Für die Werte XX01 - xx09 soll ein T erscheinen.
Für die Werte XX11 - xx29 soll ein A erscheinen.
Für die Werte XX31 - xx49 soll ein M erscheinen.
Für die Werte XX51 - xx79 soll ein S erscheinen.
Bin mal gespannt ob das möglich ist.

Bild

Betrifft: AW: Suche Formel
von: chris b
Geschrieben am: 19.02.2005 19:20:17
Hier hast du Sie !
=WENN(A1="xx01";"T";WENN(A1="xx11";"A";WENN(A1="xx31";"M";WENN(A1="xx51";"S";))))
Ps Rückmeldung nicht vergessen !
Bild

Betrifft: AW: Suche Formel
von: Hübi
Geschrieben am: 19.02.2005 20:53:02
Hi Franz und alle anderen,
jetzt mal alle bisherigen Lösungen zum Vergleich.
Tabelle2
 ABCDEF
10101TTTTT
20109TTTTT
30010AA A 
40011AAAAA
51020AA AA
61029AAAAA
71030MM M 
80031MMMMM
90140MM MM
100049MMMMM
110050SS S 
120051SSSSS
130160SS SS
140170SS SS
150079SSSSS
16 ReinhardSeppRansiFranzHübi
17So war die Frage    
18Für die Werte XX01 - xx09 soll ein T erscheinen.
19Für die Werte XX11 - xx29 soll ein A erscheinen.
20Für die Werte XX31 - xx49 soll ein M erscheinen.
21Für die Werte XX51 - xx79 soll ein S erscheinen.
Formeln der Tabelle
B1 : =WAHL(TEIL(RECHTS(A1;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C1 : =SVERWEIS(RECHTS(A1;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D1 : =WENN(RECHTS(A1;1)="0";"";WAHL(TEIL(RECHTS(A1;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E1 : =TEIL("TAAMMSSS";REST(KÜRZEN(A1/10);10)+1;1)
F1 : =WENN(UND(RECHTS(A1;2)>"0";RECHTS(A1;2)<"10");"T";WENN(UND(RECHTS(A1;2)>"10";RECHTS(A1;2)<"30");"A";WENN(UND(RECHTS(A1;2)>"30";RECHTS(A1;2)<"50");"M";WENN(UND(RECHTS(A1;2)>"50";RECHTS(A1;2)<"80");"S";""))))
B2 : =WAHL(TEIL(RECHTS(A2;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C2 : =SVERWEIS(RECHTS(A2;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D2 : =WENN(RECHTS(A2;1)="0";"";WAHL(TEIL(RECHTS(A2;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E2 : =TEIL("TAAMMSSS";REST(KÜRZEN(A2/10);10)+1;1)
F2 : =WENN(UND(RECHTS(A2;2)>"0";RECHTS(A2;2)<"10");"T";WENN(UND(RECHTS(A2;2)>"10";RECHTS(A2;2)<"30");"A";WENN(UND(RECHTS(A2;2)>"30";RECHTS(A2;2)<"50");"M";WENN(UND(RECHTS(A2;2)>"50";RECHTS(A2;2)<"80");"S";""))))
B3 : =WAHL(TEIL(RECHTS(A3;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C3 : =SVERWEIS(RECHTS(A3;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D3 : =WENN(RECHTS(A3;1)="0";"";WAHL(TEIL(RECHTS(A3;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E3 : =TEIL("TAAMMSSS";REST(KÜRZEN(A3/10);10)+1;1)
F3 : =WENN(UND(RECHTS(A3;2)>"0";RECHTS(A3;2)<"10");"T";WENN(UND(RECHTS(A3;2)>"10";RECHTS(A3;2)<"30");"A";WENN(UND(RECHTS(A3;2)>"30";RECHTS(A3;2)<"50");"M";WENN(UND(RECHTS(A3;2)>"50";RECHTS(A3;2)<"80");"S";""))))
B4 : =WAHL(TEIL(RECHTS(A4;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C4 : =SVERWEIS(RECHTS(A4;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D4 : =WENN(RECHTS(A4;1)="0";"";WAHL(TEIL(RECHTS(A4;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E4 : =TEIL("TAAMMSSS";REST(KÜRZEN(A4/10);10)+1;1)
F4 : =WENN(UND(RECHTS(A4;2)>"0";RECHTS(A4;2)<"10");"T";WENN(UND(RECHTS(A4;2)>"10";RECHTS(A4;2)<"30");"A";WENN(UND(RECHTS(A4;2)>"30";RECHTS(A4;2)<"50");"M";WENN(UND(RECHTS(A4;2)>"50";RECHTS(A4;2)<"80");"S";""))))
B5 : =WAHL(TEIL(RECHTS(A5;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C5 : =SVERWEIS(RECHTS(A5;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D5 : =WENN(RECHTS(A5;1)="0";"";WAHL(TEIL(RECHTS(A5;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E5 : =TEIL("TAAMMSSS";REST(KÜRZEN(A5/10);10)+1;1)
F5 : =WENN(UND(RECHTS(A5;2)>"0";RECHTS(A5;2)<"10");"T";WENN(UND(RECHTS(A5;2)>"10";RECHTS(A5;2)<"30");"A";WENN(UND(RECHTS(A5;2)>"30";RECHTS(A5;2)<"50");"M";WENN(UND(RECHTS(A5;2)>"50";RECHTS(A5;2)<"80");"S";""))))
B6 : =WAHL(TEIL(RECHTS(A6;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C6 : =SVERWEIS(RECHTS(A6;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D6 : =WENN(RECHTS(A6;1)="0";"";WAHL(TEIL(RECHTS(A6;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E6 : =TEIL("TAAMMSSS";REST(KÜRZEN(A6/10);10)+1;1)
F6 : =WENN(UND(RECHTS(A6;2)>"0";RECHTS(A6;2)<"10");"T";WENN(UND(RECHTS(A6;2)>"10";RECHTS(A6;2)<"30");"A";WENN(UND(RECHTS(A6;2)>"30";RECHTS(A6;2)<"50");"M";WENN(UND(RECHTS(A6;2)>"50";RECHTS(A6;2)<"80");"S";""))))
B7 : =WAHL(TEIL(RECHTS(A7;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C7 : =SVERWEIS(RECHTS(A7;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D7 : =WENN(RECHTS(A7;1)="0";"";WAHL(TEIL(RECHTS(A7;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E7 : =TEIL("TAAMMSSS";REST(KÜRZEN(A7/10);10)+1;1)
F7 : =WENN(UND(RECHTS(A7;2)>"0";RECHTS(A7;2)<"10");"T";WENN(UND(RECHTS(A7;2)>"10";RECHTS(A7;2)<"30");"A";WENN(UND(RECHTS(A7;2)>"30";RECHTS(A7;2)<"50");"M";WENN(UND(RECHTS(A7;2)>"50";RECHTS(A7;2)<"80");"S";""))))
B8 : =WAHL(TEIL(RECHTS(A8;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C8 : =SVERWEIS(RECHTS(A8;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D8 : =WENN(RECHTS(A8;1)="0";"";WAHL(TEIL(RECHTS(A8;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E8 : =TEIL("TAAMMSSS";REST(KÜRZEN(A8/10);10)+1;1)
F8 : =WENN(UND(RECHTS(A8;2)>"0";RECHTS(A8;2)<"10");"T";WENN(UND(RECHTS(A8;2)>"10";RECHTS(A8;2)<"30");"A";WENN(UND(RECHTS(A8;2)>"30";RECHTS(A8;2)<"50");"M";WENN(UND(RECHTS(A8;2)>"50";RECHTS(A8;2)<"80");"S";""))))
B9 : =WAHL(TEIL(RECHTS(A9;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C9 : =SVERWEIS(RECHTS(A9;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D9 : =WENN(RECHTS(A9;1)="0";"";WAHL(TEIL(RECHTS(A9;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E9 : =TEIL("TAAMMSSS";REST(KÜRZEN(A9/10);10)+1;1)
F9 : =WENN(UND(RECHTS(A9;2)>"0";RECHTS(A9;2)<"10");"T";WENN(UND(RECHTS(A9;2)>"10";RECHTS(A9;2)<"30");"A";WENN(UND(RECHTS(A9;2)>"30";RECHTS(A9;2)<"50");"M";WENN(UND(RECHTS(A9;2)>"50";RECHTS(A9;2)<"80");"S";""))))
B10 : =WAHL(TEIL(RECHTS(A10;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C10 : =SVERWEIS(RECHTS(A10;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D10 : =WENN(RECHTS(A10;1)="0";"";WAHL(TEIL(RECHTS(A10;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E10 : =TEIL("TAAMMSSS";REST(KÜRZEN(A10/10);10)+1;1)
F10 : =WENN(UND(RECHTS(A10;2)>"0";RECHTS(A10;2)<"10");"T";WENN(UND(RECHTS(A10;2)>"10";RECHTS(A10;2)<"30");"A";WENN(UND(RECHTS(A10;2)>"30";RECHTS(A10;2)<"50");"M";WENN(UND(RECHTS(A10;2)>"50";RECHTS(A10;2)<"80");"S";""))))
B11 : =WAHL(TEIL(RECHTS(A11;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C11 : =SVERWEIS(RECHTS(A11;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D11 : =WENN(RECHTS(A11;1)="0";"";WAHL(TEIL(RECHTS(A11;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E11 : =TEIL("TAAMMSSS";REST(KÜRZEN(A11/10);10)+1;1)
F11 : =WENN(UND(RECHTS(A11;2)>"0";RECHTS(A11;2)<"10");"T";WENN(UND(RECHTS(A11;2)>"10";RECHTS(A11;2)<"30");"A";WENN(UND(RECHTS(A11;2)>"30";RECHTS(A11;2)<"50");"M";WENN(UND(RECHTS(A11;2)>"50";RECHTS(A11;2)<"80");"S";""))))
B12 : =WAHL(TEIL(RECHTS(A12;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C12 : =SVERWEIS(RECHTS(A12;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D12 : =WENN(RECHTS(A12;1)="0";"";WAHL(TEIL(RECHTS(A12;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E12 : =TEIL("TAAMMSSS";REST(KÜRZEN(A12/10);10)+1;1)
F12 : =WENN(UND(RECHTS(A12;2)>"0";RECHTS(A12;2)<"10");"T";WENN(UND(RECHTS(A12;2)>"10";RECHTS(A12;2)<"30");"A";WENN(UND(RECHTS(A12;2)>"30";RECHTS(A12;2)<"50");"M";WENN(UND(RECHTS(A12;2)>"50";RECHTS(A12;2)<"80");"S";""))))
B13 : =WAHL(TEIL(RECHTS(A13;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C13 : =SVERWEIS(RECHTS(A13;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D13 : =WENN(RECHTS(A13;1)="0";"";WAHL(TEIL(RECHTS(A13;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E13 : =TEIL("TAAMMSSS";REST(KÜRZEN(A13/10);10)+1;1)
F13 : =WENN(UND(RECHTS(A13;2)>"0";RECHTS(A13;2)<"10");"T";WENN(UND(RECHTS(A13;2)>"10";RECHTS(A13;2)<"30");"A";WENN(UND(RECHTS(A13;2)>"30";RECHTS(A13;2)<"50");"M";WENN(UND(RECHTS(A13;2)>"50";RECHTS(A13;2)<"80");"S";""))))
B14 : =WAHL(TEIL(RECHTS(A14;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C14 : =SVERWEIS(RECHTS(A14;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D14 : =WENN(RECHTS(A14;1)="0";"";WAHL(TEIL(RECHTS(A14;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E14 : =TEIL("TAAMMSSS";REST(KÜRZEN(A14/10);10)+1;1)
F14 : =WENN(UND(RECHTS(A14;2)>"0";RECHTS(A14;2)<"10");"T";WENN(UND(RECHTS(A14;2)>"10";RECHTS(A14;2)<"30");"A";WENN(UND(RECHTS(A14;2)>"30";RECHTS(A14;2)<"50");"M";WENN(UND(RECHTS(A14;2)>"50";RECHTS(A14;2)<"80");"S";""))))
B15 : =WAHL(TEIL(RECHTS(A15;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C15 : =SVERWEIS(RECHTS(A15;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D15 : =WENN(RECHTS(A15;1)="0";"";WAHL(TEIL(RECHTS(A15;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E15 : =TEIL("TAAMMSSS";REST(KÜRZEN(A15/10);10)+1;1)
F15 : =WENN(UND(RECHTS(A15;2)>"0";RECHTS(A15;2)<"10");"T";WENN(UND(RECHTS(A15;2)>"10";RECHTS(A15;2)<"30");"A";WENN(UND(RECHTS(A15;2)>"30";RECHTS(A15;2)<"50");"M";WENN(UND(RECHTS(A15;2)>"50";RECHTS(A15;2)<"80");"S";""))))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Oder habe ich die Frage falsch verstanden?
Gruß Hübi
Bild

Betrifft: AW: Suche Formel
von: Hübi
Geschrieben am: 19.02.2005 19:23:39
Hi Christian,
der Anfang ist gemacht
Tabelle2
 AB
11009T
20012A
3den Rest schaffst du allein 
Formeln der Tabelle
B1 : =WENN(UND(RECHTS(A1;2)>"0";RECHTS(A1;2)<"10");"T";WENN(UND(RECHTS(A1;2)>"10";RECHTS(A1;2)<"30");"A";))
B2 : =WENN(UND(RECHTS(A2;2)>"0";RECHTS(A2;2)<"10");"T";WENN(UND(RECHTS(A2;2)>"10";RECHTS(A2;2)<"30");"A";))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hübi
Bild

Betrifft: AW: Suche Formel
von: chris b
Geschrieben am: 19.02.2005 19:25:27
???????????
Was passt dir an meiner Lösung nicht ?
Oder warum doppelt?
Bild

Betrifft: AW: Suche Formel
von: chris b
Geschrieben am: 19.02.2005 19:26:16
uuuppss
Bild

Betrifft: @ Chris verstehe die Frage nicht ;-(( o.T.
von: Hübi
Geschrieben am: 19.02.2005 19:27:16

Bild

Betrifft: Wahl
von: Reinhard
Geschrieben am: 19.02.2005 19:28:43
Hi Chris,
Tabellenblattname: Tabelle1
       H     | I |           J            | 
 1|      101 | 0 |                      T | 
 2|      123 | 2 |                      M | 
 3|      137 | 3 |                      S | 
 4|      711 | 1 |                      A | 
 5|     2643 | 4 | nichts definiert für 4 | 
 6|   234567 | 6 | nichts definiert für 6 | 
 7|      997 | 9 | nichts definiert für 9 | 
 8|      998 | 9 | nichts definiert für 9 | 
 9|      999 | 9 | nichts definiert für 9 | 
10|     1000 | 0 |                      T | 
11|     1081 | 8 | nichts definiert für 8 | 
12|     1002 | 0 |                      T | 
13|     1003 | 0 |                      T | 
14|     1004 | 0 |                      T | 
15|     1005 | 0 |                      T | 
16|     1006 | 0 |                      T | 
17| eotze895 | 9 | nichts definiert für 9 | 
18|     1940 | 4 | nichts definiert für 4 | 
Benutzte Formeln:
I1:  =LINKS(RECHTS(H1;2))
I2:  =LINKS(RECHTS(H2;2))
I3:  =LINKS(RECHTS(H3;2))
I4:  =LINKS(RECHTS(H4;2))
I5:  =LINKS(RECHTS(H5;2))
I6:  =LINKS(RECHTS(H6;2))
I7:  =LINKS(RECHTS(H7;2))
I8:  =LINKS(RECHTS(H8;2))
I9:  =LINKS(RECHTS(H9;2))
I10:  =LINKS(RECHTS(H10;2))
I11:  =LINKS(RECHTS(H11;2))
I12:  =LINKS(RECHTS(H12;2))
I13:  =LINKS(RECHTS(H13;2))
I14:  =LINKS(RECHTS(H14;2))
I15:  =LINKS(RECHTS(H15;2))
I16:  =LINKS(RECHTS(H16;2))
I17:  =LINKS(RECHTS(H17;2))
I18:  =LINKS(RECHTS(H18;2))
J1:  =WAHL(I1+1;"T";"A";"M";"S";F;F;F;F;F;F)
J2:  =WAHL(I2+1;"T";"A";"M";"S";F;F;F;F;F;F)
J3:  =WAHL(I3+1;"T";"A";"M";"S";F;F;F;F;F;F)
J4:  =WAHL(I4+1;"T";"A";"M";"S";F;F;F;F;F;F)
J5:  =WAHL(I5+1;"T";"A";"M";"S";F;F;F;F;F;F)
J6:  =WAHL(I6+1;"T";"A";"M";"S";F;F;F;F;F;F)
J7:  =WAHL(I7+1;"T";"A";"M";"S";F;F;F;F;F;F)
J8:  =WAHL(I8+1;"T";"A";"M";"S";F;F;F;F;F;F)
J9:  =WAHL(I9+1;"T";"A";"M";"S";F;F;F;F;F;F)
J10:  =WAHL(I10+1;"T";"A";"M";"S";F;F;F;F;F;F)
J11:  =WAHL(I11+1;"T";"A";"M";"S";F;F;F;F;F;F)
J12:  =WAHL(I12+1;"T";"A";"M";"S";F;F;F;F;F;F)
J13:  =WAHL(I13+1;"T";"A";"M";"S";F;F;F;F;F;F)
J14:  =WAHL(I14+1;"T";"A";"M";"S";F;F;F;F;F;F)
J15:  =WAHL(I15+1;"T";"A";"M";"S";F;F;F;F;F;F)
J16:  =WAHL(I16+1;"T";"A";"M";"S";F;F;F;F;F;F)
J17:  =WAHL(I17+1;"T";"A";"M";"S";F;F;F;F;F;F)
J18:  =WAHL(I18+1;"T";"A";"M";"S";F;F;F;F;F;F)
Namen in der Tabelle:
F:  ="nichts definiert für "&INDIREKT("ZS(-1)";)
Gruß
Reinhard
Tabelle wurde eingefügt mit Code von https://www.herber.de/forum/technik/messages/1226.html

Bild

Betrifft: OT: Link nicht anwählbar
von: Reinhard
Geschrieben am: 19.02.2005 19:34:20
Guten Abend,
ab dem nächsten mal ist der Link anwählbar, habe es im Code korrigiert.
Gruß
Reinhard
Bild

Betrifft: AW: Suche Formel
von: ransi
Geschrieben am: 19.02.2005 19:36:15
hallo christian
schau mal hier
 
 HI
10403T
21781 
30619A
40479S
50843M
60452S
Formeln der Tabelle
I1 : =WAHL(TEIL(RECHTS(H1;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
I2 : =WAHL(TEIL(RECHTS(H2;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
I3 : =WAHL(TEIL(RECHTS(H3;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
I4 : =WAHL(TEIL(RECHTS(H4;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
I5 : =WAHL(TEIL(RECHTS(H5;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
I6 : =WAHL(TEIL(RECHTS(H6;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Bild

Betrifft: OT Jetzt haben wir mal...
von: Reinhard
Geschrieben am: 19.02.2005 19:44:17
Hallöchen,
... seltenst genug eine klar und übersichtlich gestellte Frage ohne Ballast und ohne fehlenden Infos (Naja Gruß und Anrede müssen wir noch e mal üben ), prompt lese ich die falsch :-)
Gruß
Reinhard
Bild

Betrifft: AW: Suche Formel
von: Hübi
Geschrieben am: 19.02.2005 19:49:46
Hi Ransi,
es wäre zu schön gewesen.
Tabelle2
 AB
11000T
20101T
30109T
40010A
50011A
61029A
71030M
80031M
90049M
100050S
110051S
120079S
130080 
Formeln der Tabelle
B1 : =WAHL(TEIL(RECHTS(A1;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B2 : =WAHL(TEIL(RECHTS(A2;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B3 : =WAHL(TEIL(RECHTS(A3;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B4 : =WAHL(TEIL(RECHTS(A4;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B5 : =WAHL(TEIL(RECHTS(A5;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B6 : =WAHL(TEIL(RECHTS(A6;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B7 : =WAHL(TEIL(RECHTS(A7;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B8 : =WAHL(TEIL(RECHTS(A8;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B9 : =WAHL(TEIL(RECHTS(A9;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B10 : =WAHL(TEIL(RECHTS(A10;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B11 : =WAHL(TEIL(RECHTS(A11;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B12 : =WAHL(TEIL(RECHTS(A12;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
B13 : =WAHL(TEIL(RECHTS(A13;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Die roten sollten raus
Gruß Hübi
Bild

Betrifft: mit wenn() vorweg
von: ransi
Geschrieben am: 19.02.2005 20:06:02
hallo
hab ich doch glatt überlesen.
dann hängen wir einfach ein wenn() davor.
 
 HI
11000 
21781 
30613A
40479S
50853S
60452S
71049M
80109T
Formeln der Tabelle
I1 : =WENN(RECHTS(H1;1)="0";"";WAHL(TEIL(RECHTS(H1;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
I2 : =WENN(RECHTS(H2;1)="0";"";WAHL(TEIL(RECHTS(H2;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
I3 : =WENN(RECHTS(H3;1)="0";"";WAHL(TEIL(RECHTS(H3;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
I4 : =WENN(RECHTS(H4;1)="0";"";WAHL(TEIL(RECHTS(H4;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
I5 : =WENN(RECHTS(H5;1)="0";"";WAHL(TEIL(RECHTS(H5;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
I6 : =WENN(RECHTS(H6;1)="0";"";WAHL(TEIL(RECHTS(H6;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
I7 : =WENN(RECHTS(H7;1)="0";"";WAHL(TEIL(RECHTS(H7;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
I8 : =WENN(RECHTS(H8;1)="0";"";WAHL(TEIL(RECHTS(H8;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Bild

Betrifft: AW: mit wenn() vorweg
von: Hübi
Geschrieben am: 19.02.2005 20:30:09
Hi Ransi,
ist zwar nicht mein Problem - aber

einen Buchstaben in einer anderen Spalte ausgibt.
Für die Werte XX01 - xx09 soll ein T erscheinen.
Für die Werte XX11 - xx29 soll ein A erscheinen.
Für die Werte XX31 - xx49 soll ein M erscheinen.
Für die Werte XX51 - xx79 soll ein S erscheinen.

und wo bleiben bei dem zusätzlichen WENN() die 20, 40, 60, 70 ? - weg sind sie ;-))
Gruß Hübi
Bild

Betrifft: noch eine Variante!
von: Josef Ehrensberger
Geschrieben am: 19.02.2005 19:46:24
Hallo Christian!
 
 AB
10101T
21331M
31224A
41587S
50110A
Formeln der Tabelle
B1 : =SVERWEIS(RECHTS(A1;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B2 : =SVERWEIS(RECHTS(A2;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B3 : =SVERWEIS(RECHTS(A3;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B4 : =SVERWEIS(RECHTS(A4;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B5 : =SVERWEIS(RECHTS(A5;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
 

Gruß Sepp
P.S.: Rückmeldung nicht vergessen!
Bild

Betrifft: AW: noch eine Variante!
von: Reinhard
Geschrieben am: 19.02.2005 19:53:16
Hi Sepp,
für die Formel bräuchte ich wieder längere Zeit um das nachzudenken, aber "S" geht nur bis 1579, 1587 ist nicht definiert was da geschehen soll.
Gruß
Reinhard
Bild

Betrifft: AW: noch eine Variante!
von: Josef Ehrensberger
Geschrieben am: 19.02.2005 19:56:46
Hallo Reinhard!
Das hab ich absichtlich so gemacht!
Man soll ja das Prinzip verstehen, und das ist es gut wenn man ein
bischen herumprobiert;-)

Gruß Sepp
Bild

Betrifft: AW: noch eine Variante!
von: Hübi
Geschrieben am: 19.02.2005 20:09:12
Hi Sepp,
ist zwar auch gut gemeint, wenn das nicht definiert gewesen wäre

einen Buchstaben in einer anderen Spalte ausgibt.
Für die Werte XX01 - xx09 soll ein T erscheinen.
Für die Werte XX11 - xx29 soll ein A erscheinen.
Für die Werte XX31 - xx49 soll ein M erscheinen.
Für die Werte XX51 - xx79 soll ein S erscheinen.

Tabelle2
 ABC
10101TT
20109TT
30010AA
40011AA
51029AA
61030MM
70031MM
80049MM
90050SS
100051SS
110079SS
Formeln der Tabelle
B1 : =WAHL(TEIL(RECHTS(A1;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C1 : =SVERWEIS(RECHTS(A1;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B2 : =WAHL(TEIL(RECHTS(A2;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C2 : =SVERWEIS(RECHTS(A2;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B3 : =WAHL(TEIL(RECHTS(A3;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C3 : =SVERWEIS(RECHTS(A3;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B4 : =WAHL(TEIL(RECHTS(A4;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C4 : =SVERWEIS(RECHTS(A4;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B5 : =WAHL(TEIL(RECHTS(A5;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C5 : =SVERWEIS(RECHTS(A5;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B6 : =WAHL(TEIL(RECHTS(A6;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C6 : =SVERWEIS(RECHTS(A6;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B7 : =WAHL(TEIL(RECHTS(A7;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C7 : =SVERWEIS(RECHTS(A7;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B8 : =WAHL(TEIL(RECHTS(A8;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C8 : =SVERWEIS(RECHTS(A8;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B9 : =WAHL(TEIL(RECHTS(A9;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C9 : =SVERWEIS(RECHTS(A9;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B10 : =WAHL(TEIL(RECHTS(A10;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C10 : =SVERWEIS(RECHTS(A10;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
B11 : =WAHL(TEIL(RECHTS(A11;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C11 : =SVERWEIS(RECHTS(A11;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Die Grünlinge sollten weg.
Kann natürlich sein, dass ich es falsch verstanden habe.
Gruß Hübi
Bild

Betrifft: AW: noch eine Variante!
von: Josef Ehrensberger
Geschrieben am: 19.02.2005 20:25:52
Hallo Hübi!
Enteder mein Monitor spinnt, oder ich brauche eine neue Brille;-)
Vom Ergebnis ist aber deine Formel gleich wie meine!
Wenn schon dann so:

=SVERWEIS(RECHTS(A4;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)


Gruß Sepp
P.S.: Rückmeldung nicht vergessen!
Bild

Betrifft: AW: noch eine Variante!
von: Hübi
Geschrieben am: 19.02.2005 21:02:03
Hi Sepp,
du brauchst keine neue Brille - das war nicht meine Lösung ;-))
Hier habe ich alle bisherigen mal zusammengefasst
https://www.herber.de/forum/messages/572101.html (Sollte eigentlich als Antwort zu Franz)
Da ist deine letzte SVERWEIS() noch nicht dabei - die geht aber - clever!
Gruß Hübi
Bild

Betrifft: AW: und noch eine Variante :-)
von: FP
Geschrieben am: 19.02.2005 20:28:12
Hi Christian,
=TEIL("TAAMMSSS";REST(KÜRZEN(A1/10);10)+1;1)
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: das ist aber schon unverschämt.....
von: Josef Ehrensberger
Geschrieben am: 19.02.2005 20:47:28
...kurz;-))
Hallo Franz!

Gruß Sepp
Bild

Betrifft: AW: und was ist dann das ? :D
von: FP
Geschrieben am: 19.02.2005 21:01:42
Hi Sepp,
=TEIL("TAAMMSSS";LINKS(RECHTS(A1;2))+1;1)
3 Zeichen kürzer :-)
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: Suche Formel
von: Christian
Geschrieben am: 19.02.2005 21:00:43
Erst mal ein Fettes DANKE an euch alle.
Habe mich mal für die Version von Reinhard entschieden,
da die Formel am kürzesten ist.
=WAHL(TEIL(RECHTS(H7;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
Ich werde die anderen aber auch mal testen kann ja nicht schaden mal ein
wenig rum zu versuchen.
Vielen Dank nochmal,
Christian
Bild

Betrifft: AW: Suche Formel
von: Hübi
Geschrieben am: 19.02.2005 21:13:27
Hi Christian,
dann hast du deine Aufgabe wahrscheinlich nicht richtig beschrieben.
Hier sind alle Lösungen zusammen
Tabelle2
 ABCDEFGH
10101TTTTTTT
20109TTTTTTT
30010AA A A 
40011AAAAAAA
51020AA AAAA
61029AAAAAAA
71030MM M M 
80031MMMMMMM
90140MM MMMM
100049MMMMMMM
110050SS S S 
120051SSSSSSS
130160SS SSSS
140170SS SSSS
150079SSSSSSS
16 ReinhardSepp1RansiFranz1HübiFranz2Sepp2
17So war die Frage     clever
18Für die Werte XX01 - xx09 soll ein T erscheinen.  
19Für die Werte XX11 - xx29 soll ein A erscheinen.  
20Für die Werte XX31 - xx49 soll ein M erscheinen.  
21Für die Werte XX51 - xx79 soll ein S erscheinen.  
Formeln der Tabelle
B1 : =WAHL(TEIL(RECHTS(A1;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C1 : =SVERWEIS(RECHTS(A1;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D1 : =WENN(RECHTS(A1;1)="0";"";WAHL(TEIL(RECHTS(A1;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E1 : =TEIL("TAAMMSSS";REST(KÜRZEN(A1/10);10)+1;1)
F1 : =WENN(UND(RECHTS(A1;2)>"0";RECHTS(A1;2)<"10");"T";WENN(UND(RECHTS(A1;2)>"10";RECHTS(A1;2)<"30");"A";WENN(UND(RECHTS(A1;2)>"30";RECHTS(A1;2)<"50");"M";WENN(UND(RECHTS(A1;2)>"50";RECHTS(A1;2)<"80");"S";""))))
G1 : =TEIL("TAAMMSSS";LINKS(RECHTS(A1;2))+1;1)
H1 : =SVERWEIS(RECHTS(A1;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B2 : =WAHL(TEIL(RECHTS(A2;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C2 : =SVERWEIS(RECHTS(A2;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D2 : =WENN(RECHTS(A2;1)="0";"";WAHL(TEIL(RECHTS(A2;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E2 : =TEIL("TAAMMSSS";REST(KÜRZEN(A2/10);10)+1;1)
F2 : =WENN(UND(RECHTS(A2;2)>"0";RECHTS(A2;2)<"10");"T";WENN(UND(RECHTS(A2;2)>"10";RECHTS(A2;2)<"30");"A";WENN(UND(RECHTS(A2;2)>"30";RECHTS(A2;2)<"50");"M";WENN(UND(RECHTS(A2;2)>"50";RECHTS(A2;2)<"80");"S";""))))
G2 : =TEIL("TAAMMSSS";LINKS(RECHTS(A2;2))+1;1)
H2 : =SVERWEIS(RECHTS(A2;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B3 : =WAHL(TEIL(RECHTS(A3;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C3 : =SVERWEIS(RECHTS(A3;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D3 : =WENN(RECHTS(A3;1)="0";"";WAHL(TEIL(RECHTS(A3;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E3 : =TEIL("TAAMMSSS";REST(KÜRZEN(A3/10);10)+1;1)
F3 : =WENN(UND(RECHTS(A3;2)>"0";RECHTS(A3;2)<"10");"T";WENN(UND(RECHTS(A3;2)>"10";RECHTS(A3;2)<"30");"A";WENN(UND(RECHTS(A3;2)>"30";RECHTS(A3;2)<"50");"M";WENN(UND(RECHTS(A3;2)>"50";RECHTS(A3;2)<"80");"S";""))))
G3 : =TEIL("TAAMMSSS";LINKS(RECHTS(A3;2))+1;1)
H3 : =SVERWEIS(RECHTS(A3;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B4 : =WAHL(TEIL(RECHTS(A4;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C4 : =SVERWEIS(RECHTS(A4;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D4 : =WENN(RECHTS(A4;1)="0";"";WAHL(TEIL(RECHTS(A4;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E4 : =TEIL("TAAMMSSS";REST(KÜRZEN(A4/10);10)+1;1)
F4 : =WENN(UND(RECHTS(A4;2)>"0";RECHTS(A4;2)<"10");"T";WENN(UND(RECHTS(A4;2)>"10";RECHTS(A4;2)<"30");"A";WENN(UND(RECHTS(A4;2)>"30";RECHTS(A4;2)<"50");"M";WENN(UND(RECHTS(A4;2)>"50";RECHTS(A4;2)<"80");"S";""))))
G4 : =TEIL("TAAMMSSS";LINKS(RECHTS(A4;2))+1;1)
H4 : =SVERWEIS(RECHTS(A4;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B5 : =WAHL(TEIL(RECHTS(A5;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C5 : =SVERWEIS(RECHTS(A5;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D5 : =WENN(RECHTS(A5;1)="0";"";WAHL(TEIL(RECHTS(A5;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E5 : =TEIL("TAAMMSSS";REST(KÜRZEN(A5/10);10)+1;1)
F5 : =WENN(UND(RECHTS(A5;2)>"0";RECHTS(A5;2)<"10");"T";WENN(UND(RECHTS(A5;2)>"10";RECHTS(A5;2)<"30");"A";WENN(UND(RECHTS(A5;2)>"30";RECHTS(A5;2)<"50");"M";WENN(UND(RECHTS(A5;2)>"50";RECHTS(A5;2)<"80");"S";""))))
G5 : =TEIL("TAAMMSSS";LINKS(RECHTS(A5;2))+1;1)
H5 : =SVERWEIS(RECHTS(A5;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B6 : =WAHL(TEIL(RECHTS(A6;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C6 : =SVERWEIS(RECHTS(A6;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D6 : =WENN(RECHTS(A6;1)="0";"";WAHL(TEIL(RECHTS(A6;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E6 : =TEIL("TAAMMSSS";REST(KÜRZEN(A6/10);10)+1;1)
F6 : =WENN(UND(RECHTS(A6;2)>"0";RECHTS(A6;2)<"10");"T";WENN(UND(RECHTS(A6;2)>"10";RECHTS(A6;2)<"30");"A";WENN(UND(RECHTS(A6;2)>"30";RECHTS(A6;2)<"50");"M";WENN(UND(RECHTS(A6;2)>"50";RECHTS(A6;2)<"80");"S";""))))
G6 : =TEIL("TAAMMSSS";LINKS(RECHTS(A6;2))+1;1)
H6 : =SVERWEIS(RECHTS(A6;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B7 : =WAHL(TEIL(RECHTS(A7;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C7 : =SVERWEIS(RECHTS(A7;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D7 : =WENN(RECHTS(A7;1)="0";"";WAHL(TEIL(RECHTS(A7;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E7 : =TEIL("TAAMMSSS";REST(KÜRZEN(A7/10);10)+1;1)
F7 : =WENN(UND(RECHTS(A7;2)>"0";RECHTS(A7;2)<"10");"T";WENN(UND(RECHTS(A7;2)>"10";RECHTS(A7;2)<"30");"A";WENN(UND(RECHTS(A7;2)>"30";RECHTS(A7;2)<"50");"M";WENN(UND(RECHTS(A7;2)>"50";RECHTS(A7;2)<"80");"S";""))))
G7 : =TEIL("TAAMMSSS";LINKS(RECHTS(A7;2))+1;1)
H7 : =SVERWEIS(RECHTS(A7;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B8 : =WAHL(TEIL(RECHTS(A8;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C8 : =SVERWEIS(RECHTS(A8;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D8 : =WENN(RECHTS(A8;1)="0";"";WAHL(TEIL(RECHTS(A8;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E8 : =TEIL("TAAMMSSS";REST(KÜRZEN(A8/10);10)+1;1)
F8 : =WENN(UND(RECHTS(A8;2)>"0";RECHTS(A8;2)<"10");"T";WENN(UND(RECHTS(A8;2)>"10";RECHTS(A8;2)<"30");"A";WENN(UND(RECHTS(A8;2)>"30";RECHTS(A8;2)<"50");"M";WENN(UND(RECHTS(A8;2)>"50";RECHTS(A8;2)<"80");"S";""))))
G8 : =TEIL("TAAMMSSS";LINKS(RECHTS(A8;2))+1;1)
H8 : =SVERWEIS(RECHTS(A8;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B9 : =WAHL(TEIL(RECHTS(A9;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C9 : =SVERWEIS(RECHTS(A9;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D9 : =WENN(RECHTS(A9;1)="0";"";WAHL(TEIL(RECHTS(A9;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E9 : =TEIL("TAAMMSSS";REST(KÜRZEN(A9/10);10)+1;1)
F9 : =WENN(UND(RECHTS(A9;2)>"0";RECHTS(A9;2)<"10");"T";WENN(UND(RECHTS(A9;2)>"10";RECHTS(A9;2)<"30");"A";WENN(UND(RECHTS(A9;2)>"30";RECHTS(A9;2)<"50");"M";WENN(UND(RECHTS(A9;2)>"50";RECHTS(A9;2)<"80");"S";""))))
G9 : =TEIL("TAAMMSSS";LINKS(RECHTS(A9;2))+1;1)
H9 : =SVERWEIS(RECHTS(A9;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B10 : =WAHL(TEIL(RECHTS(A10;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C10 : =SVERWEIS(RECHTS(A10;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D10 : =WENN(RECHTS(A10;1)="0";"";WAHL(TEIL(RECHTS(A10;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E10 : =TEIL("TAAMMSSS";REST(KÜRZEN(A10/10);10)+1;1)
F10 : =WENN(UND(RECHTS(A10;2)>"0";RECHTS(A10;2)<"10");"T";WENN(UND(RECHTS(A10;2)>"10";RECHTS(A10;2)<"30");"A";WENN(UND(RECHTS(A10;2)>"30";RECHTS(A10;2)<"50");"M";WENN(UND(RECHTS(A10;2)>"50";RECHTS(A10;2)<"80");"S";""))))
G10 : =TEIL("TAAMMSSS";LINKS(RECHTS(A10;2))+1;1)
H10 : =SVERWEIS(RECHTS(A10;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B11 : =WAHL(TEIL(RECHTS(A11;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C11 : =SVERWEIS(RECHTS(A11;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D11 : =WENN(RECHTS(A11;1)="0";"";WAHL(TEIL(RECHTS(A11;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E11 : =TEIL("TAAMMSSS";REST(KÜRZEN(A11/10);10)+1;1)
F11 : =WENN(UND(RECHTS(A11;2)>"0";RECHTS(A11;2)<"10");"T";WENN(UND(RECHTS(A11;2)>"10";RECHTS(A11;2)<"30");"A";WENN(UND(RECHTS(A11;2)>"30";RECHTS(A11;2)<"50");"M";WENN(UND(RECHTS(A11;2)>"50";RECHTS(A11;2)<"80");"S";""))))
G11 : =TEIL("TAAMMSSS";LINKS(RECHTS(A11;2))+1;1)
H11 : =SVERWEIS(RECHTS(A11;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B12 : =WAHL(TEIL(RECHTS(A12;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C12 : =SVERWEIS(RECHTS(A12;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D12 : =WENN(RECHTS(A12;1)="0";"";WAHL(TEIL(RECHTS(A12;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E12 : =TEIL("TAAMMSSS";REST(KÜRZEN(A12/10);10)+1;1)
F12 : =WENN(UND(RECHTS(A12;2)>"0";RECHTS(A12;2)<"10");"T";WENN(UND(RECHTS(A12;2)>"10";RECHTS(A12;2)<"30");"A";WENN(UND(RECHTS(A12;2)>"30";RECHTS(A12;2)<"50");"M";WENN(UND(RECHTS(A12;2)>"50";RECHTS(A12;2)<"80");"S";""))))
G12 : =TEIL("TAAMMSSS";LINKS(RECHTS(A12;2))+1;1)
H12 : =SVERWEIS(RECHTS(A12;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B13 : =WAHL(TEIL(RECHTS(A13;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C13 : =SVERWEIS(RECHTS(A13;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D13 : =WENN(RECHTS(A13;1)="0";"";WAHL(TEIL(RECHTS(A13;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E13 : =TEIL("TAAMMSSS";REST(KÜRZEN(A13/10);10)+1;1)
F13 : =WENN(UND(RECHTS(A13;2)>"0";RECHTS(A13;2)<"10");"T";WENN(UND(RECHTS(A13;2)>"10";RECHTS(A13;2)<"30");"A";WENN(UND(RECHTS(A13;2)>"30";RECHTS(A13;2)<"50");"M";WENN(UND(RECHTS(A13;2)>"50";RECHTS(A13;2)<"80");"S";""))))
G13 : =TEIL("TAAMMSSS";LINKS(RECHTS(A13;2))+1;1)
H13 : =SVERWEIS(RECHTS(A13;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B14 : =WAHL(TEIL(RECHTS(A14;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C14 : =SVERWEIS(RECHTS(A14;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D14 : =WENN(RECHTS(A14;1)="0";"";WAHL(TEIL(RECHTS(A14;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E14 : =TEIL("TAAMMSSS";REST(KÜRZEN(A14/10);10)+1;1)
F14 : =WENN(UND(RECHTS(A14;2)>"0";RECHTS(A14;2)<"10");"T";WENN(UND(RECHTS(A14;2)>"10";RECHTS(A14;2)<"30");"A";WENN(UND(RECHTS(A14;2)>"30";RECHTS(A14;2)<"50");"M";WENN(UND(RECHTS(A14;2)>"50";RECHTS(A14;2)<"80");"S";""))))
G14 : =TEIL("TAAMMSSS";LINKS(RECHTS(A14;2))+1;1)
H14 : =SVERWEIS(RECHTS(A14;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
B15 : =WAHL(TEIL(RECHTS(A15;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";"")
C15 : =SVERWEIS(RECHTS(A15;2);{0."";"01"."T";"10"."A";"30"."M";"50"."S"};2;1)
D15 : =WENN(RECHTS(A15;1)="0";"";WAHL(TEIL(RECHTS(A15;2);1;1)+1;"T";"A";"A";"M";"M";"S";"S";"S";"";""))
E15 : =TEIL("TAAMMSSS";REST(KÜRZEN(A15/10);10)+1;1)
F15 : =WENN(UND(RECHTS(A15;2)>"0";RECHTS(A15;2)<"10");"T";WENN(UND(RECHTS(A15;2)>"10";RECHTS(A15;2)<"30");"A";WENN(UND(RECHTS(A15;2)>"30";RECHTS(A15;2)<"50");"M";WENN(UND(RECHTS(A15;2)>"50";RECHTS(A15;2)<"80");"S";""))))
G15 : =TEIL("TAAMMSSS";LINKS(RECHTS(A15;2))+1;1)
H15 : =SVERWEIS(RECHTS(A15;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hübi
Bild

Betrifft: AW: geht aber auch dann kürzer :-)
von: FP
Geschrieben am: 19.02.2005 21:36:01
Hi Hübi,
Tabelle3
 ABCD
1 FPSeppHübi
21109TTT
31110   
41120AAA
51130   
61140MMM
71150   
81160SSS
91179SSS
Formeln der Tabelle
B2 : =LINKS(TEIL("TAAMMSSS";LINKS(RECHTS(A2;2))+1;1);REST(A2;20)<>10)
C2 : =SVERWEIS(RECHTS(A2;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
D2 : =WENN(UND(RECHTS(A2;2)>"0";RECHTS(A2;2)<"10");"T";WENN(UND(RECHTS(A2;2)>"10";RECHTS(A2;2)<"30");"A";WENN(UND(RECHTS(A2;2)>"30";RECHTS(A2;2)<"50");"M";WENN(UND(RECHTS(A2;2)>"50";RECHTS(A2;2)<"80");"S";""))))
B3 : =LINKS(TEIL("TAAMMSSS";LINKS(RECHTS(A3;2))+1;1);REST(A3;20)<>10)
C3 : =SVERWEIS(RECHTS(A3;2);{"00"."";"01"."T";"10"."";"11"."A";"30"."";"31"."M";"50"."";"51"."S";"80".""};2;1)
D3 : =WENN(UND(RECHTS(A3;2)>"0";RECHTS(A3;2)<"10");"T";WENN(UND(RECHTS(A3;2)>"10";RECHTS(A3;2)<"30");"A";WENN(UND(RECHTS(A3;2)>"30";RECHTS(A3;2)<"50");"M";WENN(UND(RECHTS(A3;2)>"50";RECHTS(A3;2)<"80");"S";""))))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: geht aber auch dann kürzer :-)
von: Hübi
Geschrieben am: 19.02.2005 22:01:30
Hi Franz,
jetzt fehlt aber die 70
Aber insgesamt wie auch bei Sepp ganz clevere Lösungen ;-))
Bin gespannt, ob das auch so kurz geht.
Gruß Hübi
Bild

Betrifft: AW: fast schon so lang...
von: FP
Geschrieben am: 19.02.2005 22:16:26
Hi Hübi,
... wie die Lösung von Sepp ;-)
=LINKS(TEIL("TAAMMSSS";LINKS(RECHTS(A1;2))+1;1);(REST(A1+(A1=1170);20)<>10))
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: fast schon so lang...
von: Hübi
Geschrieben am: 19.02.2005 23:23:50
Hi Franz,
ich glaube, sie muss noch länger werden
Tabelle2
 AJ
110150 
120051S
131879S
141870 
151170S
Formeln der Tabelle
J11 : =LINKS(TEIL("TAAMMSSS";LINKS(RECHTS(A11;2))+1;1);(REST(A11+(A11=1170);20)<>10))
J12 : =LINKS(TEIL("TAAMMSSS";LINKS(RECHTS(A12;2))+1;1);(REST(A12+(A12=1170);20)<>10))
J13 : =LINKS(TEIL("TAAMMSSS";LINKS(RECHTS(A13;2))+1;1);(REST(A13+(A13=1170);20)<>10))
J14 : =LINKS(TEIL("TAAMMSSS";LINKS(RECHTS(A14;2))+1;1);(REST(A14+(A14=1170);20)<>10))
J15 : =LINKS(TEIL("TAAMMSSS";LINKS(RECHTS(A15;2))+1;1);(REST(A15+(A15=1170);20)<>10))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Den fetten Teil von REST(A15+(A15=1170);20)<>10 habe ich noch nicht richtig durchschaut, außer dass A15=xx70 WAHR werden muss - auch bei beliebigen xx.
Ist ein schöner Zeitvertreib ;-))
Gruß Hübi
Bild

Betrifft: AW: fast schon so lang...
von: FP
Geschrieben am: 19.02.2005 23:54:52
Hi Hübi,
Heute hat es mich mit dem lesen ;-)
=LINKS(TEIL("TAAMMSSS";TEIL(A2;3;1)+1;1);(REST(A2+10+(REST(A2;100)=70);20)))
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: geht es noch kürzer ?
von: FP
Geschrieben am: 20.02.2005 00:47:26
Hi Hübi,
=TEIL("TAAMMSSS";TEIL(A2;3;1)+1;REST(A2+(REST(A2;100)=70);20)<>10)
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: habe 00 vergessen :-(
von: FP
Geschrieben am: 20.02.2005 01:01:28
Hi Hübi,
=TEIL("TAAMMSSS";TEIL(A2;3;1)+1;(REST(A2+(REST(A2;100)=70);20)<>10)*(REST(A2;100)<>0))
ist aber immer noch kürzer als die von Sepp :-)
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: AW: kürzer
von: FP
Geschrieben am: 20.02.2005 01:19:52
Hi Hübi,
dann ist die Idee von Sepp in anderer Schreibweise wieder die kürzere Variante:
=VERWEIS(REST(A2;100);{0.1.10.11.30.31.50.51.80};{""."T".""."A".""."M".""."S".""})
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: jetzt warte ich nur noch bis.....
von: Josef Ehrensberger
Geschrieben am: 20.02.2005 01:25:51
... du die Formel auf "=FP(A1)" verkürzt;-))
Ich wünsch dir eine gute Nacht,
Gruß Sepp
Bild

Betrifft: AW: noch kürzer
von: FP
Geschrieben am: 20.02.2005 01:25:16
Hi Hübi,
=TEIL(" T A M S ";VERGLEICH(REST(A2;100);{0.1.10.11.30.31.50.51.80};1);1)
und jetzt lass ich's :-)
Servus aus dem Salzkammergut
Franz
Bild

Betrifft: Gratulation - unschlagbar kurz
von: Hübi
Geschrieben am: 20.02.2005 11:50:57
Hi Franz,
diese Version =TEIL("TAAMMSSS";TEIL(A2;3;1)+1;(REST(A2+(REST(A2;100)=70);20)<>10)*(REST(A2;100)<>0)) lieferte auch noch Fehler.
Die letzte =TEIL(" T A M S ";VERGLEICH(REST(A2;100);{0.1.10.11.30.31.50.51.80};1);1) ist absolut Spitze.
Gruß Hübi
Bild

Betrifft: AW: geht aber auch dann kürzer :-)
von: Reinhard
Geschrieben am: 19.02.2005 22:43:34
Hallöchen,
habe auch noch ein wenig rumgespielt.
Fehlerüberprüfung wurde ja arg vernachlässigt bisher *g
"-" ---- Zahl okay, aber Ziffer gehört nicht zu 0...7
"?" ---- keine Zahl, nur einstellig usw
Tabellenblattname: Tabelle1
      A   |        B        |     C      | 
 1|       | Mit Fehlercheck | Kaum Check | 
 2|  1100 |               T |          T | 
 3|  1110 |               A |          A | 
 4|  1120 |               A |          A | 
 5|  1130 |               M |          M | 
 6|  1140 |               M |          M | 
 7|  1150 |               S |          S | 
 8|  1160 |               S |          S | 
 9|  1170 |               S |          S | 
10|  1180 |               - |          - | 
11|  1190 |               - |          - | 
12|     1 |               ? |            | 
13|    xx |               ? |            | 
14|    a1 |               ? |            | 
15|    1a |               ? |            | 
16| -2457 |               S |            | 
17|       |               ? |            | 
Benutzte Formeln:
B2:  =F
B3:  =F
B4:  =F
B5:  =F
B6:  =F
B7:  =F
B8:  =F
B9:  =F
B10:  =F
B11:  =F
B12:  =F
B13:  =F
B14:  =F
B15:  =F
B16:  =F
B17:  =F
C2:  =TT
C3:  =TT
C4:  =TT
C5:  =TT
C6:  =TT
C7:  =TT
C8:  =TT
C9:  =TT
C10:  =TT
C11:  =TT
Namen in der Tabelle:
F :  =WENN((Tabelle1!A2<>"")*(LÄNGE(Tabelle1!A2)>1)*(ISTZAHL(Tabelle1!A2));T;"?")
T :  =TEIL("TAAMMSSS--";LINKS(RECHTS(Tabelle1!A2;2))+ISTZAHL(Tabelle1!A2);1)
TT:  =TEIL("TAAMMSSS--";LINKS(RECHTS(Tabelle1!A2;2))+ISTZAHL(Tabelle1!A2);1)
Grade festgestellt, bei Namen treibt die A1Schreibweise seltsame Blüten, 
bzw. war dieses Verhalten mir neu. 
Allerdings, jenachdem in welcher zelle ich stehe und mir die Namen anschaue, sind dort andere Bezüge.
Mein Makro schrieb jedenfalls überall in den 3 namen anstatt Tabelle1!A2 Tabelle1!IV1.
Naja, mal schauen wie das in den Griff zu kriegen ist :-) 
Gruß
Reinhard

Bild

Betrifft: AW: geht aber auch dann kürzer :-)
von: Hübi
Geschrieben am: 19.02.2005 23:32:52
Hi Reinhard,
eine Fehlerüberprüfung ist aus meiner Sicht nicht nötig
In Spalte H stehen nicht sortiert, die Werte 0101 - 1879
Werde morgen noch ein bischen an Franz´s Lösung spielen - ist auch sehr interessant.
Vielleicht komme ich dann irgenwann von meinen langen Formeln weg.
Ganz clever war ja wieder Sepp ;-))
Gruß Hübi
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Suche Formel"