teilergebnisse

Bild

Betrifft: teilergebnisse von: gunther
Geschrieben am: 22.02.2005 09:04:29

eine tabellenspalte soll analysiert werden nach SUMME;MIN;MAX;ANZAHL;MITTELWERT
das geht ganz einfach.
nun soll jedoch nicht die gesamte spalte ausgewertet werden, sondern von den werten werden die äußeren z.B. 10% "abgeschnitten". auch dass klappt mit der array-formel:
{=MITTELWERT(KKLEINSTE(erg;ZEILE(INDIREKT($G$19&":"&(ANZAHL(erg)-$G$19)))))}
in $G$19 steht die anzahl der "abzuschneidenen" zeilen
erg ist der name für die ergebnisspalte (=bw*100/bwr) nur genau für die mit zahlen belegten zeilen manuell festgelegt, da sonst bei leeren bzw. text-feldern fehlermeldung erfolgt

jetzt soll die formel aber auch bei einem auto-filter richtig rechnen. ich verzweifle bald bei den versuchen mit dem teilergebnis.

am liebsten würde ich die erg - spalte gar nicht in die rohdatentabelle einfügen, sondern das ergebnis nur in der analyse verwenden (erg=bw*100/bwr).

wer kann helfen? vielen dank gunther

Bild


Betrifft: AW: teilergebnisse von: MichaV
Geschrieben am: 22.02.2005 09:12:02

Hi,

wenn Du die ausgeblendeten Zellen mitrechnen willst, nimm =SUMME
wenn Du nur die sichtbaren Zellen rechnen willst, nimm =TEILERGEBNIS

Gruß


Bild


Betrifft: AW: teilergebnisse von: gunther
Geschrieben am: 22.02.2005 09:28:46

das habe ich ja in den unterschiedlichsten varianten versucht. aber leider ohne erfolg.

{=MIN(TEILERGEBNIS(9;..???)}
{=SUMME(TEILERGEBNIS(9;..???)} oder auch
=SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT ????

wie bekomme ich nun meinen filter in die formel?

ganz verstanden habe ich diese verschachtelung auch noch nicht, da es zur summenberechnen auch mit 1 statt 9 als funktion zu teilergebnis richtig rechnet.


Bild


Betrifft: AW: teilergebnisse von: MichaC
Geschrieben am: 22.02.2005 09:41:56

Hi,

vielleicht solltest Du mal ne Beispieldatei hochladen.

Gruß


Bild


Betrifft: AW: teilergebnisse von: gunther
Geschrieben am: 22.02.2005 10:02:21

hallo micha,

vielen dank für die schnelle reaktion. ich hab jetzt eine musterdatei auf den server hochgeladen. sie steht unter:https://www.herber.de/bbs/user/18496.xls

gruß gunther


Bild


Betrifft: AW: teilergebnisse von: gunther
Geschrieben am: 22.02.2005 10:32:03

hallo
ich sende den link nochmal (er hat automatisch das wort davor mit verlinkt?):

https://www.herber.de/bbs/user/18496.xls


Bild


Betrifft: AW: teilergebnisse von: Stefan
Geschrieben am: 22.02.2005 10:23:42

Hallo Gunther,

konnte deine Datei leider nicht öffnen,
aber den Min-Wert bei den Teilergebnissen
zeigt du zum Beispiel so an:

=Teilergebnis(5;B1:B1000)

(siehe Hilfe zum Teilergebnis)

Gruß Stefan


Bild


Betrifft: AW: teilergebnisse von: MichaV
Geschrieben am: 22.02.2005 10:16:12

Oh,

sorry, das ist noch nicht meine Liga ;o)

Ich mach die Frage mal wieder auf und bin gespannt auf die Antworten.

Viel Erfolg!


Bild


Betrifft: AW: teilergebnisse von: MichaV
Geschrieben am: 22.02.2005 10:16:14

Oh,

sorry, das ist noch nicht meine Liga ;o)

Ich mach die Frage mal wieder auf und bin gespannt auf die Antworten.

Viel Erfolg!


 Bild

Beiträge aus den Excel-Beispielen zum Thema "teilergebnisse"