Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
572to576
572to576
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

teilergebnisse

teilergebnisse
22.02.2005 09:04:29
gunther
eine tabellenspalte soll analysiert werden nach SUMME;MIN;MAX;ANZAHL;MITTELWERT
das geht ganz einfach.
nun soll jedoch nicht die gesamte spalte ausgewertet werden, sondern von den werten werden die äußeren z.B. 10% "abgeschnitten". auch dass klappt mit der array-formel:
{=MITTELWERT(KKLEINSTE(erg;ZEILE(INDIREKT($G$19&":"&(ANZAHL(erg)-$G$19)))))}
in $G$19 steht die anzahl der "abzuschneidenen" zeilen
erg ist der name für die ergebnisspalte (=bw*100/bwr) nur genau für die mit zahlen belegten zeilen manuell festgelegt, da sonst bei leeren bzw. text-feldern fehlermeldung erfolgt
jetzt soll die formel aber auch bei einem auto-filter richtig rechnen. ich verzweifle bald bei den versuchen mit dem teilergebnis.
am liebsten würde ich die erg - spalte gar nicht in die rohdatentabelle einfügen, sondern das ergebnis nur in der analyse verwenden (erg=bw*100/bwr).
wer kann helfen? vielen dank gunther

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: teilergebnisse
MichaV
Hi,
wenn Du die ausgeblendeten Zellen mitrechnen willst, nimm =SUMME
wenn Du nur die sichtbaren Zellen rechnen willst, nimm =TEILERGEBNIS
Gruß
AW: teilergebnisse
gunther
das habe ich ja in den unterschiedlichsten varianten versucht. aber leider ohne erfolg.
{=MIN(TEILERGEBNIS(9;..?)}
{=SUMME(TEILERGEBNIS(9;..?)} oder auch
=SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT ?
wie bekomme ich nun meinen filter in die formel?

ganz verstanden habe ich diese verschachtelung auch noch nicht, da es zur summenberechnen auch mit 1 statt 9 als funktion zu teilergebnis richtig rechnet.
AW: teilergebnisse
MichaC
Hi,
vielleicht solltest Du mal ne Beispieldatei hochladen.
Gruß
Anzeige
AW: teilergebnisse
Stefan
Hallo Gunther,
konnte deine Datei leider nicht öffnen,
aber den Min-Wert bei den Teilergebnissen
zeigt du zum Beispiel so an:
=Teilergebnis(5;B1:B1000)
(siehe Hilfe zum Teilergebnis)
Gruß Stefan
Anzeige
AW: teilergebnisse
MichaV
Oh,
sorry, das ist noch nicht meine Liga ;o)
Ich mach die Frage mal wieder auf und bin gespannt auf die Antworten.
Viel Erfolg!
AW: teilergebnisse
MichaV
Oh,
sorry, das ist noch nicht meine Liga ;o)
Ich mach die Frage mal wieder auf und bin gespannt auf die Antworten.
Viel Erfolg!

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige