Verzwickte Verweis Funktion

Bild

Betrifft: Verzwickte Verweis Funktion von: Marc
Geschrieben am: 22.02.2005 10:48:50

Hallo zusammen,

ich habe folgendes Problem:

Ich möchte in einer Zelle einen Verweiswert ausgeben. Der Nutzer kann in einer bestimmten Zelle einen Wert für die Kalenderwoche angeben (bspw. 24). Dieser Wert soll die dann die Grundlage für den Verweis sein, d.h. Excel soll in einer anderen Zeile den Wert "24" suchen und innerhalb dieser Spalte den Wert einer wieder anderen Zeile zurückgeben (das ist der gesuchte Verweis).

Zur Veranschaulichung bitte die angehängte Datei ansehen.

https://www.herber.de/bbs/user/18500.xls


Wie muss die Formel im Verweisfeld lauten?

Vielen Dank für Eure Hilfe!!!!

Gruß
Marc

Bild


Betrifft: =WVERWEIS(B2;B4:F6;3;) von: Boris
Geschrieben am: 22.02.2005 10:52:40

Grüße Boris


Bild


Betrifft: AW: =WVERWEIS(B2;B4:F6;3;) von: Marc
Geschrieben am: 22.02.2005 11:06:48

Hi Boris,

besten Dank für Deine schnelle Antwort. Passt genau!

Nun hätte ich aber noch eine kleine Modifkation: Falls in dem Datenfeld ein #NV-Wert steht, soll der nächste links gelegene Zahlenwert genommen werden, d.h. wenn in KW 24 und auch KW 23 nur #NVs sind, dann nehme KW22 (erster Zahlenwert).

Vielleicht kannst Du mir ja nochmal helfen ;)

Danke im Voraus und viele Grüße
Marc


Bild


Betrifft: Mit Fehlerwerten von: Boris
Geschrieben am: 22.02.2005 11:37:19

Hi Marc,

wenn in der Ergebniszeile IMMER nur ZAHLEN oder Fehlerwerte stehen, dann folgende Array-Formel:

{=INDEX(6:6;MIN(MAX(ISTZAHL(6:6)*SPALTE(1:1));VERGLEICH(B2;4:4;)))}

{geschweifte Klammern} nicht eingeben, sondern Formeleingabe mit gleichzeitig Strg-Shift-Enter abschließen. Das erzeugt sie.

Grüße Boris


Bild


Betrifft: Modifizierung mit Fehlerwerten von: Boris
Geschrieben am: 22.02.2005 11:57:18

Hi Marc,

...denn wenn in deiner Datenzeile NACH der gesuchten KW noch weitere Zahlen kommen, dann liefert die erste Formel falsche Ergebnisse.
Daher muss der Beriech noch eingeschränkt werden - das passiert hier (auch Arrayormel):

{=INDEX(6:6;MIN(MAX(ISTZAHL(BEREICH.VERSCHIEBEN(A6;;;;VERGLEICH(B2;4:4;)))*MTRANS(ZEILE(INDIREKT("1:"&VERGLEICH(B2;4:4;)))));VERGLEICH(B2;4:4;)))}

Grüße Boris


Bild


Betrifft: Ich bin wohl etwas durch die Tüte... von: Boris
Geschrieben am: 22.02.2005 12:18:37

Hi Marc,

...das MIN ist völlig sinnlos (stört allerdings auch nicht):

{=INDEX(6:6;MAX(ISTZAHL(BEREICH.VERSCHIEBEN(A6;;;;VERGLEICH(B2;4:4;)))*MTRANS(ZEILE(INDIREKT("1:"&VERGLEICH(B2;4:4;))))))}

Das war´s jetzt aber...

Grüße Boris


Bild


Betrifft: AW: Ich bin wohl etwas durch die Tüte... von: Marc
Geschrieben am: 22.02.2005 12:46:27

Hast mir wirklich sehr geholfen, Boris.

Besten Dank nochmal!!!!!

Gruß
Marc


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Verzwickte Verweis Funktion"