Herbers Excel-Forum - das Archiv

Wenn Feld gleich null

Bild

Betrifft: Wenn Feld gleich null
von: steve

Geschrieben am: 22.02.2005 15:54:45
Hallo,
ich habe folgende Formel:
=WENN(WVERWEIS("Vertragsnotiz";Importdateien!$A$2:$IM$3;2;0)="0";"";
WVERWEIS("Vertragsnotiz";Importdateien!$A$2:$IM$3;2;0))
Sie soll bezwecken, dass wenn der Eintrag Vertragsnotiz gleich 0 ist soll er mit "" - leere Menge anzeigen, also auf keinen Fall 0. Wenn was anderes in der Zelle steht, soll er mir deren Inhalt wiedergeben.
Was ist an der Formel falsch?
MfG
Steve
Bild

Betrifft: AW: Wenn Feld gleich null
von: Dr.
Geschrieben am: 22.02.2005 15:56:00
Grundätzlich ist die Formel unnötig. Du kannst in den Extras|Optionen|Ansicht einstellen, dass Nullwerte nicht angezeigt werden sollen.
Bild

Betrifft: AW: Wenn Feld gleich null
von: steve

Geschrieben am: 22.02.2005 16:07:47
Ich habe es über eine Zwischenstation gelöst. Den Vorschlag kann ich leider so nicht verwenden, da an andere Stelle die Nullstellen angezeigt werden müssen.
MfG
Steve
P.S.: Die Lösung ist folgende. Wenn ich mit der Formel =WVERWEIS("Vertragsnotiz";Importdateien!$A$2:$IM$3;2;0) ziehe und das Feld leer ist, gibt er mir den Wert 0 aus. Also ist die logische Konsequenz, dass ich das erst noch über ein anderes Tabellenblatt laufen lasse. Heißt: Ich füge die o.a. Formel unter dem Blatt Verknüpfungen ein, und dann hole ich mir denn Inhalt mit der im ersten Beitrag aufgeführten wenn Formel (leicht abgewandelt)
Bild

Betrifft: AW: Wenn Feld gleich null
von: steve
Geschrieben am: 22.02.2005 16:08:07
o.T.
 Bild
Excel-Beispiele zum Thema "Wenn Feld gleich null"
Zellen vergleichen und markieren Tabellen vergleichen
Tabellenvergleich und Übernahme der Doppel Spalten A und B vergleichen und Doppel in C listen
Werte vergleichen Bereiche auf Übereinstimmung vergleichen
Daten in jeweils einer Spalte zweier Tabellen vergleichen SVERWEIS, WVERWEIS, INDEX, VERGLEICH und Zielwertsuche
Gleiche Zufallszahlen zählen und in Diagramm anzeigen Werte vergleichen und Ergebnis in Tabelle eintragen