WENN Text

Bild

Betrifft: WENN Text
von: Stefan
Geschrieben am: 23.02.2005 11:47:32
Ich habe folgendes Problem. Habe schon diverse Beiträge durchgeschaut in der Hoffnung die Lösung zu finden aber vergebens.
Ich habe eine Tabelle in der z.B. in Spalte A folgendes steht = Hardware A, Hardware B, A ( Hardware ), C Hardware, Software A ( Software ) B..... etc., in Spalte B steht der netto Preis
Nun versuche ich mit der WENN Funk. zu erreichen das ich in Spalte C nur die Netto-Preise habe wo die Bezeichnung unter Spalte A Hardware ist und in Spalte D nur die Preise mit der Bezeichnung Software aus Spalte A.
Wie muss die Formel aussehen????
Bin Anfänger :-(

Bild

Betrifft: Lade mal ein Beispiel hoch....... oT.
von: Bastelpeter
Geschrieben am: 23.02.2005 11:52:48
..
Bild

Betrifft: AW: WENN Text
von: HermannZ
Geschrieben am: 23.02.2005 12:01:31
Hallo Stefan,
meinst du das so???
Beispiel;
LeerB
 ABCD
42    
43  HardwareSoftware
44Hardware A123123 
45Software 1124 124
46Hardware B125125 
47Software 2126 126
48Hardware C127127 
49Software 3128 128
50Hardware129129 
51Software130 130
52Hardware A131131 
53Software132 132
54    
Formeln der Tabelle
C44 : =WENN(ISTFEHLER(FINDEN("Hardware";A44));"";B44)
D44 : =WENN(ISTFEHLER(FINDEN("Software";A44));"";B44)
C45 : =WENN(ISTFEHLER(FINDEN("Hardware";A45));"";B45)
D45 : =WENN(ISTFEHLER(FINDEN("Software";A45));"";B45)
C46 : =WENN(ISTFEHLER(FINDEN("Hardware";A46));"";B46)
D46 : =WENN(ISTFEHLER(FINDEN("Software";A46));"";B46)
C47 : =WENN(ISTFEHLER(FINDEN("Hardware";A47));"";B47)
D47 : =WENN(ISTFEHLER(FINDEN("Software";A47));"";B47)
C48 : =WENN(ISTFEHLER(FINDEN("Hardware";A48));"";B48)
D48 : =WENN(ISTFEHLER(FINDEN("Software";A48));"";B48)
C49 : =WENN(ISTFEHLER(FINDEN("Hardware";A49));"";B49)
D49 : =WENN(ISTFEHLER(FINDEN("Software";A49));"";B49)
C50 : =WENN(ISTFEHLER(FINDEN("Hardware";A50));"";B50)
D50 : =WENN(ISTFEHLER(FINDEN("Software";A50));"";B50)
C51 : =WENN(ISTFEHLER(FINDEN("Hardware";A51));"";B51)
D51 : =WENN(ISTFEHLER(FINDEN("Software";A51));"";B51)
C52 : =WENN(ISTFEHLER(FINDEN("Hardware";A52));"";B52)
D52 : =WENN(ISTFEHLER(FINDEN("Software";A52));"";B52)
C53 : =WENN(ISTFEHLER(FINDEN("Hardware";A53));"";B53)
D53 : =WENN(ISTFEHLER(FINDEN("Software";A53));"";B53)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
Bild

Betrifft: AW: WENN Text
von: Stefan
Geschrieben am: 23.02.2005 12:18:07
danke dir, das hat geklappt, gar nicht so schwer wie es ausschaut.
habe ich auch die möglichkeit mehrere suchkreterien in dieser formel einzubauen?
wenn zum beispiel in einer spalte statt hardware ein firmenname steht welches eigentlich hardware sein sollte?
Bild

Betrifft: AW: WENN Text
von: heikoS
Geschrieben am: 23.02.2005 12:35:20
Hallo Stefan,
meinst Du so:
=WENN(ISTFEHLER(UND(FINDEN("hardware";A1);FINDEN("firmenname";A1)));"";B1)
alternativ halt mit ..(oder(finden(...

Gruß Heiko
Bild

Betrifft: AW: WENN Text
von: HermannZ
Geschrieben am: 23.02.2005 12:43:22
Hallo Stefan,
das ganze mit einer zweiten Abfrage;
Beispiel;
LeerB
 ABCD
42    
43  HardwareSoftware
44Hardware A123123 
45Software 1124 124
46Hardware B125125 
47Software 2126 126
48Hardware C127127 
49Software 3128 128
50Hardware129129 
51Software130 130
52Hardware A131131 
53Software132 132
54Siemens133133 
Formeln der Tabelle
C44 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A44));ISTFEHLER(FINDEN("Siemens";A44)));"";B44)
D44 : =WENN(ISTFEHLER(FINDEN("Software";A44));"";B44)
C45 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A45));ISTFEHLER(FINDEN("Siemens";A45)));"";B45)
D45 : =WENN(ISTFEHLER(FINDEN("Software";A45));"";B45)
C46 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A46));ISTFEHLER(FINDEN("Siemens";A46)));"";B46)
D46 : =WENN(ISTFEHLER(FINDEN("Software";A46));"";B46)
C47 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A47));ISTFEHLER(FINDEN("Siemens";A47)));"";B47)
D47 : =WENN(ISTFEHLER(FINDEN("Software";A47));"";B47)
C48 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A48));ISTFEHLER(FINDEN("Siemens";A48)));"";B48)
D48 : =WENN(ISTFEHLER(FINDEN("Software";A48));"";B48)
C49 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A49));ISTFEHLER(FINDEN("Siemens";A49)));"";B49)
D49 : =WENN(ISTFEHLER(FINDEN("Software";A49));"";B49)
C50 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A50));ISTFEHLER(FINDEN("Siemens";A50)));"";B50)
D50 : =WENN(ISTFEHLER(FINDEN("Software";A50));"";B50)
C51 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A51));ISTFEHLER(FINDEN("Siemens";A51)));"";B51)
D51 : =WENN(ISTFEHLER(FINDEN("Software";A51));"";B51)
C52 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A52));ISTFEHLER(FINDEN("Siemens";A52)));"";B52)
D52 : =WENN(ISTFEHLER(FINDEN("Software";A52));"";B52)
C53 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A53));ISTFEHLER(FINDEN("Siemens";A53)));"";B53)
D53 : =WENN(ISTFEHLER(FINDEN("Software";A53));"";B53)
C54 : =WENN(UND(ISTFEHLER(FINDEN("Hardware";A54));ISTFEHLER(FINDEN("Siemens";A54)));"";B54)
D54 : =WENN(ISTFEHLER(FINDEN("Software";A54));"";B54)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
Bild

Betrifft: AW: WENN Text
von: Stefan
Geschrieben am: 23.02.2005 14:27:36
Vielen lieben dank für eure hilfe, aber leider ist aller anfang schwer.
danke nochmals
Bild

Betrifft: AW: WENN Text
von: heikoS
Geschrieben am: 23.02.2005 14:43:35
Hallo Stefan,
kein Problem. Danke für die Rückmeldung.
Gruß Heiko
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeilenumbrüche Alt Enter ersetzen"