2 Spalten !

Bild

Betrifft: 2 Spalten !
von: Tobi
Geschrieben am: 23.02.2005 14:14:59
Hallo,
ich habe folgendes Problem
Beispiel:
Ich habe 2 Spalten und ich möchte wenn der Wert größer Null ist, ein Resultat haben und zwar 2. Wieso 2 weil in 2 Spalten etwas steht.
Ziel:
Wochenkalender
und es sollen nur die Samstags(Spalte)des Monats gerechnet werden
aber nur wenn die Spalte einen Inhalt hat
Siehe Bild...
Versuch:
=ZÄHLENWENN(A1:D1;">0")
Dies funktioniert aber nur für den ganzen Bereich
=ZÄHLENWENN(A1+D1;">0")
geht leider nicht );

Bild

Betrifft: Excel-Profi - VBA gut????
von: Level
Geschrieben am: 23.02.2005 14:52:56
lad doch mal ne Beispielmappe hoch
Bild

Betrifft: AW: 2 Spalten !
von: heikoS
Geschrieben am: 23.02.2005 15:02:15
Hallo Tobi,
so ganz verstanden habe ich das Problem nicht, aber vielleicht geht´s ja so:
=SUMMENPRODUKT((A1:A100>0)*(D1:D100>0))
Rückmeldung?

Gruß Heiko
Bild

Betrifft: AW: 2 Spalten !
von: tobias
Geschrieben am: 23.02.2005 15:18:09
Danke Heiko,
Ich habe das *(Mal) einfach durch Plus(+) ersetzt und schon gehts....
Jetzt muss ich kein VBA-Prog schreiben,,,, SUPIE
DANKE!!!!
=SUMMENPRODUKT((A1:A100>0)+(D1:D100>0))
Bild

Betrifft: ZÄHLENWENN mit diskontinuierlichen Bereichen
von: Boris
Geschrieben am: 23.02.2005 15:57:47
Hi Tobi,
auch wenn schon gelöst:
Falls du mal in die richtige Verlegenheit kommen solltest, und ZÄHLENWENN auf nicht zusammenhängende (diskontinuierliche) Bereiche anwenden musst, dann geht das auch mit folgender Syntax:
=SUMME(ZÄHLENWENN(INDIREKT({"A1"."D1"."H12:H20"});">0"))
Zählt alle Einträge größer Null in A1, D1 und H12:H20.
Grüße Boris
Bild

Betrifft: Die ist wieder einmal ...
von: heikoS
Geschrieben am: 23.02.2005 16:41:34
... richtig gut. Denn "die Verlegenheit" ist bereits da.
Danke Boris. Auf Eurer HP hatte ich sie bisher übersehen.
:-)
Gruß Heiko
 Bild

Beiträge aus den Excel-Beispielen zum Thema "2 Spalten !"