Herbers Excel-Forum - das Archiv

Sprachwechsel in Funktion vermeiden

Bild

Betrifft: Sprachwechsel in Funktion vermeiden
von: Namei

Geschrieben am: 24.02.2005 05:19:47
hallo,
folgendes Problem zunaechst einfach erlaeutert:
Habe in ein paar Zellen eine Funktion aufgestellt, die den Monat erkennt und ihn in die Zellen schreibt. Diese Excel-Tabelle ist wiederum in ein Word-file eingelassen.
Die Datei wird von deutschen, englischen und chinesischen Anwendern genutzt. Somit verandert sich die Ausgabe der Monate je nachdem an welchem (verschiedensprachigen) Arbeitsplatz die Datei geoeffnet wird.
Frage:
Wie schaffe ich es, dass die Monate immer nur in Englisch ausgegeben werden?
(sollte auf alle neueren EXCEL-Versionen anwendbar sein!)
Bild

Betrifft: AW: Sprachwechsel in Funktion vermeiden
von: bst

Geschrieben am: 24.02.2005 08:19:30
Morgen Namei,
am einfachsten ist es vermutlich eine eigene Monatsbestimmung zu machen.
Wenn in A1 ein Monat als Zahl steht, nimm sowas:
=SVERWEIS(A1;tabMonate;2;FALSCH)
und definiere irgendwo in Deiner Mappe eine 2-spaltige Tabelle als tabMonate (via Einfügen-Namen-Definieren) welche in der 1. Spalte den Monat als Zahl und in der 2. Spalte den von Dir gewünschten Text enthält.
Gruß, Bernd
 Bild
Excel-Beispiele zum Thema "Sprachwechsel in Funktion vermeiden"
Funktion ANZAHL2 ohne ausgeblendete Spalten Mit der Indirekt-Funktion auf geschlossene Arbeitsmappe zugreifen
Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche Alle Prozeduren und Funktionen auflisten
In Funktionskategorie einordnen Ausgabe einer benutzerdefinierten Funktion in Matrixformel
Benutzerdefinierte Funktion durch Code erstellen und löschen Ermittlung von Entfernungen über benutzerdefinierte Funktion
Handhabung von Arrays in benutzerdefininierten Funktionen Arbeitsmappen-Titel über benutzerdefinierte Funktion