Herbers Excel-Forum - das Archiv

Ein neuer Laufzeitfehler beim Makro!

Bild

Betrifft: Ein neuer Laufzeitfehler beim Makro!
von: Emu

Geschrieben am: 24.02.2005 11:44:28
Moin!
Habe mir ein Makro gebastelt, welches Werte-Paare in einer Tabelle anhand bestimmter Kriterien durch Grafiken ersetzt. Eine genauere Erklärung erspar ich mir, lade lieber eine gekürzte Tabelle hoch (mit den passenden Grafiken, zusammen 33 kb, https://www.herber.de/bbs/user/18661.zip ). Dann können sich interessierte das mal anschauen.
Nachdem ich endlich einen Laufzeitfehler in meinem Makro erledigt hatte, kam ein Stück später schon der nächste: "Laufzeitfehler '1004': Die Methode 'Range' für das Objekt '_Global' ist fehlgeschlagen". Aber warum nur?
Vielleicht kann mir jemand weiterhelfen? Ist mein erstes Makro in Excel und ganz schön anstrengend...
Schöne Grüße,
Emu
Bild

Betrifft: AW: Ein neuer Laufzeitfehler beim Makro!
von: Cardexperte

Geschrieben am: 25.02.2005 15:42:41
Hello emu,
also die Spalte "B@" die kann es nicht geben, deshalb der Fehler, die Spalte setzt du doch aus B und dann irgendwie mit dem Ascii-zeichen zusammen, dort liegt auch der Fehler, so richtig verstehe ich nicht warum die Zeilen mit diesem Ascii zeichen zusammengesetzt wird, kannst du nicht zu Steuerung dies mit den Zeilen und Spaltennummern machen also mit cells und nicht mit a1 und b1 usw.
Gruss WS
 Bild
Excel-Beispiele zum Thema "Ein neuer Laufzeitfehler beim Makro!"
Fortlaufende Suche unter Vermeidung eines Laufzeitfehlers