frage zu anzahl2

Bild

Betrifft: frage zu anzahl2 von: alex k
Geschrieben am: 25.02.2005 21:08:40

Hallo habe da mal eine frage.
Diese funkton zählt alle zellen in denen texte oder Zahlen vorhanden sind.
Wie kann ich es umgehen das wenn z.B in dem Bereich A1 bis A10 formeln stehen die aber als ergebniss "" haben also in der zelle kein wert steht das diese Funktion anzahl2 auch 0 als ergebniss anzeigt und nicht alle werte zählt auch wenn nur formeln in der zelle stehen die nichts anzeigen.? danke


=(ANZAHL2(A1:A10))

Bild


Betrifft: AW: frage zu anzahl2 von: Ramses
Geschrieben am: 25.02.2005 21:24:39

Hallo

nicht schön aber funktioniert

 
 GH
11 
2 3
31 
41 
Formeln der Tabelle
G2 : =WENN(F2="";"";F2)
H2 : =ANZAHL2(G1:G4)-ZÄHLENWENN(G1:G4;"")
 
Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Gruss Rainer


Bild


Betrifft: AW: frage zu anzahl2 von: HermannZ
Geschrieben am: 25.02.2005 21:30:16

Hallo Alex,

noch eine variante;

Beispiel;

Rang
 AB
126  
127 1
128  
129  
130  
131  
13212 
Formeln der Tabelle
A127 : =WENN($A$1="";"";)
B127 : {=SUMME(WENN(A127:A132="";0;1))}
A128 : =WENN($A$1="";"";)
A129 : =WENN($A$1="";"";)
A130 : =WENN($A$1="";"";)
A131 : =WENN($A$1="";"";)

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


Bild


Betrifft: AW: frage zu anzahl2 von: alex k
Geschrieben am: 25.02.2005 21:37:57

Also vielen dank.
Aber wie funktioniert diese formel ?
Weil summe will ich ja nicht ich will nur die anzahl.
Und das macht die formel auch richtig aber warum ?
Danke


Bild


Betrifft: Hier werden doch nur Einser summiert... von: Boris
Geschrieben am: 25.02.2005 21:46:47

Hi Alex,

...und demzufolge ist das nix anderes als zählen.

Grüße Boris


Bild


Betrifft: AW: frage zu anzahl2 von: Hübi
Geschrieben am: 25.02.2005 21:34:16

Hi Alex,

der grüne Bereich sollte deinem Wunsch entsprechen
Tabelle6
 ABCDE
111111
222222
333333
400000
5 00  
6TextTextTextTextText
745665
Formeln der Tabelle
B1 : =$A1
C1 : =$A1
D1 : =WENN($A1="";"";$A1)
E1 : =WENN($A1="";"";$A1)
B2 : =$A2
C2 : =$A2
D2 : =WENN($A2="";"";$A2)
E2 : =WENN($A2="";"";$A2)
B3 : =$A3
C3 : =$A3
D3 : =WENN($A3="";"";$A3)
E3 : =WENN($A3="";"";$A3)
B4 : =$A4
C4 : =$A4
D4 : =WENN($A4="";"";$A4)
E4 : =WENN($A4="";"";$A4)
B5 : =$A5
C5 : =$A5
D5 : =WENN($A5="";"";$A5)
E5 : =WENN($A5="";"";$A5)
B6 : =$A6
C6 : =$A6
D6 : =WENN($A6="";"";$A6)
E6 : =WENN($A6="";"";$A6)
A7 : =ANZAHL(A1:A6)
B7 : =ANZAHL(B1:B6)
C7 : =ANZAHL2(C1:C6)
D7 : =ANZAHL2(D1:D6)
E7 : =SUMMENPRODUKT((E1:E6<>"")*1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: AW: frage zu anzahl2 von: alex k
Geschrieben am: 25.02.2005 21:42:32

Vielen Dank auch dir !


 Bild

Beiträge aus den Excel-Beispielen zum Thema "frage zu anzahl2"