wann ist eine Zelle leer?

Bild

Betrifft: wann ist eine Zelle leer?
von: Peter Feustel
Geschrieben am: 07.03.2005 13:15:53
Hallo Excel Experten,
ich habe in einer Zelle folgende Formel stehen:
=SUMMENPRODUKT((MONAT('C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Temporary Internet Files\Content.IE5\OBVV6819\[Eis-06.xls]2005'!$B$7:$B$300)=3)*('C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Temporary Internet Files\Content.IE5\OBVV6819\[Eis-06.xls]2005'!$G$7:$G$300=C9)*'C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Temporary Internet Files\Content.IE5\OBVV6819\[Eis-06.xls]2005'!$D$7:$D$300)
Nun möchte ich die Zelle, in der bis auf die Formel kein Wert angezeigt wird auf LEER abfragen.
Len sagt mir die Zelle sei 1 und obendrein sagt IsNumeric sie auch noch numerisch.
Wie bekomme ich die Abfrage auf KEIN INHALT hin?
Zur Zeit bringt


If Len(WksZahlng.Cells(iZeile, (3 + iMonat)).Value) <> 0 And _
   IsNumeric(WksZahlng.Cells(iZeile, (3 + iMonat)).Value) Then

     Code eingefügt mit Syntaxhighlighter 2.5

kein richtiges Ergebnis.
Aber auch <> "" bringt kein richtiges Resultat und auch Not IsEmpty ist erfolglos.
Für einen guten Hinweis bereits im voraus vielen Dank.
Gruß Peter
Bild

Betrifft: AW: Problem gefunden
von: Peter Feustel
Geschrieben am: 07.03.2005 14:03:28
Hallo Excel Experten,
offenbar bedingt durch die Formel (ich bin kein Formel-Experte) steht in der Zelle 0 (Null). Warum die unsichtbar bleibt weiß ich im Augenblick nicht, zumal es eine Fremd_Excelmappe ist, an der ich erweitert habe.
So löst sich mein Problem mit eine Abfrage auf größer Null.

Viele Grüße Peter
Bild

Betrifft: AW: Problem gefunden
von: Martin Beck
Geschrieben am: 07.03.2005 16:54:13
Hallo Peter,
bei einer Fremdmappe könnte es an der Formatierung liegen, daß eine Null nicht angezeigt wird.
Gruß
Martin Beck
 Bild

Beiträge aus den Excel-Beispielen zum Thema "PIvot-Tabellem über mehrere Blätter"