Herbers Excel-Forum - das Archiv

Zugriff auf Index über Grenze hinaus

Bild

Betrifft: Zugriff auf Index über Grenze hinaus
von: Georg

Geschrieben am: 09.03.2005 19:55:32
Hallo,
ich habe mir einen Index erstellt, um auf bestimmt Werte zugreifen zu können. Er sieht in etwa so aus:
Tag Wert
1 F1
2 F2
3 G1
4 H1
. .
. .
. .
110 V1
111 V2
112 V3
Mit
=INDEX($R$1:$S$113; VERGLEICH(Rythmus;$R$1:$R$113;); VERGLEICH("Wert";$R$1:$S$1;)
möchte ich den jeweiligen Wert weiterverarbeiten.
Das Problem: Die Variable Rythmus (und somit die Spalte Tag) kann ggf. einen höheren Wert als 112 (bis 364) haben. Bei 113 soll beispielsweise wieder auf "Tag 1", bei 114 auf "Tag 2" usw. zugegriffen werden.
Hat jemand eine Problemlösung für mich?
Viele Grüße,
Georg
Bild

Betrifft: AW: Zugriff auf Index über Grenze hinaus
von: Sigi
Geschrieben am: 09.03.2005 21:16:20
Hallo Georg,
schreib statt Rythmus folgende Formel:
"=WENN(REST(Rythmus;112) = 0; 112; REST(Rythmus;112))"
Gruß
Sigi
 Bild
Excel-Beispiele zum Thema "Zugriff auf Index über Grenze hinaus"
VBA-Zugriff auf geschlossene Arbeitsmappe. Zugriff auf geschlossene Arbeitsmappen
Zugriff über SVERWEIS() auf eine Artikelliste Zugriff auf Zellen unter Verwendung eines Bereichsnamens
Rechnungsformular mit Zugriff auf Kunden- und Artikelstamm Zugriff auf VB-Editor verhindern, solange Arbeitsmappe geöffnet
Grafik einfügen, wenn Wert in A1 unter eine Grenze sinkt Eingabelänge in TextBox begrenzen und Werte aus Liste übernehmen
Scrollbereich begrenzen Signal, wenn sich Formelwert über eine Grenze bewegt