Probleme mit öffnen einer userform

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: Probleme mit öffnen einer userform von: louis
Geschrieben am: 09.03.2005 21:42:28

excel gut - VBA geht immer besser

Hallo forum,
so langsam bin ich am verzweifeln, ich versuche nun schon den ganzen tag folgendes problem zu lösen. ich bitte nochmal um eure hilfe.
wieso schliessen sich alle userform`s aller geöffneten arbeitsmappen wenn ich eine über einen makro mit dem close befehl schliesse?
Als beispiel
userform1 mit cmd1 (in Workbook TP)/ShowModal = False enthält folgenden code


Private Sub CommandButton1_Click()
Workbooks.Open "E:\NTP1.xls"
End Sub

hiermit rufe ich die arbeitsmappe NTP1 auf die eine workbook_open prozedur enthält

Private Sub Workbook_open()
UserForm2.Show
End Sub

bis hierher klappt alles super.
userform1 ist deaktiviert hinter userform 2 sichtbar
userform2 mit cmd2 (in Workbook NTP1) enthält folgenden code

Private Sub CommandButton2_Click()
Unload Me
ThisWorkbook.Close saveChanges: = False
End Sub

wenn ich jetzt cmd2 betätige schliesst sich Workbook NTP1 und die Userform2
aber auch die userform 1 und liegt mein problem.
wieso schliessen sich beim speichern einer arbeitsmappe alle userform`s?
ich könnte verückt werden es muss doch eine möglichkeit geben das userform 1 sichtbar bleibt?
für hilfe würde ich mitlerweile so einiges tun.
mfg und mit hoffnung
louis
Bild


Betrifft: AW: Probleme mit öffnen einer userform von: Simon
Geschrieben am: 09.03.2005 21:48:53

hallo,
schreib doch einfach mal in den cmd2 statt Unload Me,
Userform2.hide
gruß simon


Bild


Betrifft: alles schon probiert von: louis
Geschrieben am: 09.03.2005 21:56:25

hallo simon,
danke für deine antwort
das habe ich alles schon probiert. Selbst so schliesst sich userform 1.

Private Sub CommandButton2_Click()
ThisWorkbook.Close saveChanges: = False
End Sub

es muss was mit dem close befehl zu tun haben.
sobald ich eine arbeitsmappe über den close befehl schliesse sind alle userforms weg.

mfg
louis


Bild


Betrifft: AW: Probleme mit öffnen einer userform von: Matthias G
Geschrieben am: 09.03.2005 21:59:03

Hallo Louis,

ich habe das mal nachgebaut:
https://www.herber.de/bbs/user/19435.zip

und kann dein Problem nicht nachvollziehen.

Was habe ich anders gemacht?
Oder geht mein Beispiel bei Dir auch nicht?

Gruß Matthias


Bild


Betrifft: AW: Probleme mit öffnen einer userform von: louis
Geschrieben am: 09.03.2005 22:38:21

hallo matthias,
vielen dank für deine arbeit und mühe.
dein beispiel läuft bei mir.
aber baue ich dein beispiel eins zu eins nach habe ich die selben probleme wie immer.
ich schmeiss gleich den rechner aus dem fenster.
ich schmeiss jetzt erst mal office runter und ziehe es neu drauf.
ich könnte bekloppt werden.
vielen vielen dank für eure geduld mit mir.
ich melde mich wieder wenn ich das problem behoben habe.
mfg
louis


Bild


Betrifft: Viel Glück noch! - o.w.T. von: Matthias G
Geschrieben am: 09.03.2005 22:45:53

-


Bild


Betrifft: AW: Viel Glück noch! - o.w.T. von: louis
Geschrieben am: 09.03.2005 23:35:37

es läuft
office neu drauf und jetzt läuft es weiss der geier warum
danke an alle
gute nacht
louis


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Probleme mit öffnen einer userform"