Aufsummierung

Bild

Betrifft: Aufsummierung von: drigi
Geschrieben am: 13.03.2005 10:31:04

Hallo,

ich habe folgendes Problem:

In einer Tabelle habe ich einen Darlehensrechner. Dieser baut sich in Zeilen wie folgt auf:
Datum | Tilgung | Zins | Stand

Ich möchte nun flexibel wenn ich eine Jahreszahl eingebe, die in diesem Jahr in Summe gezahlten Zinsen ausgerechnet haben.

Hat jemand einen Vorschlag, wie ich das am geschicktesten anstelle?

Besten Dank!
Drigi

Bild


Betrifft: summenprodukt() kann das von: ransi
Geschrieben am: 13.03.2005 10:41:54

hallo drigi

schau dir mal summenprodukt() an.
 
 ABCD
101.01.20051782005
201.02.20052  
301.03.20053  
401.04.20054  
501.05.20055  
601.06.20056  
701.07.20057  
801.08.20058  
901.09.20059  
1001.10.200510  
1101.11.200511  
1201.12.200512  
1301.01.200613  
1401.02.200614  
1501.03.200615  
1601.04.200616  
1701.05.200617  
1801.06.200618  
1901.07.200619  
2001.08.200620  
2101.09.200621  
2201.10.200622  
2301.11.200623  
2401.12.200624  
2501.01.200725  
2601.02.200726  
2701.03.200727  
2801.04.200728  
2901.05.200729  
Formeln der Tabelle
C1 : =SUMMENPRODUKT((JAHR(A1:A29)=D1)*1;B1:B29)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

ransi


Bild


Betrifft: SUMMENPRODUKT() von: Jörg Gradert
Geschrieben am: 13.03.2005 10:42:58

Hallo Drigi,

=SUMMENPRODUKT((JAHR(A2:A100)=J1)*C2:C100)

Bezüge an deine Tabelle, die ich nicht kenne anpassen.

Gruß Jörg


Bild


Betrifft: AW: SUMMENPRODUKT() von: drigi
Geschrieben am: 13.03.2005 11:05:40

Ich bekomme immer den Fehler #WERT! Woran liegt das. Mache ich was falsch?


Bild


Betrifft: AW: SUMMENPRODUKT() von: Hajo_Zi
Geschrieben am: 13.03.2005 11:10:51

Hallo

1. die meisten haben hier keine Glaskugel
2. die meisten können nicht auf Deinen Rechner schauen, ich auch nicht. Es würde auch nichts nützen, da ich ja den Dateinamen nicht kenne

für alle diese Leute ist die Antwort schneller erstellt, wenn die Datei hochlädst.
Natürlich anonyme Daten.

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.



"Wer Rechtschreibfehler findet, darf sie behalten!"


Bild


Betrifft: irgendwo ist kein datum drin von: ransi
Geschrieben am: 13.03.2005 11:19:30

hallo drigi

irgendwo in der spalte mit den datums werten ist eine zelle die KEIN DATUM enthält.
check das mal.
ansonsten machs wie hajo schon sagte:
lade die datei mal hoch.

ransi


Bild


Betrifft: AW: irgendwo ist kein datum drin von: drigi
Geschrieben am: 13.03.2005 11:31:08

Das mit dem Datum kann ggf. sein, da hier dort eine Formel steht. Es handelt sich hierbei um einen Tilgungsplan wo bei Tilgungsende kein Datum mehr drinsteht (open end). Kann ich das Problem irgendwie beheben?

Die Datei ist leider zu groß zum hochladen!


Bild


Betrifft: AW: irgendwo ist kein datum drin von: ransi
Geschrieben am: 13.03.2005 11:54:08

hallo drigi

...aus der hilfe:
"Hinweise

Die als Argumente angegebenen Matrizen müssen bezüglich der Zeilen- und Spaltenanzahl identisch sein. Ist dies nicht der Fall, gibt SUMMENPRODUKT den Fehlerwert #WERT! zurück."

das heisst: du musst deine bereiche anpassen.

ransi


Bild


Betrifft: ohne Datum mußt Du WENNEN (Array) von: WF
Geschrieben am: 13.03.2005 12:02:18

Hi,

{=SUMME(WENN(ISTZAHL(A1:A29);WENN(JAHR(A1:A29)=D1;B1:B29)))}

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite


Bild


Betrifft: Ich danke Euch!!! Läuft! von: drigi
Geschrieben am: 13.03.2005 12:21:34

Super


Bild


Betrifft: AW: {=SUMME((JAHR(N(A1:A29))=D1)*B1:B29)} von: FP
Geschrieben am: 13.03.2005 21:31:56

Hallo Walter,

sollte auch funktionieren :-)

Servus aus dem Salzkammergut
Franz


Bild


Betrifft: N() mir gefällt´s! von: Jörg Gradert
Geschrieben am: 14.03.2005 05:37:26

Hallo Franz,
mit dem N() funktioniert auch meine Summenproduktformel wieder.
Danke für den Tipp
Gruß Jörg


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Userform - Kontrollkästchen"