Sverweis.....HILFE!!!

Bild

Betrifft: Sverweis.....HILFE!!!
von: Daniel H.
Geschrieben am: 13.03.2005 17:39:43
Hy leute,
habe warscheinlich nur ein klitzekleines problem.
Und zwar hab ich eine Tabelle, die ich vergleichen möchte.
https://www.herber.de/bbs/user/19609.xls
sehts euch an....ist nur eine test-tabelle.
Sobald ich in die Zeile D1 einen Wert eingebe, sollte das ergebnis in Spalte A gesucht werden, und Der Wert aus Spalte B in Zeile D3 stehen.
So weit hab ich das auch verstanden. Nur bei dem wert 0,3 erscheint ein falsches ergebnis, was dann aber bei 0,4 wieder stimmt. Und ab 1,4 Verschiebt sich das ergebnis um jeweils 1 stelle.....
PS.: Bitte nicht nur Lösungsvorschläge, sondern auch versuchen mir es zu erklären.
Thanks im Vorraus....
Daniel

Bild

Betrifft: AW: Sverweis.....HILFE!!!
von: Hajo_Zi
Geschrieben am: 13.03.2005 17:42:55
Hallo Daniel,
Ich vermute mal Du solltest auch den letzten Schalter von Sverweis angeben; 0

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


Bild

Betrifft: AW: Sverweis.....HILFE!!!
von: MichaV
Geschrieben am: 13.03.2005 18:01:57
Hi,
das scheint ein Rundungs- Problem in der x-ten Stelle nach dem Komma zu sein. Wenn Du Optionen- Berechnen- Genauigkeit wie angezeigt "an" schaltest oder die Werte in Spalte A durch Kopieren- Inhalte einfügen: Werte in Text umwandelst, dann klappt Dein SVERWEIS wieder.
Gruß! Micha
Bild

Betrifft: AW: Sverweis.....HILFE!!!- Nachtrag
von: MichaV
Geschrieben am: 13.03.2005 18:19:48
Hi,
alternativ kannst Du auch in Spalte A für die Berechnung der Werte die Formel =RUNDEN(A3+0,1;1) nehmen.
Gruß! Micha
Bild

Betrifft: AW: Sverweis.....HILFE!!!Danke an alle
von: Daniel H.
Geschrieben am: 13.03.2005 18:21:22
Hallo Micha,
joa genau daran hats gelegen!!!!
Vielen dank....wusste doch es is nur ne kleinigkeit!!!
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Adressen sortieren mit VBA"