Herbers Excel-Forum - das Archiv

Leerzeichen

Bild

Betrifft: Leerzeichen
von: bernhard

Geschrieben am: 14.03.2005 10:36:50
hallo
ich habe folgendes problem:
mit dieser formel:
=WENN(A13="";"";WENN((A13+1)>$F$6;"";A13+1))
sollte eine auflistung der tage des aktuellen monats dargestellt werden. das enddatum wird in f6 berechnet. wenn aber z.b. der februar nur 28 tage hat, sollen die letzten 3 felder leer bleiben. mit dieser formel werden aber - glaube ich - leerzeichen in die zellen eingefügt. dies ist aber ein problem, weil sich eine weitere funktion auf diese zellen bezieht, die nicht mit leerzeichen umgehen kann.
zur übersicht ein auszug aus dem worksheet:
Userbild

wie könnte ich dieses problem umgehen?
vielen dank
bernhard
Bild

Betrifft: AW: Leerzeichen
von: M@x
Geschrieben am: 14.03.2005 11:58:30
hi Bernhard,
probiers mit NV() "nicht vorhanden"
=WENN(A13="";#NV;WENN((A13+1)>$F$6;#NV;A13+1))
Gruss
M@x
Bild

Betrifft: AW: Leerzeichen
von: Gert Seler

Geschrieben am: 14.03.2005 12:20:41
Hallo Bernhard,
das Zeichen ("")besagt nur ,das nichts in der Zelle steht.
Ein Leerzeichen, hat einen Tastatur-Code und wird so (" ") angezeigt.
Die andere Formel sollte allerdings eine leere Zelle akzeptieren.
Deine Formel etwas kürzer.
=WENN(ODER(A13="";A13+1>F6);"";A13+1)
mfg
Gert
Bild

Betrifft: AW: Leerzeichen
von: bernhard
Geschrieben am: 14.03.2005 12:37:51
vielen dank!
 Bild
Excel-Beispiele zum Thema "Leerzeichen"
Leerzeichen aus einem Bereich löschen Nach jedem 5. Zeichen ein Leerzeichen einfügen
Alle überflüssigen Leerzeichen im Arbeitsblatt löschen Zeichen in Zeichenfolgen umwandeln und Leerzeichen entfernen
Leerzeichen zwischen Zeichen- und Zahlenfolge entfernen Überflüssige Leerzeichen in einem vorgegebenen Bereich löschen
Zeichenfolgen aus Zellen in TextBox mit Leerzeichen darstellen Zeichenfolgen aus 1. mit Leerzeichen in 2. TextBox übernehmen