Zahlenproblem

Bild

Betrifft: Zahlenproblem von: Udo
Geschrieben am: 19.03.2005 21:15:45

Hallo,
Hab da mal ein Problem, ich habe da eine Spalte voller Zahlen, aus denen ich eine Zahl X suche und die nächsten 9 niedrigeren Zahlen.

Hat einer eine Idee, wie man es anstellt?

Mfg. Udo

Bild


Betrifft: AW: Zahlenproblem von: Hajo_Zi
Geschrieben am: 19.03.2005 21:24:36

Hallo Udo,

falls Du alle unterschiedlichen Werte haben willst (also max 157, dann 140; 140; 136usw.

Gesamt
 AHAIAJ
21571. WertFormel von Thomas Ramel
31402. Wert 
41363. Wert 
51264. Wert 
61245. Wert 
71156. Wert 
81107. Wert 
91028. Wert 
10999. Wert 
119710. Wert 
Formeln der Tabelle
AH2 : =MAX(AF:AF)
AH3 : {=MAX(WENN($AF$1:$AF$505<MAX(AF:AF);$AF$1:$AF$505;""))}
AH4 : {=MAX(WENN($AF$1:$AF$505<AH3;$AF$1:$AF$505;""))}
AH5 : {=MAX(WENN($AF$1:$AF$505<AH4;$AF$1:$AF$505;""))}
AH6 : {=MAX(WENN($AF$1:$AF$505<AH5;$AF$1:$AF$505;""))}
AH7 : {=MAX(WENN($AF$1:$AF$505<AH6;$AF$1:$AF$505;""))}
AH8 : {=MAX(WENN($AF$1:$AF$505<AH7;$AF$1:$AF$505;""))}
AH9 : {=MAX(WENN($AF$1:$AF$505<AH8;$AF$1:$AF$505;""))}
AH10 : {=MAX(WENN($AF$1:$AF$505<AH9;$AF$1:$AF$505;""))}
AH11 : {=MAX(WENN($AF$1:$AF$505<AH10;$AF$1:$AF$505;""))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hajo

Das Forum lebt auch von den Rückmeldungen.


Bild


Betrifft: AW: Zahlenproblem von: Udo
Geschrieben am: 19.03.2005 21:46:19

Hallo Hajo,

Ja fast, nur das ich bei der ersten Zahl nicht die größte Zahl sondern irgendeine Zahl habe.
Beispiel die Anfangszahl ist 115, aber die größte ist z.b. 850.

Gruß Udo


Bild


Betrifft: AW: Zahlenproblem von: Hajo_Zi
Geschrieben am: 19.03.2005 21:48:58

Hallo Udo

schreibe Deine Zahl in Zelle AH3

Gruß Hajo

Das Forum lebt auch von den Rückmeldungen.


Bild


Betrifft: AW: Zahlenproblem von: Udo
Geschrieben am: 19.03.2005 22:06:29

Hallo Hajo,

Danke dir Funktioniert.

Gruß Udo


Bild


Betrifft: AW: auf oder absteigend ? von: FP
Geschrieben am: 20.03.2005 01:44:23

Hallo Udo,

Wie hättest Du die Zahlen denn gern gelistet? :-)

Tabelle3
 ABCDEFG
1406261 Na dann wollen wir mal... 
221810 233 141    
3740141 218 154    
44920 212 155  B1die "Ausgangszahl"
572481 201 180  B2wieviele kleinere Zahlen sollen gelistet werden?
6731 191 182  B3wie groß muss die Zahl mindestens sein, damit die gewünschte Anzahl gelistet werden kann?
7337 182 191  B4wieviele Zahlen sind kleiner als die Ausgangszahl?
8781 180 201  B5wieviele Zahlen sind größer oder gleich der Ausgangszahl?
9680 155 212    
10267 154 218   Lösungen:
11777 141 233   ab C2: die Zahlen in absteigender Reihenfolge
12710     ab D2: die Zahlen in aufsteigender Reihenfolge
13897      
1433     Vorteile meiner Lösung gegenüber der von HaJo / Thomas Ramel:
15657     es ist keine Arrayformel :-) :-) :-)
16757     sie ist trotzdem kürzer :-)
Formeln der Tabelle
C1 : =WENN(B4<B2;"Du mußt eine größere Zahl wählen!";"Na dann wollen wir mal...")
C2 : =WENN(ZEILE(A1)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A1)+1))
D2 : =WENN(ZEILE(A1)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A1)))
B3 : =KKLEINSTE(A:A;B2+1)
C3 : =WENN(ZEILE(A2)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A2)+1))
D3 : =WENN(ZEILE(A2)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A2)))
B4 : =ZÄHLENWENN(A:A;"<"&B1)
C4 : =WENN(ZEILE(A3)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A3)+1))
D4 : =WENN(ZEILE(A3)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A3)))
B5 : =ZÄHLENWENN(A:A;">="&B1)+1
C5 : =WENN(ZEILE(A4)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A4)+1))
D5 : =WENN(ZEILE(A4)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A4)))
C6 : =WENN(ZEILE(A5)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A5)+1))
D6 : =WENN(ZEILE(A5)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A5)))
C7 : =WENN(ZEILE(A6)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A6)+1))
D7 : =WENN(ZEILE(A6)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A6)))
C8 : =WENN(ZEILE(A7)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A7)+1))
D8 : =WENN(ZEILE(A7)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A7)))
C9 : =WENN(ZEILE(A8)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A8)+1))
D9 : =WENN(ZEILE(A8)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A8)))
C10 : =WENN(ZEILE(A9)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A9)+1))
D10 : =WENN(ZEILE(A9)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A9)))
C11 : =WENN(ZEILE(A10)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A10)+1))
D11 : =WENN(ZEILE(A10)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A10)))
C12 : =WENN(ZEILE(A11)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A11)+1))
D12 : =WENN(ZEILE(A11)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A11)))
C13 : =WENN(ZEILE(A12)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A12)+1))
D13 : =WENN(ZEILE(A12)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A12)))
C14 : =WENN(ZEILE(A13)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A13)+1))
D14 : =WENN(ZEILE(A13)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A13)))
C15 : =WENN(ZEILE(A14)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A14)+1))
D15 : =WENN(ZEILE(A14)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A14)))
C16 : =WENN(ZEILE(A15)>B$2;"";KKLEINSTE(A:A;B$4-ZEILE(A15)+1))
D16 : =WENN(ZEILE(A15)>B$2;"";KGRÖSSTE(A:A;B$5+B$2-ZEILE(A15)))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


Bild


Betrifft: AW: auf oder absteigend ? von: Udo
Geschrieben am: 22.03.2005 17:27:35

Danke auch dir Franz

Gruß Udo


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Blattschutz mit gesperrte Zellen nicht anwählen"