Herbers Excel-Forum - das Archiv

Zählenwenn

Bild

Betrifft: Zählenwenn
von: Ernst Lalla

Geschrieben am: 21.03.2005 14:32:30
Hallo,
ich habe folgendes Problem:
Ich habe eine Exeltabelle mit 2 Blättern.
Auf dem ersten Blatt steht in Feld A2 "014010" (ohne "")
Im zweiten Blatt habe ich in Spalte A ca. 1200 Einträge, worin einigemale 014010 vorhanden ist. In Spalte B habe ich manchmal ein X stehen. Die Zelle sind als Standart formatiert.
Nun möchte ich in dem Feld A3 auf Blatt eins die Anzahl der Einträge mit der Nummer und dem X ausgegeben haben.
Ich habe schon mehrere Vorschläge (s.u.) aus dem Archiv versucht. Meistens kommt aber nur das Ergebnis "#Zahl!"
SUMMENPRODUKT mit und ohne {}
ZÄHLENWENN
WENN
Ich weiß leider nicht mehr weiter...
Kann mir jeman helfen??
Danke Ernst
Bild

Betrifft: AW: Zählenwenn
von: danny
Geschrieben am: 21.03.2005 15:10:45
hallo Ernst
Versuch es mal so
=ZÄHLENWENN(Tabelle2!B:B;"x")

gruss
danny
Bild

Betrifft: AW: Zählenwenn
von: Ernst Lalla

Geschrieben am: 21.03.2005 15:27:18
Sorry,
vieleicht habe ich mich nicht richtig oder vollständig ausgedrückt.
In der Spalte A stehen verschiedene Zahlen. z.B. 014072; 011250; 211522 u.s.w.
Er soll natürlich nur zählen, wenn beides passt.
Gruß Ernst
Bild

Betrifft: AW: Zählenwenn
von: heikoS
Geschrieben am: 21.03.2005 15:30:50
Hallo Ernst,
in A3: =SUMMENPRODUKT((Tabelle2!$A$1:$A$1200=A2)*(Tabelle2!$B$1:$B$1200="X"))

Gruß Heiko
Bild

Betrifft: AW: Zählenwenn
von: Ernst Lalla
Geschrieben am: 21.03.2005 15:39:40
Hallo,
geht leider nicht. Als Ergebnis habe ich wieder nur #Zahl!
Gruß Ernst
Bild

Betrifft: AW: Zählenwenn
von: th.heinrich

Geschrieben am: 21.03.2005 17:30:30
hallo Ernst,
funzzt doch.
Tabelle2
 ABC
1014010x2
22x014010
3014010x 
Formeln der Tabelle
C1 : =SUMMENPRODUKT((Tabelle2!$A$1:$A$1200=C2)*(Tabelle2!$B$1:$B$1200="X"))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruss thomas
Bild

Betrifft: AW: Zählenwenn
von: heikoS

Geschrieben am: 22.03.2005 08:44:36
Hallo Ernst,
den Fehler kann ich leider mit Deinen Angaben nicht nachstellen. Poste doch mal eine Beispielmappe (incl. Fehler), vielleicht kann Dir dann geholfen werden.

Gruß Heiko
 Bild