Summenprodukt ?

Bild

Betrifft: Summenprodukt ? von: Korl
Geschrieben am: 22.03.2005 00:11:12

Hallo,

ich bin auf ein Problem in meinen Schichtplan gestoßen.
In Spalte "A" werden Feiertage mit einem "x" gekennzeichnet.
In Spalte "B" werden die Schichtkürzel, z.B. 6 verschiedene an der Zahl, eingetragen.
Für die Schichtkürzel habe ich jeweils einen Namen vergeben.

In Zelle "C1" soll die Schichten gezählt werden, die auf einen Feiertag gefallen sind.
Dies ist meine Formel: =SUMMENPRODUKT((A2:A10="x")*((B2:B10=kürz1)+(B2:B10=kürz2)+(B2:B10=kürz3)+(B2:B10=kürz4)+(B2:B10=kürz5)+(B2:B10=kürz6)))
Soweit funktioniert auch alles.
Nun kommt es vor, das unterschiedliche Benutzergruppen von der Anzahl und Art, unterschiedliche Schichtkürzel benutzen.

Entferne ich aus dem Bereich ein Kürzel, wird durch die Formel ein Feiertag aufaddiert?

Wie kann man diesen nicht gewollten Effekt verändern?

Gruß Korl

PS: hier meine Beispieldatei https://www.herber.de/bbs/user/19974.xls

Bild


Betrifft: SUMMENPRODUKT mit MTRANS und <>"" von: Beate Schmitz
Geschrieben am: 22.03.2005 01:34:50

Hallo Korl,

du musst Leerzellen ausschließen, sonst hast du ja nen Treffer bei Kreuz in Spalte A und Leerzelle in Spalte B:

 
 D
3Anzahl der Feiertagsarbeiten
41
Formeln der Tabelle
D4 : {=SUMMENPRODUKT((B2:B13=MTRANS(G3:G8))*(A2:A13="x")*(B2:B13<>""))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 


Du kannst verschieden große Spaltenbereiche mit SUMMENPRODUKT vergleichen, indem du die Funktion MTRANS einbaust, damit behandelt Excel den Bereich wie eine Zeile und der darf verschieden groß sein. Damit sparst du den langen "ODER"-Teil in deiner Formel.

Gruß,
Beate


Bild


Betrifft: das ist genial, juhu! Danke, Beate! owT von: Korl
Geschrieben am: 22.03.2005 07:41:24

-


Bild


Betrifft: ... man lernt nie aus :) coole Funktion :) von: c0bRa (oT)
Geschrieben am: 22.03.2005 07:53:13




Bild


Betrifft: AW: SUMMENPRODUKT mit MTRANS und <>"" von: M@x
Geschrieben am: 22.03.2005 08:34:37

Hi Beate,
zuerst ein Bravo für die Lösung,
Matrixformel in Matrixformel ist aber nicht nötig,
statt Summenprodukt einfach SUMME

Gruss

M@x


Bild


Betrifft: AW: SUMMENPRODUKT mit MTRANS und <>"" von: Beate Schmitz
Geschrieben am: 22.03.2005 09:22:18

Hallo Max,

meine Lösungsidee hatte ich mal hierher:
http://www.xldynamic.com/source/xld.SUMPRODUCT.html#transpose
Da findet man noch mehr außergewöhnliche SUMMENPRODUKT-Formeln.

Danke für deine weitergehende Lösung, die auch funktioniert.

Gruß,
Beate


Bild


Betrifft: AW: SUMMENPRODUKT mit MTRANS und <>"" von: M@x
Geschrieben am: 22.03.2005 09:46:30

Hi Beate,
Danke für diesen sehr interessanten Link

Gruss

M@x


 Bild

Beiträge aus den Excel-Beispielen zum Thema ""Zusammengesetzte" Variablen"