Spalten zusammen fügen

Bild

Betrifft: Spalten zusammen fügen von: Andreas
Geschrieben am: 22.03.2005 09:17:46

Ich habe folgendes Problem. Und zwar benötige ich die folgende Daten in einem anderen Format:

https://www.herber.de/bbs/user/19976.xls

Und zwar nur zwei Spalten, und die Texte aus Spalte 2 + 3 die mit gleicher Artikelnummer anfangen in ein Feld. Wenn es geht auch mit html Formatierung.

Die Liste ist natürlich im Original wesentlich länger, und wird täglich aktualisiert.

In der original liste sind ca 3000 - 4000 Artikel. Es sind nicht immer gleichviele Zeilen pro Artikelnummer.

Ich habe echt so wenig Ahnung davon, das ein wenig Hilfe schön wäre.
Danke im Voraus

Andreas

Bild


Betrifft: Anm. Spalten zusammen fügen von: Andreas
Geschrieben am: 22.03.2005 09:25:55

Die Datei liegt auch als tabstob getrennter Text vor falls das einfacher ist.


Bild


Betrifft: AW: Spalten zusammen fügen von: c0bRa
Geschrieben am: 22.03.2005 09:37:23

hallo...

also mein vorschlag dazu:
1. Sicherungskopie erstellen!!!

2. formeln einfügen:
D1: =B1&" "&C1
D2-Dxxx: =WENN(A2=A1;D1&" "&B2&" "&C2;B2&" "&C2)
E1-Exxx: =WENN(A1<>A2;"X";"")

wenn du die formeln bis runter kopiert hast, markierst du die komplette tabelle und machst folgendes:
- bearbeiten
- kopieren
- Zelle A1 markieren
- bearbeiten
- inhalte einfügen
- werte

nun sortierst du noch nach spalte E und haust alle zeilen raus, die kein X haben, jetzt noch spalte B, C und E löschen und schon hast du alle daten in einer Zelle :)

siehe auch: https://www.herber.de/bbs/user/19977.xls


Rückmeldung nicht vergessen...
c0bRa


Bild


Betrifft: AW: Spalten zusammen fügen von: c0bRa
Geschrieben am: 22.03.2005 09:40:07

oder willst du einfach nur spalte 2 und 3 verbinden?

wenn ja =b1&" "&c1

c0bRa


Bild


Betrifft: AW: Spalten zusammen fügen von: Andreas
Geschrieben am: 22.03.2005 09:48:13

Danke c0bRa Du bist genial. Das es so einfach geht hätte ich nicht gedacht.
Ich hatte mit vba oder ähnlichem gerechnet.

Gruß
Andreas


Bild


Betrifft: np :) von: c0bRa
Geschrieben am: 22.03.2005 09:56:17




Bild


Betrifft: AW: Spalten zusammen fügen von: c0bRa
Geschrieben am: 22.03.2005 09:58:26

achso... für die schönheit kannste mit =wechseln(a1;"--";"-") (- durch leerzeichen ersetzen) noch doppelte leerzeichen rausschmeissen :)


Bild


Betrifft: Dafür gibt´s die Funktion GLÄTTEN() ...;-) oT von: Boris
Geschrieben am: 22.03.2005 10:03:37




Bild


Betrifft: GLÄTTEN() in der mitte? von: c0bRa
Geschrieben am: 22.03.2005 10:07:06

entfernt glätten nicht nur leerzeichen am anfang und ende?

zumindest stehts so in der hilfe:
Entfernt führende und nachfolgende Leerzeichen aus dem Text in der Formel (Gewinn im ersten Quartal)

habs gradmal ausprobiert... anscheinend macht die funktion mehr, als die Hilfe dazu verrät... ;)

c0bRa


Bild


Betrifft: So steht´s in der Hilfe zu xl2000: von: Boris
Geschrieben am: 22.03.2005 10:17:27

Hi Cobra,

Löscht Leerzeichen in einem Text, die nicht als jeweils einzelne zwischen Wörtern stehende Trennzeichen dienen. GLÄTTEN können Sie für Texte verwenden, die Sie aus anderen Anwendungsprogrammen übernommen haben und die eventuell unerwünschte Leerzeichen enthalten.

Grüße Boris


Bild


Betrifft: ... das wurde in XP wegrationalisiert :) von: c0bRa (oT)
Geschrieben am: 22.03.2005 10:21:28




Bild


Betrifft: AW: ... das wurde in XP wegrationalisiert :) von: Andreas
Geschrieben am: 22.03.2005 10:30:49

Gibt es jetzt noch die Möglichkeit, das wenn Excel mit der genannten Funktion die nächste Zeile reinnimmt ein
einfügt.
Ich brauche Die Liste für eine Datenbank die für einen Webshop gedacht ist? Wenn der Text so endlos und ohne Zeilenumbrüche ist, liest er sich nicht so gut.


Bild


Betrifft: AW: ... das wurde in XP wegrationalisiert :) von: Andreas
Geschrieben am: 22.03.2005 10:33:39

Ein html Zeilenumbruch meine ich BR in eckigen Klammern


Bild


Betrifft: AW: ... das wurde in XP wegrationalisiert :) von: c0bRa
Geschrieben am: 22.03.2005 10:47:09

dazu einfach:

D2-Dxxx: =WENN(A2=A1;D1&" "&B2&" "&C2;B2&" "&C2)
durch
D2-Dxxx: =WENN(A2=A1;D1&"<BR>"&B2&" "&C2;B2&" "&C2)
schreiben
c0bRa


Bild


Betrifft: AW: ... das wurde in XP wegrationalisiert :) von: Andreas
Geschrieben am: 22.03.2005 10:51:15

Wenn ich die Formel verstanden hätte wäre ich selber drauf gekommen.

Vielen Dank noch mal Cobra

Gruß Andreas


Bild


Betrifft: AW: ... das wurde in XP wegrationalisiert :) von: c0bRa
Geschrieben am: 22.03.2005 10:54:48

die formel macht eingentlich nix anderes als:
wenn a2=a1, nimm d1 und häng b2 und c2 ran... wenn a2 nicht a1 (also anderer artikel) nimm nur b2 und c2 :)des &" "& trennt nur durch ein leerzeichen ab, da er sonst die werte aneinanderklebt...

c0bRa


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Spalten zusammen fügen"