Summe aus Tabellenblatt KW 1 bis KW 52

Bild

Betrifft: Summe aus Tabellenblatt KW 1 bis KW 52
von: Harald G.
Geschrieben am: 26.03.2005 15:05:18
Hallo zusammen,
ich habe eine Datei mit folgenden Tabellenblättern:
Tabelle1 (Originalvorlage)
Tabelle2 (Gesamtzahlen)
so weit, so gut.
Jetzt wird einmal pro Woche die Originalvorlage per Makro kopiert und umbenannt in KW 1, KW 2, usw... so dass wöchentlich 1 Tabellenblatt hinzu kommt.
Nun zu meiner Frage:
Wie muss die Formel aussehen, um im Tabellenblatt2 (Gesamt) immer die Gesamtsummen aller aktuell vorhandenen KW-Tabellenblatter zu haben.
Gruß, Harald G.

Bild

Betrifft: AW: Summe aus Tabellenblatt KW 1 bis KW 52
von: Ramses
Geschrieben am: 26.03.2005 15:18:00
Hallo
die einfachste Variante wäre:
Erstelle auf der Basis deiner Vorlage eine Tabelle mit dem Namen ENDE und schreib in die Zelle der Auswertung
=SUMME(KW1:ENDE!A1)
Die neuen Tabellenblätter müssen lediglich VOR der Tabelle "Ende" stehen
Das ist ohne grossen Aufwand und grossen HokusPokus
Gruss Rainer
Bild

Betrifft: AW: Summe aus Tabellenblatt KW 1 bis KW 52
von: Harald G.
Geschrieben am: 26.03.2005 16:23:46
Hallo Rainer,
ja, genau - ohne grossen Schnick-Schnack - so wollte ich es.
Das Tabellenblatt "Ende" kann ja auch ein leeres ausgeblendetes Blatt sein.
Vielen Dank und frohe Ostern.
Gruß, Harald G. aus Köln
Bild

Betrifft: Hilfe ! Summe aus Dateien KW 1 bis KW 52
von: Harald G.
Geschrieben am: 26.03.2005 16:36:41
Noch eine ähnliche Frage zu diesem Thema:
Ich habe festgestellt, dass mir die Datei zu groß wird, wenn jede Kalenderwoche ein neues Blatt eingefügt wird.
Wie sieht die Sache aus, wenn ich eine Datei "Originalvorlage.XLT" und eine Datei "Gesamtsummen.XLS" in einen Ordner packe und dann wöchentlich eine neue Datei KW1, KW2, KW3 usw... erzeuge und speichere.
Gibt es eine Möglichkeit mir (per Excel-Formel) in der Datei "Gesamtsummen" die Summe aller immer mehr werdenden Einzel-Dateien KW ... anzeigen zu lassen, ohne dass ich die Formel ständig ändern muss, weil die Dateien immer mehr werden ?
Gruß, Harald G. aus Köln
Bild

Betrifft: AW: Hilfe ! Summe aus Dateien KW 1 bis KW 52
von: Beate Schmitz
Geschrieben am: 26.03.2005 19:24:25
Hallo Harald,
warum machst du es nicht alles in einem Tabellenblatt? Richtest eine Zusatzspalte ein, in der ausgehend vom Datum in der Zeile die Kalenderwoche berechnet wird, dann kann du z.B. über Autofilter bestimmte Kalenderwochen ausfiltern und mit TEILERGEBNIS(9.... wird dir die Summe des gefilterten Bereichs zurückgegeben. Ist kein Filter gesetzt, wird die Gesamtsumme angezeigt. Hat auch den Vorteil, die gesamten Jahresdaten sind stets direkt greifbar und die Datei bleibt schlank.
Die Formel, um die Summe aus bis zu 52 Dateien zu ziehen, stelle ich mir sehr aufwändig vor..., außer: du legst in einem Blatt der Sammeldatei in 52 Zellen jeweils Verknüpfungen zu den dortigen Sammelzellen und summierst diese dann.
Gruß,
Beate
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summe aus Tabellenblatt KW 1 bis KW 52"