Bildung eines komplexen Mittelwertes

Bild

Betrifft: Bildung eines komplexen Mittelwertes
von: sathiere
Geschrieben am: 30.03.2005 15:17:14
Hi,
ich habe ein etwas komplexeres Excel-Problem das sich wahrscheinlich am besten an einem Beispiel erklären lässt:
Ich habe in zwei Spalten für verschiedene Häuser die jeweiligen Kaufpreise und Quadratmeterzahlen. Nun möchte ich gern in einer Auswertungszeile den durchnittlichen Quadratmeterpreis der z.B. fünf preiswertesten Häuser (bezogen wiederum auf den Preis pro Quadratmeter). Weiterhin sollen Werte gleich Null ("Platzhalter") aus der Berechnung ausgeschlossen werden. Hilfsspalten sind auch nicht möglich.
Ein Beispiel so einer Tabelle (nur exemplarisch) liegt unter https://www.herber.de/bbs/user/20377.xls
Falls jemandem zu diesem Problem eine Lösung einfällt, bin ich im Voraus schon mal sehr dankbar.
Sascha

Bild

Betrifft: AW: Bildung eines komplexen Mittelwertes
von: c0bRa
Geschrieben am: 30.03.2005 15:28:32
hallo...
probier mal die formel hier:
{=MITTELWERT(KKLEINSTE(WENN($A$2:$A$13>0;C2:C13/$A$2:$A$13;KGRÖSSTE(C2:C13;1));ZEILE(1:5)))}
die sollte tun, was du willst ;)
Achtung Matrixformel!!! Umrandende {} nicht mit eingeben, sondern mit Strg+Shift+Enter abschliessen!

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: kommando zurück...
von: c0bRa
Geschrieben am: 30.03.2005 15:37:20
des wäre der durchschnittsmittelwert der 5 häuser...
Bild

Betrifft: AW: Bildung eines komplexen Mittelwertes
von: Martin Beck
Geschrieben am: 30.03.2005 16:05:53
Hallo Sascha,
in C14 folgende Matrixformel und dann nach rechts kopieren:
=MITTELWERT(KKLEINSTE(WENN(ISTFEHLER(C2:C13/$A$2:$A$13);"";C2:C13/$A$2:$A$13);ZEILE(1:5)))
Gruß
Martin Beck
Bild

Betrifft: ok ;)
von: c0bRa
Geschrieben am: 30.03.2005 16:11:08
da deine formel auf die gleichen ergebnisse kommt, denk ich mal dass meine auch richtig ist ;)
c0bRa
Bild

Betrifft: Abfrage Spalte A auf größer Null reicht
von: Boris
Geschrieben am: 30.03.2005 16:29:37
Hi Martin,
{=MITTELWERT(KKLEINSTE(WENN($A2:$A13>0;C2:C13/$A2:$A13);ZEILE(1:5)))}
und ab nach rechts damit.
Grüße Boris
Bild

Betrifft: Stimmt, Boris, aber Sascha ...
von: Martin Beck
Geschrieben am: 31.03.2005 13:14:50
... scheint's nicht zu interessieren. :-(
Gruß
Martin Beck
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bildung eines komplexen Mittelwertes"