Fehler in Funktion Wenn

Bild

Betrifft: Fehler in Funktion Wenn
von: Micha
Geschrieben am: 31.03.2005 15:20:37
Hallo,
wenn ich diese Formel eingebe, sagt er mir immer Fehler. Kann mir mal jemand kurz auf die Sprünge helfen.

=wenn(b25="";"";wenn(b25="K";8;wenn(b25="FT";0;wenn(B25="FR";24*(8e25-d25-c25);wenn(b25="U";8;wenn(B25="UH";24*(8e25-d25-c25)-4;wenn(b25="SU";8;wenn(b25="SH";24*(8e25-d25-c25)-4;wenn(b25="ÜS";-8;WENN(E5>C5;(E5-D5-C5)*24;24-(C5-E5+D5)*24))))))))

Danke
Micha

Bild

Betrifft: AW: Fehler in Funktion Wenn
von: Remo
Geschrieben am: 31.03.2005 15:26:26
Da liegt der Hund begraben...
8e25-d25-c25
Bild

Betrifft: Monsterverschachtelung...
von: Boris
Geschrieben am: 31.03.2005 15:27:24
Hi Micha,
du überschreitest einfach die maximale Verschachtelungstiefe von Funktionen (8).
Schau dir doch mal alternativ die Verweis-Funktionen ans.
Grüße Boris
Bild

Betrifft: AW: Fehler in Funktion Wenn
von: Andi
Geschrieben am: 31.03.2005 15:30:41
Hi,
ich hoffe mal ich hab mich jetzt nicht verzählt, aber ich bin bei dreimaligen durchzählen jedesmal auf 15 öffnende und nur 13 schliessende Klammern gekommen. Das kann nicht gut gehen...
Schönen Gruß,
Andi
Bild

Betrifft: AW: Fehler in Funktion Wenn
von: UweN
Geschrieben am: 31.03.2005 15:32:04
Hallo Micha,
nach sieben geöffneten Klammern ist Schluß mit weiteren Verschachtelungen.
Hast Du schon mal versucht, das Problem mit SVERWEIS zu lösen?
Wenn Du die verschiedenen Bedingungen und ihre Ausprägung in eine separate Tabelle
schreiben kannst, ist es vermutlich möglich diese riesige WENN - Verschachtelung zu vereinfachen.
Ansatz:
A1: K
B1: 8
A2: FT
B2: 0
.... etc., bis alle Deine Bedingungen in Tabellenform vorliegen.
Jetzt schreibst Du in Deine Zielzelle noch die SVERWEIS - Funktion und schon sollte es funktionieren.
Noch etwas: was soll eigentlich 8e25-d25-c25 bedeuten ?
Viele Grüße
Uwe
Bild

Betrifft: AW: Fehler in Funktion Wenn
von: ingoG
Geschrieben am: 31.03.2005 16:37:48
Hallo Micha,
was hälst Du von:
=WENN(ISTFEHLER(SUCHEN(LINKS(B25&" ";2);" K FTFRU UHSUSHÜS";1));REST(1+E5-D5-C5;1)*24;WAHL((SUCHEN(LINKS(B25&" ";2);" K FTFRU UHSUSHÜS";1)+1)/2;"";8;0;24*(E25-D25-C25);8;24*(E25-D25-C25)-4;8;24*(E25-D25-C25)-4;8))
Gruß Ingo
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Fehler in Funktion Wenn"