VBA programmierung notwendig????

Bild

Betrifft: VBA programmierung notwendig???? von: Reinhard
Geschrieben am: 02.04.2005 11:22:46

Hallo ihr

Ich bräuchte da was kleines????

Ich habe eine Liste, bei der zu jeder Kostenstellennummer ein Arbeitsgang folgt.

Ich möchte im Excel nur die Nummer eintragen und er soll mir automatisch den Namen des Arbeitsganges in die nächste Spalte eintragen.

Wie gehe ich das am besten an?

Bitte um Hilfe!

Danke, mfg Reinhard

Ausserdem habe ich noch immer mein Problem mit meinem Organigramm.

Ich kann die einzelnen Felder nicht vergrößern!
Wenn ich es versuche, dann meldet er immer: "Dieser Arbeitsmappe können keine weiteren Schriftarten hinzugefügt werden".

Ich habe sie nochmal hochgeladen!

https://www.herber.de/bbs/user/20519.xls

Danke für die Hilfe

Bild


Betrifft: AW: VBA programmierung notwendig???? von: Hajo_Zi
Geschrieben am: 02.04.2005 11:25:17

Hallo Reinhard,

zu 1 benutze Sverweis


Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.




Bild


Betrifft: AW: VBA programmierung notwendig???? von: Reinhard
Geschrieben am: 02.04.2005 11:28:23

Hallo!

Was genau ist sverweis????

und wie mach ich das?

Danke


Bild


Betrifft: AW: VBA programmierung notwendig???? von: Hajo_Zi
Geschrieben am: 02.04.2005 11:30:21

Hallo Reinhard,

ein Blick in die Hilfe reicht da schon.

Buchungsmasken
 JKLM
17700004   
18  VornameVorname11111111
19Herr   
20   Fima
21    
22Tel geschäftlich11111111 AdresseAdresse11111111
23Tel privat11111111   
24Mobil11111111 URLURL11111111
25    
26Fax11111111 NameName11111111
27    
28    
29E-mail11111111   
30    
31DatumDatum11111111  
Formeln der Tabelle
M18 : =SVERWEIS($J$1;Lieferanten!A2:M9;5;0)
J19 : =SVERWEIS($J$1;Lieferanten!A2:M9;3;0)
J22 : =SVERWEIS($J$1;Lieferanten!A2:M9;7;0)
M22 : =SVERWEIS($J$1;Lieferanten!A2:M9;6;0)
J23 : =SVERWEIS($J$1;Lieferanten!A2:M9;8;0)
J24 : =SVERWEIS($J$1;Lieferanten!A2:M9;9;0)
M24 : =SVERWEIS($J$1;Lieferanten!A2:M9;12;0)
J26 : =SVERWEIS($J$1;Lieferanten!A2:M9;10;0)
M26 : =SVERWEIS($J$1;Lieferanten!A2:M9;4;0)
J29 : =SVERWEIS($J$1;Lieferanten!A2:M9;11;0)
K31 : =SVERWEIS($J$1;Lieferanten!A2:M9;13;0)
 
Lieferanten
 ABCDEFGH
1Lieferantennr.FimaAnredeNameVornameAdresseTel geschäftlichTel privat
2700001aaaaaSeñorName1Vorname1Adresse1Tel geschäftlich1Tel privat1
3700002bbbbbSeñoraName11Vorname11Adresse11Tel geschäftlich11Tel privat11
4700003cccccHerrName111Vorname111Adresse111Tel geschäftlich111Tel privat111
5700004dddddSeñoraName1111Vorname1111Adresse1111Tel geschäftlich1111Tel privat1111
6700005eeeeeFrauName11111Vorname11111Adresse11111Tel geschäftlich11111Tel privat11111
7700006ffffffSeñorName111111Vorname111111Adresse111111Tel geschäftlich111111Tel privat111111
8700007gggggSeñoraName1111111Vorname1111111Adresse1111111Tel geschäftlich1111111Tel privat1111111
9700008lhlhkljHerrName11111111Vorname11111111Adresse11111111Tel geschäftlich11111111Tel privat11111111
10        
11        
12        
13        
14        
15 Name Lieferantennr.=BEREICH.VERSCHIEBEN(Lieferanten!$A$2;0;0;ANZAHL(Lieferanten!$A:$A))     
16 Name Matrix=INDIREKT("Lieferanten!A2:M"&ANZAHL2(Lieferanten!$A:$A))     
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hajo

Das Forum lebt auch von den Rückmeldungen.


Bild


Betrifft: AW: VBA programmierung notwendig???? von: Ramses
Geschrieben am: 02.04.2005 11:29:46

Hallo

Frage 1:
Da ist die Funktion SVERWEIS() das richtige

Frage 2:
Ich kann mit 2003 die Datei öffnen und anpassen.
Allerdings glaube ich schon, dass EXCEL da langsam Limit ist, wohl weniger wegen den Schriften, sondern eher an den vielen Objekten

Beantragt VISIO oder sonst ein professionelles Flow-Chart Diagramm.
Kostet nicht die Welt, aber da hast du was vernünftiges.
Die Zeit die du verbratest um in deinem Diagramm Änderungen oder Anpassungen durchzuführen, sofern nötig, ist teurer als das Programm.

Gruss Rainer


Bild


Betrifft: AW: VBA programmierung notwendig???? von: Reinhard
Geschrieben am: 02.04.2005 12:06:38

Kann ich mit sverweis auf andere Exceltabellen verweisen?

Wenn ich das mache, dann gibt er mir den Fehler "Bezug"

Ich versteh das nicht?

Hat wer eine Antwort?

mfg Reinhard


Bild


Betrifft: AW: VBA programmierung notwendig???? von: Hajo_Zi
Geschrieben am: 02.04.2005 12:18:16

Hallo Reinhard,

da muß ich doch Fragen wozu ich mir die Mühe gemacht habe meine Tabelle im Beitrag einzufügen? Das sind zwei unterschiedliche Tabellen, wie man es im Posting auch sieht.

Gruß Hajo

Das Forum lebt auch von den Rückmeldungen.


Bild


Betrifft: AW: VBA programmierung notwendig???? von: Paula
Geschrieben am: 02.04.2005 12:26:55

hi,
klar, geht das

SVERWEIS(D1;[Test.xls]Tabelle1!$A$2:$D$100;2;FALSCH)

Erklärung: d1 ist zelle für den gesuchter Begriff; $A$2:$D$100 ist der Datenbereich aus der Datei Test.xls,Tabelle1,Bereich A2 bis beispielsweise d100;
2 ist die Spaltennr aus der der dazugehörige Eintrag gesucht wird .

Paula


Bild


Betrifft: AW: VBA programmierung notwendig???? von: Reinhard
Geschrieben am: 02.04.2005 12:37:23

Ich hab die Tabelle erst nach meinem Eintrag gesehn.....

Danke für eure Hilfe!

Jetzt ist mir alles klar!

Danke nochmal und schönes WE wünsch ich euch....!

lg Reinhard


Bild


Betrifft: AW: VBA programmierung notwendig???? von: Paula
Geschrieben am: 02.04.2005 11:52:13

hi,
benutze SVERWEIS zum Durchsuchen von links nach rechts

SP A SPB
Meier 200
müller 300

In D1 die Eingabe, in D2 folgende Formel:
=SVERWEIS(D1;A:B;2;FALSCH)


Erklärung: d1 ist gesuchter Begriff, A:B ist der Datenbereich (hier ganze Spalte),
2 ist die Spaltennr aus der der dazugehörige Eintrag gesucht wird .

Passe sie an deine Tabelle an. Wenn Überschriften vorhanden sind,ändere die Schreibform
"A:B" in "A1:Bxx" (XX ist Anzahl der Zeilen mit Daten)

Paula


 Bild

Beiträge aus den Excel-Beispielen zum Thema "VBA programmierung notwendig????"