Formelsuche

Bild

Betrifft: Formelsuche von: Josef
Geschrieben am: 07.04.2005 07:31:18

Hallo!

Ich habe folgende Formel:

=WENN(A2="06";"JA";WENN(A2="01";"JA";WENN(A2="02";"JA";WENN(A2="03";"JA";WENN(A2="04";"JA";WENN(A2="05";"JA";WENN(A2="07";"JA";WENN(A2="08";"JA";"NEIN"))))))))&WENN(A2="09";"JA";"NEIN")

Wenn die Zahl 9 vorhanden ist bekomme ich statt der Meldung JA die Meldung NEINJA.
Wo hätte ich hier bitte in der Formel den Fehler?

Danke


Josef

Bild


Betrifft: AW: Formelsuche von: Holger Levetzow
Geschrieben am: 07.04.2005 07:40:13

Hallo Josef,

was soll die Formel machen? reicht nicht? sie schreibt doch immer JANEIN oder NEINJA.

Holger


Bild


Betrifft: AW: Formelsuche von: Josef
Geschrieben am: 07.04.2005 07:45:19

Hallo Holger!


Die Formel sollte folgendes Ergebnis bringen:

Ist in der Spalte die 01, 02, 03, 04, 05, 06, 07, 08 oder 09 enthalten, dann soll in Spalte I der Wert JA eingetragen werden. Ist keiner dieser Werte vorhanden, dann sollte in Spalte I Nein stehen.

Da ja eine Verschachtelung nur 8x zulässig ist, versuchte ich diese Lösung, welche anscheinend aber leider nicht ganz gelungen ist.


Josef


Bild


Betrifft: AW: Formelsuche von: Thorsten
Geschrieben am: 07.04.2005 07:45:25

Hallo Josef,

wie wär´s mit

=WENN(ODER(A2="01";A2="02";A2="03";A2="04;A2="05;A2="06;A2="07;A2="08;A2="09;);"JA";"NEIN")

Gruß Thorsten


Bild


Betrifft: AW: Formelsuche von: Thorsten
Geschrieben am: 07.04.2005 07:47:41

So natürlich

=WENN(ODER(A2="01";A2="02";A2="03";A2="04";A2="05";A2="06";A2="07";A2="08";A2="09");"JA";"NEIN")


Bild


Betrifft: AW: Formelsuche von: Josef
Geschrieben am: 07.04.2005 08:58:25

Hallo Thorsten!

Besten Dank für Deine Hilfe


Josef


Bild


Betrifft: AW: Formelsuche von: Harald E
Geschrieben am: 07.04.2005 07:47:48

Moin Josef,

du kombinierst 2 Formeln mit &. Dagegen ist nix zu sagen...ausser, dass Du auch 2 Ergebnisse bekommst, wenn der erste Teil der Formel kein Ja produziert.


=WENN(UND(WERT(A2)>=1;WERT(A2)<=9);"Ja";"Nein")


Dürfte auch funzen

Gruß
Harald


Bild


Betrifft: AW: Formelsuche von: Josef
Geschrieben am: 07.04.2005 09:01:34

Hallo Harald!

Danke für Deinen Lösungsvorschlag.


Josef


Bild


Betrifft: Gern geschehen o.T. von: Harald E
Geschrieben am: 07.04.2005 09:20:37




 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bereich selektieren"