Rang - wenn..........

Bild

Betrifft: Rang - wenn..........
von: R.Schmitt
Geschrieben am: 18.04.2005 09:41:23
Guten Morgen,
wir beginnen die Woche gleich mit einer "Fiesen Formel"
Nun bin ich bekanntermaßen ja nicht der Formelexperte -
stehe aber vor dem Problem Ränge in Abhängigkeit eines
zu erfüllenden Kriteriums (Zugehörigkeit zu einem Land,
oder einer Gruppe) zu vergeben.
In der Datei
https://www.herber.de/bbs/user/21275.xls
dürfte klar werden, worauf ich rauswill.
Für die Kunden 1 bis 93 den Verkaufsrang BRD mittels
Formel und Hilfsspalte bei gleichen Werten zu errechnen
schaffe ich noch genauso, wie die Summen der einzelnen
Gruppen oder Bundesländer mittels Summenprodukt zu errechnen.
Wie aber schaffe ich es in den Spalten E und F den Verkaufsrang
des Kunden innerhalb dem Bundesland bzw der Gruppe der er zuge-
hörig ist mittels Formel darzustellen ?????
Habe am Sonntag nach zwei Stunden Herumprobieren mit wenn()
und so weiter entnervt aufgegeben und auch in der Recherche
leider nichts passendes gefunden (wobei ich da vieleicht auch
wissen sollte, wonach ich eigentlich suchen muß)
Euch allen schon mal
Vielen Dank
R.Schmitt

Bild

Betrifft: AW: Rang - wenn..........
von: Boris
Geschrieben am: 18.04.2005 10:57:04
Hi,
E2:
=SUMMENPRODUKT(($B$2:$B$94=$B2)*($D$2:$D$94>$D2))+1
F2:
=SUMMENPRODUKT(($C$2:$C$94=$C2)*($D$2:$D$94>$D2))+1
Soll "Rang Land" noch in Abhängigkeit der Gruppe ermittelt werden, dann in F2:
=SUMMENPRODUKT(($B$2:$B$94=$B2)*($C$2:$C$94=$C2)*($D$2:$D$94>$D2))+1
Und alles runterkopieren.
Grüße Boris
Bild

Betrifft: Vielen Dank
von: R.Schmitt
Geschrieben am: 18.04.2005 13:10:14
Lieber Boris,
vielen vielen Dank.
Scheint genau die Lösung meines Problems zu sein.
Viele Grüße
R.Schmitt
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel Files aus Powerpoint öffnen u. schliessen"