Ruhezeitberechnung

Bild

Betrifft: Ruhezeitberechnung
von: tim
Geschrieben am: 19.04.2005 15:35:08
Guten Tag
Ich habe bereits einmal einen Thread gepostet in dieser Sache, doch funktionierte die sache nicht so wie ich es beabsichtigt habe. vielleicht kann mir aber trotzdem jemand helfen. Ich habe für mich nun neue Anforderungen/Grundlagen geschaffen und benötige Hilfe für folgendes:
- in Spalte D und E wird jeweils der Beginn resp. das Ende der Arbeitszeit eingegeben
- jeder Tag muss in einer neuen Zeile erfasst werden
- ein Tag kann auch mit 00:00 bis 00:00 erfasst werden (freier Tag)
Mein Problem ist, dass ich eine Formel finden sollte, welche die Ruhezeit zwischen zwei Arbeitstagen berechnen kann,d.h. Arbeitsende bis Arbeitsbeginn. Diese Formel sollte auch bemerken, wenn sich ein oder mehrere freie Tage dazwichen befinden und diese freien Tage dazurechnen (Bsp. Montag Ende um 18:00, Dienstag frei, Mittwoch frei, Donnerstag Beginn um 07:00, Total Ruhezeit = 61 Std.)
Die Berechnung mit SUMME(E1-D2) funktioniert nicht, da diese Formel nicht über mehrere Felder geht und auch nicht bemerkt, wenn ein freier Tag dazwischen ist.
Kann mir jemand unter die Arme greifen???
Vielen Dank

Bild

Betrifft: AW: Ruhezeitberechnung
von: UweD
Geschrieben am: 19.04.2005 16:20:59
Hallo
so als Ansatz:

 
 ABCD
1TagBeginnEndeRuhe
2Mo. 18.04.2005 18:00 
3Di. 19.04.2005  6
4Mi. 20.04.2005  24
5Do. 21.04.200507:00 31
6    
7    
8  Summe61
9Format: TTT. TT.MM.JJJJhh:mmhh:mmStandard
Formeln der Tabelle
D3 : =((A3+B3)-(A2+C2))*24
D4 : =((A4+B4)-(A3+C3))*24
D5 : =((A5+B5)-(A4+C4))*24
D8 : =SUMME(D2:D5)
 


Gruß UweD
Bild

Betrifft: AW: Ruhezeitberechnung
von: tim
Geschrieben am: 19.04.2005 16:38:05
danke, werde es so versuchen.
gruss
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Springen zw Tabellenblättern mit CommandButton"