Stundenrechnung ohne Pause

Bild

Betrifft: Stundenrechnung ohne Pause
von: Ludwig
Geschrieben am: 21.04.2005 08:43:20
Hallo!
Ich habe einen Tätigkeitsbericht als Excelvorlage entworfen, in dem Mitarbeiter Ihre Tätigkeiten eintragen können. Diese sind als Standardtexte hinterlegt. Wählt man eine Tätigkeit aus, so wird in einem anderen Feld die passende Auftragsnummer eingetragen.
Desweiteren muss der MA dann noch seine Uhrzeit eintragen.

Hier mein Beispiel:

 
 ABCDFGH
5TagBezeichnung der TätigkeitvonbisStd.Auftrags-Nr./
601P Monatsabrechnung - Ablesung07:0009:002,0082 9000 0562
7 P Pegelmessungen09:0016:057,0882 9000 0565
802N Druckmessungen (ESS, Elektriker)07:0016:059,0882 9000 0582
Formeln der Tabelle
F6 : =WENN(C6>D6;"";D6-C6)*24
G6 : =WENN(ISTNV(SVERWEIS(B6;Standardtexte;2;0));"";SVERWEIS(B6;Standardtexte;2;0))
F7 : =WENN(C7>D7;"";D7-C7)*24
G7 : =WENN(ISTNV(SVERWEIS(B7;Standardtexte;2;0));"";SVERWEIS(B7;Standardtexte;2;0))
F8 : =WENN(C8>D8;"";D8-C8)*24
G8 : =WENN(ISTNV(SVERWEIS(B8;Standardtexte;2;0));"";SVERWEIS(B8;Standardtexte;2;0))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


In einem weiteren Reiter für die Stundensummen ist eine Formel hinterlegt.
Hier stehen in Spalte A alle verfügbaren Auftragsnummern, in Spalte B die Formel, die dann jeweils alles Stunden zur passenden Auftragsnummer zusammenzählt.
So, da die aufaddierten Stunden nicht tages- sondern auftragsgebunden sind, wie kann ich Excel mitteilen, daß trotzdem 0,75 Pause pro Arbeitstag abzuziehen sind?
Oder bleibt nur der manuelle Weg des Mitarbeiters die Zeiten entsprechend einzutragen? Das wollte ich nämlich vermeiden, da einige gerade mal wissen wo man den Mausknopf findet. :)
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: ingoG
Geschrieben am: 21.04.2005 11:34:34
Hallo Ludwig,
schau dir mal folgende Datei an...
https://www.herber.de/bbs/user/21477.xls

hab der einfachheit halber mit hilfszeilen gearbeitet.
pause wird nur abgezogen, wenn mindestens 6 Stunden gearbeitet wurden (kannst Du ja ändern, wenn es anders gehandelt werden soll)
Die formeln gehen allerdings davon aus, dass die Zeiten und Tage nacheinander in chronologischer Reihenfolge vorliegen.
Gruß Ingo
PS eine Rückmeldung wäre nett...
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: Ludwig
Geschrieben am: 21.04.2005 12:10:39
Vielen Dank erstmal für deine Mühe.
Aber hier liegt der Hund begraben.
Deine Tabelle errechnet in der letzten Spalte zwar die richtige Anzahl Stunden, aber mit der kann ich nichts anfangen, da die Stunden in Spalte E (mein obiges Beispiel = Spalte F) ausschlaggebend sind.
Denn diese Stunden werden zu den Auftragsnummern verbucht. Da bringt mir eine reine Tagessumme leider nichts.
Deine Spalte L müsste jetzt quasi erkennen in welchem Zeitrahmen die 12 Uhr-Marke ist. (09:00 bis 16:05 z. B.) und hier dann die 0,75 abziehen.
Die Summe sollte dann in der Spalte E stehen bzw. F nach meinem Bsp.
Anders lässt sich das wohl nicht realisieren!!?
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: ingoG
Geschrieben am: 21.04.2005 12:35:14
hallo Ludwig,
wenn Du generell nicht zwischen 12:00 und 12:45 arbeiten darfst geht das nat.
aber was ist, wenn ein MA um 11 ins Büro kommt, 2 Std am Projekt arbeitet und dann wieder nach hause geht.
bekommt er dann auch die Pause abgezogen?
Da müsstest Du Dich auf jeden Fall noch einmal zu äußern und am besten in Deine Tabelle einige Grenzfälle eingeben mit einer Solllösung (als wert), damit man weiss, was rauskommen soll...
Gruß Ingo
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: Ludwig
Geschrieben am: 21.04.2005 13:34:13
Das pro Arbeitstag mal jemand nur 2 Stunden einträgt gibt es nicht.
Sobald etwas eingetragen wird, gilt das immer für die volle Sollarbeitszeit pro Tag.
Also wenn ein Mitarbeiter eine Tätigkeit da einträgt, dann ist die Zeit IMMER mit einer Auftragsnummer verknüpft.
OK, im Klartext und um es gleich richtig zu erklären ist das bei uns so, folgende Zeiten werden als Pause abgezogen:
Montag - Donnerstag:
09:00 - 09:15 (0,25)
12:00 - 12:30 (0,50)
Sollarbeitszeit 8,33
Freitag:
09:00 - 09:15 (0,15)
Sollarbeitszeit 5,17
Diese Pausenregelung sollte berücksichtigt werden.
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: IngoG
Geschrieben am: 21.04.2005 14:07:48
Hallo Ludwig,
dann versuch mal:
=(D3-C3-(WENN(UND(D3>"9:00:00"*1;C3<"9:15"*1);MIN("9:15";D3)-MAX("9:00";C3);0)+WENN(UND(D3>"12:00"*1;C3<"12:30"*1);(MIN("12:30";D3)-MAX("12:00";C3));0)))*24

bei mir funzt das für die Mo-Do anforderung...
wenn Du noch ein Kriterium nennst, aus dem man den Freitag ablesen kann, kann die 2. Und() funtion noch darum erweitert werden.
Gruß Ingo
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: Ludwig
Geschrieben am: 22.04.2005 07:04:59
WOW!
Vielen Dank!
Die Formel funtzt, aber nur MO-DO.
Freitags ist die Arbeitszeit 07:00 bis 12:25 Uhr und da zieht Excel die 25 Minuten ab 12 Uhr natürlich auch mit ab. Hab da nicht daran gedacht.
Desweiteren habe ich ganz vergessen, daß einige Mitarbeiter am Wochenende Bereitschaftsdienst haben. Hier werden ~3-5 Stunden eingetragen.
Hmm, aber diese Zeiten kann man wohl schlecht unterscheiden um sie von der Formel "unbeachtet" zu lassen!?!
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: IngoG
Geschrieben am: 22.04.2005 09:32:26
Hallo Ludwig,
innerhalb der Zeile kann man nicht erkennen, welcher wochentag gerade ist...
Du mußt nur innerhalb der Zeile das Datum hinterlegen .
Ich hab Dir nochmal eine Datei hochgeladen, in der das verdrahtet ist.
https://www.herber.de/bbs/user/21544.xls

Gruß Ingo
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: Ludwig
Geschrieben am: 22.04.2005 09:47:03
Fast perfekt!!! Vielen Dank!
Das einzigste wäre noch mit dem Datum.
Der Mitarbeiter öffnet jeden Monat eine neue, leere Vorlage.
Hier muss er oben nur den Monat eintragen, bevor er seine Tätigkeiten einträgt.
Das Datumsformat ist bei uns so gewählt: z. B. 04/05 also April 2005.
In Spalte A trägt er dann nur noch die Tage ein (ohne Punkt, also nur 02 statt 02.)
Lässt sich das noch auf deine/meine Vorlage übertragen?
Dann wäre es perfekt.
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: IngoG
Geschrieben am: 22.04.2005 11:27:51
Hallo Ludwig,
am einfachsten geht das mit einer ausgeblendeten Hilfsspalte...
https://www.herber.de/bbs/user/21558.xls
die Spalte a kannst Du dann einfach ausblenden und die Spalte i löschen...
Gruß Ingo
Bild

Betrifft: AW: Stundenrechnung ohne Pause
von: Ludwig
Geschrieben am: 25.04.2005 07:23:42
Also irgendwas stimmt mit unserem Proxy nicht.
Konnte die Datei am Freitag schon nicht runterladen und heute auch noch nicht.
Oder stimmt was mit dem Link nicht?
Kannst du mir die Datei bitte per Mail zuschicken?
Bitte an yawa at gmx . de
Danke!
Bild

Betrifft: Link sollte funzen
von: IngoG
Geschrieben am: 25.04.2005 12:45:51
Hallo Ludwig,
sorry, aber ich kann dir momentan leider keine Email schicken...
ich selber hab aber keine Probs die Datei zu öffnen...
vielleicht schaffe ich es bis heute abend, bin mir aber nicht sicher, ob ich dann dazu komme.
Gruß Ingo
Bild

Betrifft: Adresse nicht gefunden!!!
von: ingoG
Geschrieben am: 26.04.2005 00:37:17
Hallo Ludwig,
habe gerade versucht, dir die Exceldatei zuzusenden, hat aber nicht gefunzt
yawa@gmx.de wird als nicht existent gemeldet...
vielleicht versuchst Du ja nochmal von einem anderen Rchner die Datei hier zu öffnen
Gruß Ingo
 Bild

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN mit VBA, chemische Verbindungen"