Herbers Excel-Forum - das Archiv

Mittelwert errechnen bis Zelle leer

Bild

Betrifft: Mittelwert errechnen bis Zelle leer
von: Andreas Krutzler

Geschrieben am: 21.04.2005 16:10:17
Hallo zusammen!
Nachdem ich mich nun den halben Tag durch Euer Forum gelesen habe und leider keine Lösung für mein Problem gefunden habe, bitte ich um Hilfe:
Ich habe ein Excel-Liste in der monatlich per copy/paste in den ersten vier Spalten (A bis D) die Daten der Tankungen einzelner LKW eingetragen werden. In einer Spalte dahinter (I) lasse ich per Wenn-Formelden Dieselverbrauch pro Tankung errechnen.
Nun will ich in der letzten Spalte (J) den Mittelwert aller errechneten Verbräuche pro Fahrzeug und Monat berechnen lassen und das soll auch funktionieren, wenn der LKW im kommenden Monat fünf Mal tanken wird, ohne daß ich die Formel ändern muß.
Ich denke da an eine Formel, die solange die Zahlen in der Spalte I beachtet und zur Berechnung heranzieht, bis eine leere Zelle auftaucht und ab der nächsten vollen Zelle wieder von vorne beginnt.
Danke einstweilen!
mfg Andreas!
https://www.herber.de/bbs/user/21503.xls
Bild

Betrifft: AW: Mittelwert errechnen bis Zelle leer
von: Dr.
Geschrieben am: 21.04.2005 16:27:42
Hi Andreas,
das wäre eine Möglichkeit:
=SUMMEWENN(A:A;A3;I:I)/ZÄHLENWENN(A:A;A3)
(in Zelle K3 Deiner Tabelle...)
Bild

Betrifft: AW: Mittelwert errechnen bis Zelle leer
von: Dr.
Geschrieben am: 21.04.2005 16:29:57
Sorry, muss natürlich noch einen abziehen:
=SUMMEWENN(A:A;A3;I:I)/(ZÄHLENWENN(A:A;A3)-1)
Bild

Betrifft: AW: Mittelwert errechnen bis Zelle leer
von: Andreas Krutzler
Geschrieben am: 22.04.2005 07:25:05
Perfekt!
Vielen Dank!
 Bild
Excel-Beispiele zum Thema "Mittelwert errechnen bis Zelle leer"
Mittelwert ohne Nullwerte Bedingter Mittelwert
Aus einer Reihe von 10-minütigen Messungen h-Mittelwerte auslesen Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel
Berechnung von Zeitspanne und Mittelwert Mittelwert aus den 6 höchsten Werten in Spalte A ermitteln
Portokosten aus einer Gewichts-/Gebietsmatrix errechnen Zeitdifferenz in Schulstunden (45 Minuten) errechnen
Schulnote anhand einer Punktetabelle errechnen Werte summieren, in erste freie Zeile eintragen, Differenz errechnen