Istfehler

Bild

Betrifft: Istfehler
von: Slugger
Geschrieben am: 25.04.2005 14:50:13
Hallo zusammen,
ich habe diese Formel. Hier soll nun bei dem 2ten Sverweis noch ein Istfehler mit rein. Weiß jemand wie hierfür der Syntax ist? Ich krieg immer nur Formelfehler angezeigt. Die Formal an sich aber funktioniert. Ich bekomme nur an manchen Stellen in der Tabelle #Wert angezeigt.
=(WENN(ISTFEHLER(SVERWEIS(A2;test;3;0)=WAHR);0;SVERWEIS(A2;test;3;0)))*1
gruß

Bild

Betrifft: AW: Istfehler
von: Hajo_Zi
Geschrieben am: 25.04.2005 14:59:00
Hallo Slugger,
die Formel ist eigentlich ok. Ein wenig kürzer
=WENN(ISTFEHLER(SVERWEIS(A2;test;3;0));0;SVERWEIS(A2;test;3;0))*1

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.



"Wer Rechtschreibfehler findet, darf sie behalten!" Dies gilt auch für Bert.
Bild

Betrifft: AW: Istfehler
von: Slugger
Geschrieben am: 25.04.2005 15:07:29
Hallo und danke für den Hinweis,
Wie bekomme ich es jetzt noch hin das er mir beim 2ten SVerweis-Kriterium anstatt
#Wert eine Null reinschreibt?
Im Prinzip soll sie so oder so ähnlich aussehen:
=WENN(ISTFEHLER(SVERWEIS(A2;test;3;0));0;(Wenn(Istfehler(SVERWEIS(A2;test;3;0));0)*1)))
gruß
Slugger
Bild

Betrifft: AW: Istfehler
von: Hajo_Zi
Geschrieben am: 25.04.2005 15:16:54
Hallo Slugger,
irgendwie würde ich schreiben, der zweite Sverweis sieht genauso aus wie der erste. Das ist mir nicht klar was das soll. Zuerst prüft Du ob Sverweis ein Fehler ergibt dann schreibe 0, dann prüft Du nochmal ob der selbe Sverweis ein Fehler ergibt, das wurde doch schon geprüft warum soll was anderes rauskommen! Du kanst das beliebig oft prüfen (max.Formelänge 1024 Zeichen) es kommt aber immer das gleiche raus.
Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.

"Wer Rechtschreibfehler findet, darf sie behalten!" Dies gilt auch für Bert.
Bild

Betrifft: Text * 1 = #Wert
von: Kl@us-M.
Geschrieben am: 25.04.2005 20:43:19
Hi slugger,
so wie Du das Prob beschreibst, multiplizierst Du einen Text mit 1.
btw: Was soll die Multiplikation mit 1 denn bewirken ????
Gruss aus dem wilden Hunsrück
Klaus-Martin

Bild

Betrifft: AW: Istfehler
von: Martin Beck
Geschrieben am: 25.04.2005 16:40:15
Hallo,
was soll denn rauskommen? Wenn SVERWEIS nichts findet die 0, sonst die 1?
=WENN(ISTFEHLER(SVERWEIS(A2;test;3;0);0;1)
Gruß
Martin Beck
Bild

Betrifft: Danke an alle
von: Slugger
Geschrieben am: 26.04.2005 08:15:50
Hallo,
ja diese Frage hatte ich mir auch gestellt was rauskommt wenn ichs *1 multipliziere.
Keine Ahnung wie ich darauf gekommen bin. Nuja, vielen Dank an alle die geholfen haben,
diesen dummen Fehler zu beseitigen ;-)
gruß
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Laufzeitfehler 70 abfragen"