Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMENPRODUKT?

Betrifft: SUMMENPRODUKT? von: Fernandez
Geschrieben am: 24.05.2005 14:07:23

Hi
Ich will folgendes machen:
3 Spalten, in der ersten steht eine Währung(USD,EUR,GBP), in der zweiten ein Preis und in der dritten ein Gewicht. Nun will ich alle Preise mit dem Gewicht multiplizieren und davon die Summe bilden die z.B. in der Währung "EUR" dastehen. Habs mit SUMMENPRODUKT probiert aber sgeht nicht. Ich brauche eigentlich sowas wie: SUMMENPRODUKTE(Bedingung;Bereich1;Bereich2) - Danke für jede Hilfe.

MAnuel

  


Betrifft: AW: SUMMENPRODUKT? von: serge
Geschrieben am: 24.05.2005 14:15:10

Hi Manuel
A1= Währung, B1= Preis, C1 = Kilos
=B1*C1&" "&A1
Serge


  


Betrifft: AW: SUMMENPRODUKT? von: bavariabob
Geschrieben am: 24.05.2005 14:16:29

Servus Manuel,

Währung Spalte A
Preis Spalte B
Gewicht Spalte C:

= summenprodukt((A1:A10="EUR")*(B1:B10)*(C1:C10))

Gruss aus München


  


Betrifft: AW: SUMMENPRODUKT? von: Fernandez
Geschrieben am: 24.05.2005 14:40:07

@bavariabob

Danke erstmal.
Aber das hab ich schon probiert: =SUMMENPRODUKT(('BR710 Master-Data'!U3:U27="EUR")*('BR710 Master-Data'!V3:V29)*('BR710 Master-Data'!Y3:Y29)) jedoch bekomme ich jedesmal die Fehlermeldung #NV!.


  


Betrifft: AW: SUMMENPRODUKT? von: bavariabob
Geschrieben am: 24.05.2005 14:55:37

Manuel,

kannst du eine beispieldatei hochladen?


  


Betrifft: AW: SUMMENPRODUKT? von: Fernandez
Geschrieben am: 24.05.2005 15:04:26

Ok danke habs jetz.
Lag daran, daß der beich der bedingung nicht bis Zeile 29 wie die anderen beiden bereiche ging.




  


Betrifft: AW: SUMMENPRODUKT? von: magicman
Geschrieben am: 24.05.2005 15:02:07

Hallo Manuel,

Summenprodukt mag u.A. keine Leerzeichen/Sonderzeichen im Registernamen, da hatte ich auch schon mal das gleiche Problem.

Änder mal den Namen:

BR710 Master-Data

in

BR710MasterData

und probier die Formel nochmal aus.

Gruß
Michael