Herbers Excel-Forum - das Archiv

Aufs Datum beziehen

Bild

Betrifft: Aufs Datum beziehen
von: Niker

Geschrieben am: 15.12.2006 08:34:25
Hallo @all
ich möchte folgende Wenn-Funktion.
Und zwar wenn in der Zeile XY ein Datum steht ( bsp. 14.12.2006 - angezeigt als "Do. 14. Dez 06", dann gib mir den Kalenderwoche, "50" in dem Fall, an sonst nix.
Wie lautet hierzu die Funktion? Kann mir da einer bitte weiterhelfen? Dankeschön!
LG
Bild

Betrifft: AW: Aufs Datum beziehen
von: UweD

Geschrieben am: 15.12.2006 09:00:27
Hallo
möchtest du wirklich auf ein "DATUM" hin prüfen, oder reicht es auf "Zelle nicht leer" abzufragen?
dann wäre das eine Lösung:
 
 AB
1Fr. 15. Dez 0650
Formeln der Tabelle
B1 : =WENN(A1<>"";KÜRZEN((A1-DATUM(JAHR(A1+3-REST(A1-2;7));1;REST(A1-2;7)-9))/7);"")
 

Gruß UweD
(Rückmeldung wäre schön)
Bild

Betrifft: AW: Aufs Datum beziehen
von: Harald E

Geschrieben am: 15.12.2006 09:02:54
Hi,
anderer Vorschlag:
Nutze Gültigkeit für die Datumszeile (Datum zulassen größer als...irgendein früheres Datum)
und frag die Zellen auf Füllung ab
=WENN(A1<>"";KÜRZEN((A1-DATUM(JAHR(A1+3-REST(A1-2;7));1;REST(A1-2;7)-9))/7);"")
Gruss Harald
Bild

Betrifft: AW: Aufs Datum beziehen
von: Niker
Geschrieben am: 15.12.2006 09:10:36
Vielen Dank es hat geklappt.
LG
p.s. Ihr seid hier echt klasse!
Bild

Betrifft: AW: Aufs Datum beziehen
von: wegen!
Geschrieben am: 15.12.2006 09:35:31
Nicht nur hier!^^
 Bild