Herbers Excel-Forum - das Archiv

Mietlaufzeiten

Bild

Betrifft: Mietlaufzeiten
von: architerror

Geschrieben am: 05.01.2007 14:35:50
Hallo Ihr EXCELlenten!
Für meine Studienarbeit versuche ich die eine automatische Mieterliste zu erstellen.
Dabei gibt es aber ein Problem mit der Anzahl der Argumente der WENN-Funktion.
Ich möchte am liebsten keine Beschränkung der Anzahl der Argumente (Mieteinheiten).
Gibt es eine andere Möglichkeit z.B. durch SUMMENPRODUKT oder etwas ähliches.
Hier habe ich eine Beispieldatei vorbereitet:
https://www.herber.de/bbs/user/39411.xls
Grüne Felder sollen Eingabefelder werden, die Rosaroten sind gesucht oder funktionieren noch nicht 100%ig.
Ich freue mich über jede Hilfe
Tausend Dank!
architerror
Bild

Betrifft: AW: Mietlaufzeiten
von: Daniel Eisert

Geschrieben am: 05.01.2007 15:24:47
Hallo
so ganz durchschau ich dein Projekt noch nicht, aber für deine Aufgabenstellung hilfreich sein könnten:
- Summenprodukt
- SVerweis, Vergleich und Index
- und Matrix-Funktionen allgemein (nicht alles lässt sich mit Summenprodukt abbilden, mit Matrx-Funktionen hast du mehr möglichkeiten
Gruß, Daniel
Bild

Betrifft: Konkretisierung der Fragestellung
von: architerror

Geschrieben am: 05.01.2007 15:51:52
Hallo Daniel,
Danke für Deine Nachricht. Ich versuche nocheinmal die Fragestellung zu formulieren.
Es gibt viele Mieteinheiten mit existierenden Mietverträgen, diese laufen irgendwann aus (Ende Mietvertrag) und werden dann nach einer Leerstandphase an einen neuen Mieter Nachvermietet (Start Date).
In der Zeile "Vermietungsstand existierende Mietverträge" sollen alle Flächen addiert werden die mit alten Mietverträgen vermietet sind.
In der Zeile "Vermietungsstand Nachvermietung" sollen alle Flächen addiert werden, die mit neuen Mietverträgen ausgestattet sind.
Ich hatte einen Versuch gestartet mit Wenn-Funktionen, der funktionierte auch, wenn sich der Start der Berechnung (beispielsweise auf 30-April-2007) verschoben wurde.
Mein Problem:
Die Methode funktionierte nur mit weniger als 7 oder 10 Mieteinheiten.
Jetzt sollen es aber mehr werden.
Ich denke SUMMENPRODUKT ist keine Lösung, da die Matrizen gleich lang sein müssen. Beim Vergleich des Datums gibt es viele Felder für Start Mietvertrag / Ende Mietvertrag, aber nur eines mit dem Datum des jeweiligen Berechnungsjahres.
Ich hoffe, die Frage kann nun besser verstanden werden.
Viele Grüße
architerror
Bild

Betrifft: AW: Konkretisierung der Fragestellung
von: Daniel Eisert

Geschrieben am: 05.01.2007 17:04:15
Hallo
dann ist es ja relativ einfach, Altvermietungen sind dann alle, deren Endtermin größer als das aktuelle Datum ist, das ist dann ja nur eine bedingung und geht ganz einfach mit der SUMMEWENN-Funktion die Formel dazu sieht dann so aus:
=SUMMEWENN($C$4:$C$8;">"&C16;$B$4:$B$8)
durch das Grösserzeichen werden alle Werte berücksichtigt, die Grösser als das Datum in C16 sind. Erst, wenn es mehrere Bedingunge sind, brauchst du Matrix-Formeln oder Summenprodukt. Damit lässt sich dann aber auch dein Problem abbilden. Such mal im Archiv unter "mehrere Bedingungen" oder so ähnlich, da solltest du genügend finden.
 Bild