Herbers Excel-Forum - das Archiv

Sverweis Hilfe

Bild

Betrifft: Sverweis Hilfe
von: Michael

Geschrieben am: 07.01.2007 18:34:16
Hallo Leute,
ich habe mal eine Frage bezüglich des Sverweis, einen einfachen Sverweis bekomme ich ja noch hin, aber hier muss ich leider mal nachfragen.
Und zwar habe ich eine Excel Tabelle mit Verkäufern und deren Umsatz, nun soll mittels Sverweis jedem Verkäufer die jeweilige Provision zugeordnet werden.
Mein Problem dabei ist, das es bei den Umsätzen heißt "BIS" sprich, Excel nimmt wenn ich zwischen 2 Werten liege generell den niedrigeren.
Die Datei findet Ihr hier

Die Datei https://www.herber.de/bbs/user/39453.xls wurde aus Datenschutzgründen gelöscht

Ich danke schon mal für jede Hilfe die ihr mir geben könnt.
Bild

Betrifft: AW: Sverweis Hilfe
von: ransi

Geschrieben am: 07.01.2007 18:53:55
Hallo Michael
Tabelle1

 ABCD
1    
2    
3Verkäufer: UmsatzProvision
4MeierKlaus226487,00%
5GeierMartin85360,00%
6LomerIngrid549580,00%
7SchneiderKerstin4765812,00%
8FeiglMaximilian161285,00%
9    
10    
11Umsatz bisProzent vom Umsatz  
1200,00%  
13100005,00% höchster Umsatz
14200007,00% niedrigster Umsatz
15300009,00% durchschnitt Umsatz
164000012,00%  
1750000   
18    

Formeln der Tabelle
ZelleFormel
D4=SVERWEIS(C4;$A$12:$B$17;2)
D5=SVERWEIS(C5;$A$12:$B$17;2)
D6=SVERWEIS(C6;$A$12:$B$17;2)
D7=SVERWEIS(C7;$A$12:$B$17;2)
D8=SVERWEIS(C8;$A$12:$B$17;2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Wobei jetzt aber zu klären wäre was mit dem Kollegen ist der mehr als 50000 gemacht hat...
Soll der in die Röhre gucken ??
ransi
Bild

Betrifft: AW: Sverweis Hilfe
von: Michael

Geschrieben am: 07.01.2007 20:05:20
Danke Ransi, aber jetzt passt ja die Tabelle nicht mehr und die Berechnung,
Beim ersten Verkäufer z.B. der hat einen Umsatz von 22648, kriegt aber nur die Provision "BIS" 20000 obwohl er ja doch drüber liegt.
Das war ja auch mein anfängliches Problem.
Bild

Betrifft: AW: Sverweis Hilfe
von: HermannZ

Geschrieben am: 07.01.2007 19:05:40
Hallo Michael;
oder meinst du das so??
Beispiel;
 
 ABCDEFG
110Verkäufer: UmsatzProvision   
111MeierKlaus226481585,36   
112GeierMartin85360   
113LomerIngrid549586594,96   
114SchneiderKerstin476585718,96   
115FeiglMaximilian16128806,4   
116       
117Umsatz bisProzent vom Umsatz     
1180      
119100000,00%     
120200005,00% höchster Umsatz54958LomerIngrid
121300007,00% niedrigster Umsatz8536GeierMartin
122400009,00% durchschnitt Umsatz29985,6  
1235000012,00%     
124 12,00%     
Formeln der Tabelle
D111 : =C111*WENN(ISTFEHLER(VERGLEICH(C111;$A$118:$A$123));0;INDEX($B$119:$B$124;VERGLEICH(C111;$A$118:$A$123);1))
D112 : =C112*WENN(ISTFEHLER(VERGLEICH(C112;$A$118:$A$123));0;INDEX($B$119:$B$124;VERGLEICH(C112;$A$118:$A$123);1))
D113 : =C113*WENN(ISTFEHLER(VERGLEICH(C113;$A$118:$A$123));0;INDEX($B$119:$B$124;VERGLEICH(C113;$A$118:$A$123);1))
D114 : =C114*WENN(ISTFEHLER(VERGLEICH(C114;$A$118:$A$123));0;INDEX($B$119:$B$124;VERGLEICH(C114;$A$118:$A$123);1))
D115 : =C115*WENN(ISTFEHLER(VERGLEICH(C115;$A$118:$A$123));0;INDEX($B$119:$B$124;VERGLEICH(C115;$A$118:$A$123);1))
E120 : =MAX(C111:C115)
F120 : =INDEX(A111:A115;VERGLEICH($E120;$C$111:$C$115;0))
G120 : =INDEX(B111:B115;VERGLEICH($E120;$C$111:$C$115;0))
E121 : =MIN(C112:C116)
F121 : =INDEX(A111:A115;VERGLEICH($E121;$C$111:$C$115;0))
G121 : =INDEX(B111:B115;VERGLEICH($E121;$C$111:$C$115;0))
E122 : =MITTELWERT(C111:C115)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß HermannZ
 Bild
Excel-Beispiele zum Thema "Sverweis Hilfe"
SVERWEIS auf geschlossene Arbeitsmappe aus Makro aufrufen Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
Arbeitszeittabelle und SVERWEIS-Formel Zugriff über SVERWEIS() auf eine Artikelliste
SVERWEIS-Formel über mehrere Fundstellen SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele
SVERWEIS, WVERWEIS, INDEX, VERGLEICH und Zielwertsuche Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen
Hyperlinks zu SVERWEIS-Bezugstabellen anlegen SVERWEIS als Ereignisprozedur