Microsoft Excel

Herbers Excel/VBA-Archiv

Problem mit dem Forumseditor

Betrifft: Problem mit dem Forumseditor von: Daniel
Geschrieben am: 10.03.2007 12:21:03

Hallo
mal ne Frage

wenn ich hier mit dem Forumseditor einen Beitrag schreibe und die Formatierungsfunktion "Zitat" verwende, dann werden bei dem Text, der auf das Zitat folgt, alle Zeilenumbrüche entfernt und der Text wird als Fließtext geschrieben.

Dadurch geht natürlich jede strukturierung verloren und das ganze wird sehr schwer lesbar.

Wie kann man das vermeiden?

Gruß, Daniel

  


Betrifft: AW: Problem mit dem Forumseditor von: Hans W. Herber
Geschrieben am: 10.03.2007 12:41:29

Hallo Daniel,

kann es sein, dass Du überhaupt keine echten Zeilenumbrüche drin hast, sondern nur die unechten, die erzeugt werden, wenn die Zeile am Ende des Eingabeformulars automatisch umgebrochen wird? Die zählen nicht.

Gruss hans


  


Betrifft: AW: Problem mit dem Forumseditor von: Daniel
Geschrieben am: 10.03.2007 12:55:19

Hallo
mal ausprobieren:
kann es sein, dass Du überhaupt keine echten Zeilenumbrüche drin hast, sondern nur die unechten, die _
        		erzeugt werden, wenn die Zeile am Ende des Eingabeformulars automatisch umgebrochen wird? Die zählen _
         	nicht.
        
So, jetzt schreib eich mal einfach einen Text und drücke ENTER und nocheimal ENTER und dann sehen wir ja was passiert. Wie du siehst, habe ich versucht mit ENTER einen Zeilenumbruch zu erzeugen, aber nichts passiert. kann es sein, daß die Forums-Software und mein Opera-Browser nicht ganz zusammenpassen? so erscheint der Text, bei mir im Editior, das Ergebnis im Forum siehst du ja. <img src="https://www.herber.de/bbs/user/41012.gif" border=0> Gruß, Daniel

  


Betrifft: AW: Problem mit dem Forumseditor mit Bild von: Daniel
Geschrieben am: 10.03.2007 12:58:29

So, jetzt mit Screenshot von meiner Eingabe:



ich habe den Codeschnipsel für das Bild genauso reinkopiert, wie in meiner ersten Anwort, allerdings diesmal ohne die Zitat-Funktion zu verwenden.
Hier erscheint das Bild (in der Vorschau), im ersten Posting (nach der Zitat-Funktion) nicht.

Woran könnte das liegen?

Gruß, Daniel


  


Betrifft: AW: Problem mit dem Forumseditor mit Bild von: Hans W. Herber
Geschrieben am: 10.03.2007 13:27:29

Hallo Daniel,

ich versuche mal, es nachzuvollziehen:
      kann es sein, dass Du überhaupt keine echten Zeilenumbrüche drin hast, sondern nur die unechten, die _
      		erzeugt werden, wenn die Zeile am Ende des Eingabeformulars automatisch umgebrochen wird? Die zählen _
       	nicht.
       
      

So, jetzt schreibe ich einfach mal einen Text und drücke ENTER
und noch einmal ENTER
und wir werden sehen, was passiert.

Gruss Hans


  


Betrifft: AW: Problem mit dem Forumseditor mit Bild von: Hans W. Herber
Geschrieben am: 11.03.2007 05:29:28

... ich habe an der Sache nochmal gearbeitet und hoffe, dass es sich erledigt hat.

Gruss hans


  


Betrifft: AW: Problem mit dem Forumseditor mit Bild von: Daniel
Geschrieben am: 11.03.2007 13:55:58

Hallo Hans

danke für die Arbeit.
momentan ist es bei mir so, daß

  • wenn die Zitat-Marken in einer eigenen Zeile stehen, dann funkitoneren die Zeilenumbrüche danach einwandfrei.

  • wenn die Zitat-Marken in der gleichen Zeile stehen, wie der Zitat-Text, dann geht der Zeilenumbruch danach nicht.



  • Gruß Daniel


      


    Betrifft: AW: Beispiel Fall 1, Marker in eigner Zeile von: Daniel
    Geschrieben am: 11.03.2007 13:58:52

    Test1
    Test2
    Test3
    Test1
    Test2
    Test3
       Zitat
       

    Test4
    Test5
    Test6

    allerdings stellt sich die Frage, wo das verdoppeln der Zeilen über dem Zitat herkommt.


      


    Betrifft: AW: Beispiel, Marker in gleicher Zeile wie Zitat von: Daniel
    Geschrieben am: 11.03.2007 14:00:34

    Test1
    Test2
    Test3
    Test1
    Test2
    Test3
    Zitat
    Test4 Test5 Test6

      


    Betrifft: AW: Beispiel, Marker in gleicher Zeile wie Zitat von: Hans W. Herber
    Geschrieben am: 13.03.2007 06:00:47

    test1
    test2
    test3
    test4
    test5
    test1
    test2
    test3
    test4
    test5
    Zitat

    OK
    verstanden
    hans



      


    Betrifft: jetzt geht von: Daniel
    Geschrieben am: 14.03.2007 18:11:35

    test1
    test2
    test3
    zitat

    test4
    test5
    test6

    Hallo Hans,
    jetzt klappt es, vielen Dank für die Mühe (auch im Namen der Leser meiner Beiträge.)

    Gruß, Daniel


     

    Beiträge aus den Excel-Beispielen zum Thema "Problem mit dem Forumseditor"