Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

PLZ BEREICH

Betrifft: PLZ BEREICH von: Lolie
Geschrieben am: 01.10.2007 12:38:27

Hallo community!

Habe eine Frage bezüglich Excel hoffe, das ich hier richtig bin.

Also ich habe eine Tabelle in der Postleitzahlen stehen und eine andere Tabelle in der z.B.

Niederlassung Leipzi
39000-39999
01000-04999
06000-09999
98000-99999

jetzt soll er in der ersten tabelle die PLZ nehmen und in diesen bereichen suchen jetzt ist meine frage wie bekomme ich das hin?? Muss ich ein makro schreiben oder gibt es da eine formel.

Liebe Grüße LOLIe

  

Betrifft: AW: PLZ BEREICH von: Peter
Geschrieben am: 01.10.2007 13:02:27

Hallo Lolie,

trenne die PLZ auf 2 Felder, wie in anhängender Datei.
https://www.herber.de/bbs/user/46462.xls

Gruß, Peter


  

Betrifft: AW: PLZ BEREICH von: fcs
Geschrieben am: 01.10.2007 13:41:05

Hallo Lolie,

da es Lücken in den PLZ-Bereichen gibt, geht nur wenn du die Daten etwas aufbereitest.

1. Sortiere die PLZ-Bereiche aufsteigend
2. Trenne die PLZ-Bereiche via Menü Daten - Text in Spalten so auf, dass in den Nachbarspalten jeweils die 1. bzw. Letzte PLZ des Bereichs steht, dabei das Format der Spalten im Assistenten von Standard auf Text einstellen.

Sollte dann etwa so aussehen:

Tabelle1:
A          	B    	C    
Niederlassung Leipzi		
01000-04999	01000	04999
06000-09999	06000	09999
39000-39999	39000	39999
98000-99999	98000	99999


Mit folgender Formel kannst du dann die PLZ den Bereichen zuordnen:


Formel in B2: =WENN(SUMMENPRODUKT((Tabelle2!A2>=Tabelle1!$B$2:$B$5)*
 (Tabelle2!A2<=Tabelle1!$C$2:$C$5)*1)>0;INDEX(Tabelle1!$A$2:$A$5;
 VERGLEICH(TEXT(WERT(A2)+1;"00000");Tabelle1!$A$2:$A$5;1);1);"")
Die Formel muss du als Matrix-Formel eingeben. 
(Eingabe mit Tastenkombination Strg+Shift+Enter abschließen.)
Die Formel kannst du dann nach unten kopieren.
Ergebnis in Tabelle2; die Spalte mit der PLZ muss adabei als text formatiert sein.
A  	B
PLZ	Bereich
01000	01000-04999
28000	
39001	39000-39999
44000	
07000	06000-09999


Gruß
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "PLZ BEREICH "