Microsoft Excel

Herbers Excel/VBA-Archiv

Addieren nach Kalenderwoche

Betrifft: Addieren nach Kalenderwoche von: edie
Geschrieben am: 04.10.2007 07:56:28

Hallo Zusammen,

zu dem Datum in Spalte A und deren Kalenderwoche in
Spalte B sollen die Werte aus Spalte C entsprechend
je Kalenderwoche in Spalte D summiert werden.

Wäre schön wenn die Summe in der Zeile
berechnet wird, immer zu Beginn der Kalenderwoche.

Habe leider keinen Lösungsansatz, für die Hilfe wäre
ich sehr dankbar.

Zunächst die Beispiel-Datei zur Besseren Übersicht:

https://www.herber.de/bbs/user/46518.xls

Kann mir jemand Helfen?

Vielen Dank im Voraus.

Grüße

  

Betrifft: AW: Addieren nach Kalenderwoche von: serge
Geschrieben am: 04.10.2007 08:10:33

Hallo Edie
probier es mit =WENN(B3<>B2;SUMMEWENN(B:C;B3;C:C);"") in D3 und runterkopieren!
Serge


  

Betrifft: AW: Addieren nach Kalenderwoche von: edie
Geschrieben am: 04.10.2007 08:32:30

Hallo serge,

es funktioniert, tausend mal Danke.

Grüße


  

Betrifft: KW Formel von: serge
Geschrieben am: 04.10.2007 08:52:15

Übrigens KW kannst Du mit:
=KÜRZEN((A3-WOCHENTAG(A3;2)-DATUM(JAHR(A3+4-WOCHENTAG(A3;2));1;-10))/7) ersetzen in B3 und runterkopieren
Serge


  

Betrifft: AW: KW Formel von: edie
Geschrieben am: 04.10.2007 09:23:23

Hallo Serge,

das ist toll, Vielen Dank.

Grüße


 

Beiträge aus den Excel-Beispielen zum Thema "Addieren nach Kalenderwoche"